2

I want to implement authentication on EIGRP updates.

Can I enable EIGRP authentication on a GRE tunnel interface instead of physical interface?

1 Answer 1

4

Yes, you can do that. Below is an example:

Router-A#
!
key chain Netlab
 key 13
   key-string Netlabbuilder
!
interface Tunnel1
 description Site-B
 ip address 10.99.99.1 255.255.255.252
 ip mtu 1400
 ip authentication mode eigrp 10 md5
 ip authentication key-chain eigrp 10 Netlab
 ip tcp adjust-mss 1360
 cdp enable
 tunnel source 13.1.87.2
 tunnel destination 10.12.85.2
end
!
Router-A#show ip eigrp neighbors tunnel 1
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   10.99.99.2              Tu1               13 00:04:38   54  5000  0  17

#####

Router-B#
!
key chain Netlab
 key 13
   key-string Netlabbuilder
!
interface Tunnel1
 description Site-A
 ip address 10.99.99.2 255.255.255.252
 ip mtu 1400
 ip authentication mode eigrp 10 md5
 ip authentication key-chain eigrp 10 Netlab
 ip tcp adjust-mss 1360
 cdp enable
 tunnel source 10.12.85.2
 tunnel destination 13.1.87.2
end
!
Router-B#show ip eigrp neighbors tunnel 1
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.99.99.1              Tu1               13 00:05:55  212  5000  0  10
1
  • @Fahad Glad that I could help and you are always welcome!
    – Hung Tran
    Mar 21, 2018 at 8:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.