1

I picked up an 1861 for cheap and I am trying to set it up for home lab. I have taken the Cisco courses for CCNP and I think if this was just a regular router or switch I would be OK, but I can't seem to be able to make the switched ports work with the router port.

I am trying to connect the external cable modem to F0/0. I have it set for DHCP to get IP from the cable company.

Hosts would be connected to the switched ports, including my server which is providing DHCP on the home network.

My sense is that I want to set up PAT overflow with F0/0 as NAT outside, but I can't figure out how to make everything else NAT inside. Or maybe I am not even going in the right direction?

LAN is 192.168.1.1/24 Cable company next hop is 65.175.185.1

ip source-route
ip cef
!
!
!
!
!
no ip domain lookup
ip domain name larsson.local
no ipv6 cef
!
multilink bundle-name authenticated
!
!
interface Loopback0
 ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 99
!
interface FastEthernet0/1/1
 switchport access vlan 99
!
interface FastEthernet0/1/2
 switchport access vlan 99
!
interface FastEthernet0/1/3
 switchport access vlan 99
!
interface FastEthernet0/1/4
 switchport access vlan 99
!
interface FastEthernet0/1/5
 switchport access vlan 99
!
interface FastEthernet0/1/6
 switchport access vlan 99
!
interface FastEthernet0/1/7
 switchport access vlan 99
!
interface FastEthernet0/1/8
 switchport access vlan 99
!
interface Vlan1
 no ip address
!
router ospf 99
!
ip default-gateway 65.175.150.164
ip forward-protocol nd
ip http server
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
logging esm config
ipv6 route ::/0 FastEthernet0/0
!
!

Any help is appreciated.

3
  • Please edit your question to include the router configuration that you have.
    – Ron Maupin
    Mar 30, 2018 at 14:22
  • 1
    If you completed CCNP, you should be able to do this with your eyes closed.
    – Ricky
    Mar 30, 2018 at 19:54
  • Oops! I should probably know anyway, but I took the courses for CCNA, not CCNP. Mar 30, 2018 at 20:54

1 Answer 1

1
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ipv6 route ::/0 FastEthernet0/0

Never do that. That's proxy-arp. Too many people do that with zero clue what it actually means... that's not a dialup interface that needs to be forced up.

router ospf 99

Who are you exchanging routes with? You don't need OSPF running. And for that matter, you don't need to have all the switch interfaces in vlan 99.

ip default-gateway 65.175.150.164

This is a host-mode command. It does nothing on a router.

First, ensure routing is enabled: ip routing (it's a default, so won't normally show in the config) Second, enumerate the inside and outside interfaces, and what should be natted:

int f0/0
  ip nat outside
int vlan99
  ip address 192.168.1.1 255.255.255.0
  ip nat inside
!
ip nat inside source list nat-acl interface f0/0 overload
!
ip access-list standard nat-acl
  permit 192.168.1.0 0.0.0.255

And then configure DHCP:

ip dhcp pool lan
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   domain-name my-domain.local
   dns-server 8.8.8.8 8.8.4.4
   lease 0 1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.