2

I'm attempting to set up a network with 3 Routers.

A "West" and "East" router are each connected to a "Central" router via a PA-4T+ serial interface. The first interface (s1/0) on the Central is given IP 20.0.0.1, whereas s1/2 is given 20.0.0.2. s1/0 on the West router is given IP 20.0.0.3 and is connected to s1/0 on the Central.

s1/0 on the East is given IP 20.0.0.4 and is connected to s1/1 on Central. When I ping West from Central or vice versa everything works fine, whereas when I do the same for East, I get no response.

I am making sure to run the "no shutdown" directive on each interface and add the network 20.0.0.0 to the routing engine on each router.

East Config:

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname East
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
! 
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface Serial1/0
 ip address 20.0.0.4 255.0.0.0
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router rip
 network 20.0.0.0
!
!
no ip http server
no ip http secure-server
!
!
no cdp log mismatch duplex
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

Central:

!
!
!
!
!
!
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Central
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$5lB2$4S/AyQOavlPIFAAThGJGM1
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
! 
!
!
!
!
interface FastEthernet0/0
 ip address 10.1.1.1 255.0.0.0
 duplex half
!
interface Serial1/0
 ip address 20.0.0.1 255.0.0.0
 serial restart-delay 0
!
interface Serial1/1
 ip address 20.0.0.2 255.0.0.0
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router rip
 network 10.0.0.0
 network 20.0.0.0
!
!
no ip http server
no ip http secure-server
!
!
no cdp log mismatch duplex
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

West:

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname West
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
! 
!
!
!
!
interface FastEthernet0/0
 ip address 10.1.1.2 255.0.0.0
 duplex half
!
interface Serial1/0
 ip address 20.0.0.3 255.0.0.0
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router rip
 network 10.0.0.0
 network 20.0.0.0
!
!
no ip http server
no ip http secure-server
!
!
no cdp log mismatch duplex
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end
  • You need to edit your question to include the router configurations. We cannot guess where you went wrong. – Ron Maupin Apr 5 '18 at 22:19
  • I fixed it for you, but simply paste the text into the question and use the Preformatted-text option ({}). – Ron Maupin Apr 5 '18 at 22:44
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Dec 25 '18 at 8:12
1

You problem is that you only have one network. Routers route between networks, not from a network back to the same network. You need a separate network between the routers. Usually you will have a /30 or /31 network as a point-to-point network between two routers.

You also need to let each of the routers know how to get to any networks to which they are not directly connected. That can be done with static routes or by sharing a routing protocol.

Try something like this:

East:

interface Serial1/0
 ip address 20.0.0.1 255.255.255.252
!
router rip
 version 2
 no auto-summary
 network 20.0.0.0
!

Central:

interface Serial1/0
 ip address 20.0.0.5 255.255.255.252
 serial restart-delay 0
!
interface Serial1/1
 ip address 20.0.0.2 255.255.255.252
 serial restart-delay 0
!

router rip
 version 2
 no auto-summary
 network 20.0.0.0
!

West:

interface Serial1/0
 ip address 20.0.0.6 255.255.255.252
!
router rip
 version 2
 no auto-summary
 network 20.0.0.0
!

You also have a problem on the ethernet interfaces of the Central and West because they have the same network. You will need to pick separate networks for those, too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.