2

What is the requirement for CHAP authentication on a PPP interface? I thought both routers had to have the same password defined, such as below.

r1> username r2 password demo
r2> username r1 password demo

However, in a packet tracer example the following config is specified.

!!!! Script for R1 !!!!
username ISP password cisco123
interface s0/0/0
encapsulation ppp
ppp authentication chap
interface tunnel0
tunnel mode gre ip
ip address 192.168.2.1 255.255.255.0
tunnel source s0/0/0
tunnel destination 198.133.219.86


!!!! Script for R2 !!!!
en
conf t
username ISP password 123cisco
interface s0/0/0
encapsulation ppp
ppp authentication chap
interface tunnel0
tunnel mode gre ip
ip address 192.168.2.2 255.255.255.0
tunnel source s0/0/0
tunnel destination 209.165.201.1

Is it okay for each router to specify their own password?

r1> username r2 password demo2
r2> username r1 password demo1
3
  • 1
    The username (and password) you send does not have to be the same as what you receive.
    – Ricky
    Apr 21, 2018 at 20:08
  • @RickyBeam thank you very much for the clarification
    – dcrearer
    Apr 22, 2018 at 16:07
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer.
    – Ron Maupin
    Dec 25, 2018 at 8:21

1 Answer 1

1

The username and password sent by router 1 doesn’t have to be the same as what is received from router 2. @RickyBeam thanks for the feedback.

!!!! Script for R1 !!!!
username ISP password cisco123
interface s0/0/0
encapsulation ppp
ppp authentication chap
interface tunnel0
tunnel mode gre ip
ip address 192.168.2.1 255.255.255.0
tunnel source s0/0/0
tunnel destination 198.133.219.86


!!!! Script for R2 !!!!
en
conf t
username ISP password 123cisco
interface s0/0/0
encapsulation ppp
ppp authentication chap
interface tunnel0
tunnel mode gre ip
ip address 192.168.2.2 255.255.255.0
tunnel source s0/0/0
tunnel destination 209.165.201.1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.