5

I want to configure OSPF on the topology below. The problem is when I connect two routers to each other and when I config one router to area 0 and another one to area 1, they don't see each other as neighbors. So I cannot ping from one to another. I red Cisco docs and did some other labs and I know how to configure OSPF for different areas, but not this one. I got this error :

%OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbone area must be virtual-link but not found from 192.168.12.1, FastEthernet0/0

Can someone explain me why we should use different areas for two routers which their interfaces are directly connected? And what I should do to config?
Thank you all and Sorry for bad English.

network topology

And here is my configuration for there routers on this IOS c3640-jk9s-mz.124-16.image:

R1

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Tarna
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 duplex auto
 speed auto
!
!
router ospf 1
 log-adjacency-changes
 network 192.168.12.0 0.0.0.255 area 0
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R2

Current configuration : 1419 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Spielburg
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0
 duplex auto
 speed auto
!
!
router ospf 1
 log-adjacency-changes
 network 192.168.12.0 0.0.0.255 area 1
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
8
  • I got mentioned error every 10 seconds. So I think it's related to Hello packets. Apr 26, 2018 at 12:46
  • 4
    It's not really the routers that are in areas, it is the interfaces, and two connected interfaces must be in the same area. The network statements tell OSPF which interfaces are in which areas. The two connected interfaces could be in Area 0, then any other interfaces on the routers (including loopbacks) can be in other areas.
    – Ron Maupin
    Apr 26, 2018 at 14:49
  • As you said, "two connected interfaces must be in the sare area" and I know this is the correct idea But my teacher wants me to put them in different areas. So I don't know what should I do. Apr 26, 2018 at 19:26
  • 1
    You would need to create a virtual link. I suppose the exercise is for you to understand virtual links.
    – Ron Maupin
    Apr 26, 2018 at 19:34
  • 1
    That is a poor design that should avoided if at all possible. If you end up with connected interfaces in different areas, you really need to step back and redesign the network. I would consider the use of virtual links to be a temporary fix.
    – Ron Maupin
    Apr 26, 2018 at 20:11

3 Answers 3

8

In order to connect two areas, one router has to serve as an area border router (ABR). That router has interfaces in both areas. In other words, the boundary between two areas is a router, not the link between two routers.

In your example, you could configure R1 so that interface f0/0 is in area 1, while the other interfaces are in area 0. That will make R1 the ABR for area 1.

2
  • As I explained for @ron-maupin, I have to put the connected interfaces into different areas. As you said, I can use other interfaces for other areas. So I cannot put two connected interfaces into different areas. Is this true? Apr 26, 2018 at 19:28
  • 1
    Thats correct. Directly attached interfaces must be in the same area. Apr 26, 2018 at 20:30
3

To exchange routes in this topology you don't need two areas.

A two-router setup would be best configured in a single area. Best practice is to configure them both in area 0, but if it's going to remain a single-area design you can use whatever area number you like.

Try a configuration like this:

R1

router ospf 1
network 192.168.12.0 0.0.0.255 area 0

R2

router ospf 1
network 192.168.12.0 0.0.0.255 area 0
1
  • Thanks for you answer. I did it for my previous lab. but this is my new challenge and I don't know how to do that. And I know we don't need two areas, but my question is can we config above topology with two areas? Apr 26, 2018 at 19:31
1

Area 0 is the backbone area and thus always required for communication between other areas. If you don't have 2 routers within the same area you won't have adjacency either. You should configure both routers with the same area so they have the same subnet configured. After that you can add other areas or other networks to area x. So your topology will not work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.