1

Topology Diagram

I am new in VLANs , im currently trying to complete this topology however i can see the following errors on all the three switches: EX:

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/2 (1), with S3 FastEthernet0/2 (99).

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/1 (1), with S2 FastEthernet0/1 (99).

The used configuration is : S2:

int fa0/1
switchport mode trunk
switchport trunk native vlan 99
 int range fa0/1-5
switchport mode access
switchport access vlan 99
no shutdown
exit
int range fa0/6-10
switchport mode access
switchport access vlan 30
no shutdown
exit
int range fa0/11-17
switchport mode access
switchport access vlan 10
no shutdown
exit
int range fa0/18-24
switchport mode access
switchport access vlan 20
no shutdown
exit

S1:

int range fa0/1-2
switchport mode trunk
switchport trunk native vlan 99

S3:

int fa0/2
switchport mode trunk
switchport trunk native vlan 99
int range fa0/1-5
switchport mode access
switchport access vlan 99
no shutdown
exit
int range fa0/6-10
switchport mode access
switchport access vlan 30
no shutdown
exit
int range fa0/11-17
switchport mode access
switchport access vlan 10
no shutdown
exit
int range fa0/18-24
switchport mode access
switchport access vlan 20
no shutdown
exit

the vlans created on all switches are:

vlan 99
name management
vlan 30
name Guest(Default)
vlan 10
name Faculty/Staff
vlan 20
name Students

can any one help me to know what the possible mistake may be?

8
  • You need to include the switch configurations in your question. – Ron Maupin Apr 29 '18 at 14:34
  • can you help me now? @RonMaupin – zahra marhoon Apr 29 '18 at 14:47
  • Please edit your question to include the full configurations of the switches, and use the Preformatted-text option ({}) so we can read it correctly. Simply show the configurations in you terminal applications, copy them, paste them into the question, and use the Preformatted-text option on them. – Ron Maupin Apr 29 '18 at 14:49
  • 1
    It would aslo help to have the results of the show cdp neighbor command. – Ron Maupin Apr 29 '18 at 14:52
  • 2
    Your range fa0/1-5 includes your trunk ports... so you first configure them as trunk but then change them back to access ports – hertitu Apr 29 '18 at 22:44
2

Your interface range commands on S2 and S3 are overwriting the trunk commands you had just inputted. Make sure you verify before inputting that the range doesn't include a pre-configured port, or you'll just continually overwrite them.

1

Native VLAN means - untagging a vlan 99 details, so that if a frame is being transferred to other switch, the receiving end switch will not have your native vlan details, means it's not tagging your vlan details to the frame.

In your scenario -

Switch 1 configuration is fine.

But Switch 2 interface fa0/1 connected to SW1 fa0/1 should be configured with switchport mode trunk, switchport trunk native vlan 99, you have configured like interface range fa0/1-5 under access mode but not trunk.

Similarly for Switch 3 interface fa0/2 connected to SW1 fa0/2 should be configured with switchport mode trunk, switchport trunk native vlan 99.

The problem is you have configured SW2 and SW3 interfaces which is connected to SW1 is in access mode. Make is as trunk mode and then set the native vlan command. Hope this clarifies your doubt.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.