2

I've a server process and a client process running on my machine. To capture the packets transmitted between them, I've installed the Npcap Loopback Adapter as suggested in the ever-so-famous Wireshark Loopback link. I've successfully installed the latest version of Npcap, 0.99-r4. On selecting the network adapter in the Wireshark capture options, and pinging 127.0.0.1 (from the same machine, obviously), nothing shows up in the capture results. Can anyone point out what I'm missing or where I've gone wrong?

What I've tried:

  • There's a field in the Network Adapter Driver options of Npcap called Network address. Initially, it was empty. I entered 127.0.0.1 first but it didn't work. Because it says NETWORK address, i tried entering 127.0.0.0 as a silly attempt. That didn't work either.
  • On running the command ipconfig /all, the results for Npcap Network Adaptor seemed not-wrong to me. Here's a snapshot: ipconfig /all output
  • All my other adapters are working just fine. I think its worth mentioning this.

Any kind of help would be appreciated. I couldn't find any source addressing an issue like this. There're none as far as my googling abilities go. Thanks in advance!

  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Dec 25 '18 at 8:19
1

The IP you see from CMD (the 169.254.. one) is useless, You don't need to care about it. See how Npcap Loopback Adapter is implemented: https://nmap.org/npcap/guide/npcap-devguide.html#npcap-feature-loopback

For your question, you should report bugs based on instructions here: https://nmap.org/npcap/guide/npcap-issues.html

IMO, you can install an older version, like Npcap 0.80 to see if the problem persists. Use a bisect way.

  • That is not a "fake" IP address; it is real, Link-Local, IP address address. A fake address is one with a number > 255 in an octet. – Ron Maupin May 1 '18 at 9:33
  • @RonMaupin thanks. I have improved the wording. – Yang Luo May 2 '18 at 5:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.