3

On GNS3 I have developed the following network:

enter image description here

The enp2s0f2 is my own computer network interface.

The router R1 configuration is shown below:

R1#show running-config 
Building configuration...

Current configuration : 1077 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool INTERNAL-CLIENT
   network 172.17.0.0 255.255.255.0
   default-router 172.17.0.1 
   dns-server 1.1.1.1 
!
!
ip name-server 1.1.1.1
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!         
ip tcp synwait-time 5
!
!
!
interface FastEthernet0/0
 ip address dhcp
 ip nat outside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.17.0.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
!
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 permit 172.17.0.0 0.0.0.255
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R1#

On PC-1 I have:

PC-1> show ip all

NAME   IP/MASK              GATEWAY           MAC                DNS
PC-1   172.17.0.2/24        172.17.0.1        00:50:79:66:68:00  1.1.1.1

On router R1, I have:

R1#show ip interface brief 
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.10.166  YES DHCP   up                    up      
FastEthernet0/1            172.17.0.1      YES NVRAM  up                    up      
NVI0                       unassigned      NO  unset  up                    up      
R1#

On my physical computer I have:

$ ip address 
1: lo:  mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp2s0f2:  mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 70:4d:7b:3a:6e:2c brd ff:ff:ff:ff:ff:ff
    inet 192.168.10.231/16 brd 192.168.255.255 scope global dynamic enp2s0f2
       valid_lft 343522sec preferred_lft 343522sec
    inet6 fe80::f39e:90d0:970:b350/64 scope link 
       valid_lft forever preferred_lft forever
3: wlp3s0:  mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 94:e9:79:2a:34:23 brd ff:ff:ff:ff:ff:ff

The point which I don't understand is that, on PC1, I can ping the google.com, 192.168.10.254 (gateway of my physical network) and 192.168.10.166 (IP of R1 interface), however I can NOT ping the 192.168.10.231 which is the IP of my physical computer which has the interface enp2s0f2, like below:

PC-1> ping google.com
google.com resolved to 172.217.21.238
84 bytes from 172.217.21.238 icmp_seq=1 ttl=46 time=211.381 ms
84 bytes from 172.217.21.238 icmp_seq=2 ttl=46 time=151.149 ms
84 bytes from 172.217.21.238 icmp_seq=3 ttl=46 time=139.226 ms
84 bytes from 172.217.21.238 icmp_seq=4 ttl=46 time=171.411 ms
84 bytes from 172.217.21.238 icmp_seq=5 ttl=46 time=201.004 ms

PC-1> ping 192.168.10.254
84 bytes from 192.168.10.254 icmp_seq=1 ttl=63 time=14.656 ms
84 bytes from 192.168.10.254 icmp_seq=2 ttl=63 time=29.997 ms
84 bytes from 192.168.10.254 icmp_seq=3 ttl=63 time=23.611 ms
84 bytes from 192.168.10.254 icmp_seq=4 ttl=63 time=29.338 ms
84 bytes from 192.168.10.254 icmp_seq=5 ttl=63 time=29.783 ms

PC-1> ping 192.168.10.166
84 bytes from 192.168.10.166 icmp_seq=1 ttl=255 time=2.785 ms
84 bytes from 192.168.10.166 icmp_seq=2 ttl=255 time=9.686 ms
84 bytes from 192.168.10.166 icmp_seq=3 ttl=255 time=10.499 ms
84 bytes from 192.168.10.166 icmp_seq=4 ttl=255 time=9.364 ms
84 bytes from 192.168.10.166 icmp_seq=5 ttl=255 time=11.252 ms

PC-1> ping 192.168.10.231
192.168.10.231 icmp_seq=1 timeout
192.168.10.231 icmp_seq=2 timeout
192.168.10.231 icmp_seq=3 timeout
192.168.10.231 icmp_seq=4 timeout
192.168.10.231 icmp_seq=5 timeout

PC-1> 

I couldn't understand why I cannot ping my physical computer from within the virtual PC-1 inside GNS3. Also, I cannot ping the router R1 interface from within the physical computer:

$ ping 192.168.10.166
PING 192.168.10.166 (192.168.10.166) 56(84) bytes of data.
From 192.168.10.231 icmp_seq=1 Destination Host Unreachable
From 192.168.10.231 icmp_seq=2 Destination Host Unreachable
From 192.168.10.231 icmp_seq=3 Destination Host Unreachable
From 192.168.10.231 icmp_seq=4 Destination Host Unreachable
From 192.168.10.231 icmp_seq=5 Destination Host Unreachable
From 192.168.10.231 icmp_seq=6 Destination Host Unreachable

Here is my routing table on the physical computer:

$ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.10.254  0.0.0.0         UG    20100  0        0 enp2s0f2
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 enp2s0f2
192.168.0.0     0.0.0.0         255.255.0.0     U     100    0        0 enp2s0f2
3

Since you can ping PC-1 from the physical PC (PH) but not vice versa, the most logical explanation is that PH doesn't reply to echo requests (firewall, filtering, ...).

Edit after your added PH's routing table:

On PH, you need to add a route 172.17.0.0/24-> 192.168.10.166. Otherwise the default gateway 192.168.10.254 is used, leading somewhere completely else...

  • To my surprise, from within my physical computer, I can ping 172.17.0.3, which I don't have such an IP on my GNS3 network. I think there is actually a network in our company with 172.17.0.0/24, I'm not sure. – user4838962 May 6 '18 at 9:19
  • Check the routing table on PH - you've not given any details in your question. You can't use the same subnets twice. – Zac67 May 6 '18 at 9:21
  • I added the routing table on physical device to my question. There is no mention of 172.17.0.0/24 network on routing table. – user4838962 May 6 '18 at 10:05
  • ... and this is the exact problem. – Zac67 May 6 '18 at 10:10
  • So I guess the reason that the virtual PC-1 cannot ping my physical computer is this: the routing between the virtual router R1 and physical router is not being done. Am I right? – user4838962 May 6 '18 at 10:34
0

I found an answer on a GNS3 discussion which is related to this question:

enter image description here


Basically, the physical device and the virtual devices on GNS3 are using the same NIC. Therefore, they are all using the same MAC address on the LAN. They cannot ping each other because of the way ARP and broadcasts work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.