1

Im trying to share info between two vtp servers these vtp server are connected using Etherchannel I have configured both on server mode, using the same domain and password, but the right one is not getting information from VTP SERVER 1 (Left) Etherchannel is working, all their ports are already in trunk mode

I can't notice if im missing something.

VTP SERVER 1 (LEFT) CONFIGURATION

S1#show running-config 
Building configuration...

Current configuration : 913 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S1
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface Port-channel1
!
interface GigabitEthernet0/1
!
interface GigabitEthernet1/1
 switchport mode trunk
 channel-group 1 mode active
!
interface GigabitEthernet2/1
 switchport mode trunk
 channel-group 1 mode active
!
interface GigabitEthernet3/1
 switchport mode trunk
 channel-group 1 mode active
!
interface GigabitEthernet4/1
 switchport mode trunk
 channel-group 1 mode active
!
interface GigabitEthernet5/1
 switchport mode trunk
!
interface GigabitEthernet6/1
 switchport mode trunk
!
interface GigabitEthernet7/1
!
interface GigabitEthernet8/1
!
interface GigabitEthernet9/1
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
end

VTP SERVER 2 (RIGHT) CONFIGURATION

S2#show running-config 
Building configuration...

Current configuration : 867 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S2
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface Port-channel1
!
interface GigabitEthernet0/1
!
interface GigabitEthernet1/1
 switchport mode trunk
 channel-group 1 mode active
!
interface GigabitEthernet2/1
 switchport mode trunk
 channel-group 1 mode active
!
interface GigabitEthernet3/1
 switchport mode trunk
 channel-group 1 mode active
!
interface GigabitEthernet4/1
 switchport mode trunk
 channel-group 1 mode active
!
interface GigabitEthernet5/1
!
interface GigabitEthernet6/1
!
interface GigabitEthernet7/1
!
interface GigabitEthernet8/1
!
interface GigabitEthernet9/1
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
end

VTP SERVER 1 SHOW VTP STATUS

S1#show vtp status 
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 255
Number of existing VLANs        : 11
VTP Operating Mode              : Server
VTP Domain Name                 : ccna
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x4A 0xB4 0xC6 0x2E 0xB9 0x70 0x21 0x58 
Configuration last modified by 0.0.0.0 at 3-1-93 00:07:42
Local updater ID is 0.0.0.0 (no valid interface found)

VTP SERVER 2 SHOW VTP STATUS

S2#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 255
Number of existing VLANs        : 5
VTP Operating Mode              : Server
VTP Domain Name                 : ccna
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x24 0x66 0x6C 0x45 0x8F 0xDE 0x06 0xEB 
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Local updater ID is 0.0.0.0 (no valid interface found

This is my enviroment

Thank you.

6
  • Please edit your question to include the switch configurations, and also, please never use all caps (your title).
    – Ron Maupin
    May 10 '18 at 23:59
  • My apologies, im new in this forum. I will fix my post May 11 '18 at 0:01
  • I fixed the title, but please copy your configurations and paste into the question as text, using the Preformatted-text option ({}). There are a few things that could be wrong, but we cannot guess. We can see it in your configurations.
    – Ron Maupin
    May 11 '18 at 0:05
  • I have edited my post, is it enough information to make a diagnostic? May 11 '18 at 0:19
  • I don't see where you have defined the channel interface as a trunk or any VLANs. You should include the full configurations, but obfuscate any passwords or public addresses. Also, the results of the show vtp status command on each switch could be very useful.
    – Ron Maupin
    May 11 '18 at 0:22
2

OK. You have a couple of problems.

First, you need to make sure that the channel is a trunk. VTP only works on trunks. On both switches:

interface Port-channel1
 switchport mode trunk
!

Next, you really do not have the same VTP password on both switches. You can tell this because the MD5 hash is different on each switch:

Switch 1:

MD5 digest                      : 0x4A 0xB4 0xC6 0x2E 0xB9 0x70 0x21 0x58 

Switch 2:

MD5 digest                      : 0x24 0x66 0x6C 0x45 0x8F 0xDE 0x06 0xEB

You can verify the passwords on each switch with the show VTP password command. Remember that something like a space at the start or end of the password actually counts as part of the password, even though you cannot see it. The best way to make sure the passwords are the same is by copying the password text from Notepad (or whatever text editor), and pasting it in on both switches so that you know for sure it is the same. When you have the same password on both, the MD5 hashes will match.

3
  • I did the vtp configuration in a notepad before, it is weird because it still giving me a diferent hash. May 11 '18 at 0:48
  • Interesting fact, I change the vtp mode to client in Switch 2 and it worked, but it is not what i was looking for May 11 '18 at 0:52
  • @JoséC.ArbildoLópez, you could always run the debug. See this question and answer.
    – Ron Maupin
    May 11 '18 at 0:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.