3

I have 2 HP 2920 switches and they aren't stacking as I'm expecting.
Both models are the J9729A, however one is Aruba branded and one is the original HP brand. Everywhere I read this shouldn't be an issue, and the Aruba rebrand was simply that - a rebrand with no technical change.

Both switches are detecting the stacking module in the rear - both have the module light lit. However there doesn't appear to be a link between the switches as the port 1 and/or port 2 lights are not lit. As well running show stacking detail shows both ports as inactive. I've tried connecting the stacking ports in all combinations 1>1 , 1>2 , 2>1 and 2>2.

Stacking is enabled on both, and I've tried following the procedures here with no luck. http://h22208.www2.hpe.com/eginfolib/networking/docs/switches/WB/15-18/5998-8156_wb_2926_atmg/content/ch06s02.html

I've tried firmwares 16.03.0003, 16.03.0007, and 16.05.0007 (Latest).

I've now tried doing an erase all and stacking factory-reset on both, then powered on one switch fully, entered stacking set-stack, then the other. Still not detecting the link and both switches are acting as their own Commander.

Do you have any idea what could be going on here?

  • Sounds like the cable is bad - have you tried another one? I think they are standard SFF-8614/8644 cables like the ones used for SAS. – Zac67 May 22 '18 at 10:50
  • Had that thought as well, and I'm currently getting another one sent. I hope that's it - will update with my findings once received. – Huckleberry Finn May 22 '18 at 10:54
  • Can you share the information from show stacking stack-ports? – Roger Sanghee Gold May 23 '18 at 10:56
  • @Roger So executing that was showing both ports as Down. After replacing the cable it's working as expected, both ports showing up on both switches. – Huckleberry Finn May 23 '18 at 12:38
2

This was due to either a faulty or incompatible cable

The cable which I was having trouble with has Amphenol branding on it and part number;
HP P/N: 691970-001 REV G

The cable which is working is HP branded and has the J9735A Part Number on it.

  • You should accept your answer so that the question doesn't keep popping up forever, looking for an answer. – Ron Maupin May 23 '18 at 12:53
  • @Ron Will do in 20hrs - when I'm allowed. – Huckleberry Finn May 23 '18 at 12:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.