0

20I have a server with a static IP address connected to a Comcast Business router (Cisco DPC3941B).

I also have a second machine directly connected to the same router. It gets assigned a NAT address 10.x.x.x.

When the second machine connects to the server (or vice versa) I get very slow performance. For example, if I do an RDP connection from the second machine to the server, the screen draw is unbearably slow. Similarly, an HTTP connection from the second machine to the server (via a browser) is noticeably slow.

However, when connecting to the server from an outside network, everything seems fine. No unusual delays or performance problems.

The exact same set up with a different router (a Motorola one) did not have this problem.

Is this a problem/limitation with this router? Why? Is it the translation over the NAT? Why is that so slow?

Or is it something about my set up? Could I have misconfigured something on the server or router?

Any suggestions for debugging/diagnosing?


EDIT 27 May 2018: Added config settings

ROUTER CONFIG
Router is set to defaults/factory settings except for what Comcast 
did to set up the static IP address, etc. Settings as follow:

Bridge Mode: Disabled
WiFi: Enabled (but not used)
DOCSIS Software Version: dpc3941b-v303r20421762-180419a-CMCST
Model: DPC3941B
Vendor: Cisco
Hardware Revision: 1.0
Processor Speed: 447.28 MHz
DRAM: 1048576 MB
Flash: 128 MB

Firewall
Disable Firewall for True Static IP Subnet Only: OFF
Disable Gateway Smart Packet Detection: ON
Disable Ping on WAN Interface: OFF

Firewall Security Level: Minimum
LAN-to-WAN: Allow all
WAN-to-LAN: Block IDENT (port 113)

Local IP Network
IP Address (IPv4): 10.1.10.1
Subnet mask: 255.255.255.0
DHCPv4 Server: Enabled
DHCPv4 Lease Time: 7d:0h:0m
Link Local Gateway Address (IPv6): fe80::481d:70ff:fede:dcc8
Global Gateway Address (IPv6): 2603:3024:1705:3c00:481d:70ff:fede:dcc8
Delegated prefix: 2603:3024:1705:3c00::/56
DHCPv6 Lease Time: 7d:0h:0m
IPV6 DNS: 2001:558:feed::1

WAN Network
Internet:Active
Local time:2018-05-26 14:11:06
System Uptime: 4 days 16h: 56m: 42s
WAN IP Address (IPv4): 50.242.89.126
WAN Default Gateway Address (IPv4): 24.5.176.1
WAN IP Address (IPv6): 2001:558:6045:bf:31e4:2d63:9158:8238
WAN Default Gateway Address (IPv6): fe80::201:5cff:fe65:4c46
Delegated prefix (IPv6): 2603:3024:1705:3c00::/56
Primary DNS Server (IPv4): 75.75.75.75
Secondary DNS Server (IPv4):75.75.76.76
Primary DNS Server (IPv6):2001:558:feed::1
Secondary DNS Server (IPv6):2001:558:feed::2
WAN Link Local Address (IPv6): fe80::4a1d:70ff:fede:dcc7
DHCP Client (IPv4):Enabled
DHCP Client (IPv6): Enabled
DHCP Lease Expire Time (IPv4): 2d:10h:53m
DHCP Lease Expire Time (IPv6): 2d:17h:59m

Managed Sites: Disabled
Managed Services: Disabled
Managed Devices: Disabled
Port Forwarding: Disabled
Port Triggering: Disabled
True Static IP Port Management: Disable all rules and allow all
   inbound traffic through
Remote Management: Disabled
DMZ: Disabled
NAT: Disable All
Static Routing: None
Dynamic DNS: Disabled
Device Discovery: Disabled

EDIT 27 May 2018 This might be relevant: Email not delivered over local wifi, delivered all other times

Perhaps the Cisco router does not support Hairpinning? But wouldn't that result in NO connection as opposed to a slow connection?

  • You need to edit your question to provide more information. For example, what is the router configuration? See the Network Engineering Question Checklist for guidance, then edit your question to give us enough information to help. – Ron Maupin May 26 '18 at 21:01
  • @RonMaupin: Thank you. I've added configs. Please let me know if there is anything else that would be helpful. – George Moromisato May 27 '18 at 15:08
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Dec 25 '18 at 8:30
0

The firewall for static IP must be on when you have a static IP, it keeps the modem from handling that traffic. You need to call in to Care and have them roll back the firmware on your modem to one that doesn't have an issue with local loopback. It will go the Engineers that handle that and then you are good to go. You will be put on a list to not receive any firmware upgrades and if you factory reset the modem, you get to do it all over again.

0

Assuming the "server" is located in your network, accessing the router by the public address requires hairpinning: a client's packet is first source NATed, then destination NATed by port forwarding/reverse NAT. That can be slow on some routers, doesn't work at all on others, and it's generally very inefficient.

When both client and server are located on the same private network, NAT is only a burden. A better solution is to access the server by its private address directly.

The easiest way to do that is to set up split-brain DNS: on your DNS server, you set up an A record with the server FQDN, pointing to the private address (instead of the public DNS which points to the public = the router's address). That way, clients in your local network use the private IP address while anyone outside uses the public IP.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.