I am trying to configure an ASA with Oxidized but the log file keeps telling me "status no_connection" and goes through it's attempts. I have tried many different configurations with no success. I have put my current configuration below. Can someone help me figure out why I cannot pull this config?

config group:

    username: myusername
    password: mypw
    enable:          <-----(Currently nothing here. I have tried 'blank' here)

  • 1
    Have you tried to connect manually as the oxidized user from the oxidized host?
    – Teun Vink
    May 29, 2018 at 14:13
  • You cannot see the configuration without the enable password.
    – Ron Maupin
    May 29, 2018 at 14:14
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer.
    – Ron Maupin
    Dec 25, 2018 at 8:30

1 Answer 1


A few ideas to get you moving forward:

  • Make sure SSH is working on the ASA. Can you SSH to it from your computer?
  • Then, make sure that the ASA allows SSH from the Oxidize server. Do a show run ssh on the ASA to see the sources from which the ASA will accept connections.
  • Once you're SSH'd to the ASA, you are put into user mode (where the prompt is firewall>. User mode gives you almost no privileges, so you have to escalate to 'enable' mode, where the prompt is firewall#. Enable mode will allow you to view the config by doing a show run. Whatever the Enable password is, it needs to be put into the Oxidize config. If the ASA does not have an Enable password, then set one by using the command enable password s0meth1ng-s3cret command in configuration mode on the ASA.

If all that doesn't work, then update your post with the output of a show ssh from your firewall, as well as the IP address of the Oxidize server, and we'll try to provide some other advice.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.