4

I have a working Cent OS server that is giving out dhcp and is also acting as a ftp server. ZTP works as it should on EX-2200 switches but something is off when I try to perform the same process on s EX-2300. Has anyone experienced anything similar? Only thing I can think of is the Software difference. Any info on this is greatly appreciated.


Edit:

I manually changed the date and time on the switch but I am still getting a error:

Auto Image Upgrade: Tried [2] attempts to fetch "file_name".txt file from s erver x.x.x.x through vme. Summary: "Failed to change directory.". To ret ry [4] times.

and it seems to see the server

Auto Image Upgrade: DHCP Options for client interface vme.0 ConfigFile: /configs/ex2300/file_name.txt ImageFile: /image/ex2300/junos-arm-32-15.1X53-D58.3.tgz Gateway: x.x.x.x DHCP Server:

x.x.x.x File Server: x.x.x.x Options state: All options set

Auto Image Upgrade: Active on client interface: vme.0

Auto Image Upgrade: Interface:: "vme"

Auto Image Upgrade: Server:: "x.x.x.x"

Auto Image Upgrade: Image File:: "junos-arm-32-15.1X53-D58.3.tgz"

Auto Image Upgrade: Server File:: "file_name.txt"

Auto Image Upgrade: Gateway:: "x.x.x.x"

Auto Image Upgrade: Protocol:: "ftp"

Its very strange as my ZTP server works with ex-2200.

Any ideas on why this would happen? Do I need a Network Director in order for this to work? I spent 3 hours with JTAC on the phone with no solution, just trying to figure out if it is possible to do without Network Director.

  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Dec 25 '18 at 8:37
2

The ZTP set up is pretty well documented here: https://kb.juniper.net/InfoCenter/index?page=content&id=KB27327

We have had issues in the past with some EX3400s where the time setting out of the box from the factory is back near Epoch (Jan 1 1970), and this caused ZTP to fail due to certificates on the software packages not yet being valid.

Try consoling in and setting the date to the current time (or even close to it) and see if that resolves your issue.

Yes, I realise the irony of having to console into a box to set the date to enable "Zero" Touch Provisioning ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.