1

I´m using 'enable'from the command prompt > to get access to the command prompt #. Doing this I get a list of commands starting with the word 'enable' but the command prompt doesn´t change. What could be the solution?. It has been a long time since the last time I had to work with switches...
Thank you for your help

5
  • What model of switch are you working with?
    – Stuggi
    Jun 1 '18 at 11:59
  • Just to be clear: do you get enable rights when you type enable? So is your problem that your prompt does not change, or that the enable command does not work?
    – Teun Vink
    Jun 1 '18 at 12:12
  • The model of switch is HP ProCurve 2910al-24G (J9145A). I´ve used the command 'help' before and after using 'enable' and I get the same list of commands, so I suppose that it has no effect... I´ve added a comment below with the output of the command 'enable'
    – fernando
    Jun 4 '18 at 8:30
  • I tried the same thing on a 2910al-24G, and I get output consistent with my answer below. I also tried logging in as a restricted operator user, and I get the same non-privileged prompt. What firmware are you running? Can you type just "help" and copy the list of commands here (I'm trying to figure out what context that you might be in)?
    – Stuggi
    Jun 5 '18 at 8:06
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer.
    – Ron Maupin
    Dec 25 '18 at 8:36
2

I'm not sure what your problem exactly is, but here's how it works on a HP Procurve switch

Switch1> enable
Username: root
Password: password
Your previous successful login (as manager) was on 1990-02-28 02:54:09
 from 192.168.0.1
Switch1#

Then to access the configuration options, you need to type conf

Switch1# conf
Switch1(config)#
3
  • CEGET_SW1_8GB:root> enable enable . enable : enable [ enable alias enable bg enable bind ... enable wait CEGET_SW1_8GB:root>
    – fernando
    Jun 4 '18 at 7:31
  • This is the output I get when I use ‘enable’: CEGET_SW1_8GB:root> enable enable . enable : enable [ enable alias enable bg enable bind ... enable wait CEGET_SW1_8GB:root> So finally I don´t get the command prompt #
    – fernando
    Jun 4 '18 at 7:38
  • CEGET_SW1_8GB:root> CEGET_SW1_8GB:root> enable exec CEGET_SW1_8GB:root> This is what I get when I use 'enable exec'. The output is the same with any other command 'enable...'
    – fernando
    Jun 4 '18 at 7:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.