9

I have CenturyLink Internet service, and they have a 6RD IPv6 deployment where they hand out an IPv6 delegated prefix /56 block to me and allow me to use it as I wish. My Cisco ISR router receives the /56 delegated prefix.

I have multiple VLANs and IPv4 routing on a layer 3 switch (a 3750) and am running an IPv4 DHCP server on it currently to hand out v4 IPs to the end hosts.

I have IPv6 running on the 3750 switch and would like to have it send IPv6 router advertisement packets with prefixes of the /56 delegated prefix that is further subnetted.

For example, if the /56 delegated prefix on the router is 2602:35:AE19:5400::/56, I'd like the 3750 to send router advertisement packets with the following prefixes, one prefix per VLAN:

2602:35:AE19:5401::/64

2602:35:AE19:5402::/64

2602:35:AE19:5403::/64

... and so on.

My plan is to have each host on the VLANs use SLAAC and EUI-64 to generate their globally routable IPv6 address.

I know how to make this setup work if I send the router advertisement messages from the router. Here's the Cisco code to do that:

ipv6 general-prefix PREFIX-CENTURYLINK 6rd Tunnel1
ipv6 unicast-routing
ipv6 multicast-routing
ipv6 cef
ipv6 route 2602::/24 Tunnel1

interface Tunnel1
    description CENTURYLINK IPV6 6RD TUNNEL
    no ip address
    ip mtu 1452
    ip tcp adjust-mss 1432
    ipv6 enable
    ipv6 mtu 1432
    ipv6 tcp adjust-mss 1412
    tunnel source Dialer1
    tunnel mode ipv6ip 6rd
    tunnel path-mtu-discovery
    tunnel 6rd prefix 2602::/24
    tunnel 6rd br <BR-IP-ADDRESS>
exit

interface GigabitEthernet0/0.1
    ipv6 enable
    ipv6 address autoconfig
    ipv6 address PREFIX-CENTURYLINK 0:0:0:1::/64 eui-64
    ipv6 nd autoconfig prefix
    ipv6 nd autoconfig default-route
exit

interface GigabitEthernet0/0.2
    ipv6 enable
    ipv6 address autoconfig
    ipv6 address PREFIX-CENTURYLINK 0:0:0:2::/64 eui-64
    ipv6 nd autoconfig prefix
    ipv6 nd autoconfig default-route
exit

interface GigabitEthernet0/0.3
    ipv6 enable
    ipv6 address autoconfig
    ipv6 address PREFIX-CENTURYLINK 0:0:0:3::/64 eui-64
    ipv6 nd autoconfig prefix
    ipv6 nd autoconfig default-route
exit

Is there some combination of DHCPv6 relay, DHCPv6 client, DHCPv6 prefix delegation (separate but related to 6rd delegated prefixes) and IPv6 router advertisements to achieve what I'm trying to do?

2
  • 1
    I am in the same boat with a 891 as CPE and a 3750G L3-switch as CE. I don't think there is a way to make this work without wild trickery. While you can set up your 6RD router as a DHCPv6 PD enabled server, IOS still won't let you use the 6RD learned general-prefix in ipv6 local pool <mylocalpoolname> <ipv6supernet> /<delegated-prefix-length>. See also the IP Addressing: DHCP Configuration Guide, Cisco IOS Release 15M&T at cisco.com/c/en/us/td/docs/ios-xml/ios/ipaddr_dhcp/configuration/… Jun 6, 2018 at 12:36
  • Did any answer help you? If so, you should accept the answer so that the question does not keep popping up forever, looking for an answer. Alternatively, you could post and accept your own answer.
    – Ron Maupin
    Dec 15, 2022 at 23:28

2 Answers 2

-1

Router Configuration (Cisco ISR):

Configure 6rd tunnel on the router to receive the delegated prefix:

ipv6 unicast-routing
ipv6 cef

interface Tunnel1
 description 6RD Tunnel
 no ip address
 ipv6 address 2602::/24 eui-64
 tunnel source Dialer1
 tunnel mode ipv6ip 6rd
 tunnel 6rd prefix 2602::/24
 tunnel 6rd br <BR-IP-ADDRESS>
exit

Enable IPv6 routing on the router's LAN interface and use the delegated prefix for SLAAC EUI-64 addressing:

interface GigabitEthernet0/0
 description LAN interface
 ipv6 enable
 ipv6 address 2602:35:AE19:5400::1/56
 ipv6 nd prefix 2602:35:AE19:5400::/56 infinite
 ipv6 nd managed-config-flag
 ipv6 nd other-config-flag
Layer 3 Switch Configuration (Cisco Catalyst 3750):

Configure IPv6 routing on the switch:

ipv6 unicast-routing

For each VLAN on the switch, assign a /64 prefix and enable IPv6, along with SLAAC EUI-64 addressing:

interface Vlan1
 description LAN interface
 ipv6 enable
 ipv6 address 2602:35:AE19:5401::1/64
 ipv6 nd prefix 2602:35:AE19:5401::/64 infinite
 ipv6 nd managed-config-flag
 ipv6 nd other-config-flag

Repeat this configuration for each VLAN, adjusting the VLAN number and prefix accordingly.

1
  • 1
    Your answer only shows how to assign various /64 on various SVIs of a L3 Switch, manually picked from a larger prefix (for example the /56). So your answer misses the key point of 6RD: changing prefixes followed by (implicit/automatic) renumbering. Your solution leaves the L3 switch completerly unaware of what's happening on the router. Aug 14 at 7:38
-3

A switch isn’t designed to route traffic, so it’s very likely that you couldn’t send RA from it (I’m a bit surprised that it supports IPv6 at all). Send RAs from the router, and use the switch as a switch.

3
  • 4
    Layer 3 switches - by nature capable of routing and many things "classic" CPU based routers do - have been in existence for more than 20 years. Jan 31, 2020 at 22:49
  • Generating RAs based on a 6rd split prefix isn’t a classical thing.
    – Alarig
    Feb 1, 2020 at 9:11
  • 3
    The three statements in your answer all miss their point. (1) A statement like a switch isn’t designed to route traffic is just plain wrong. The Cat3750 is a very capable L3 switch that can route both IPv4 and IPv6. (2) The assumption that you couldn't send RA from it falls very short. The 3750 is perefectly capable of that, and if memory serves right, its SVIs can even act as DHCPv6 client, to obtain a prefix from a DHCPv6 server. (3) Not all L3 designs want the router (here: the 6RD capable CPE) to be directly attached to the internal subnets, so sending RAs from the CPE is impossible. Feb 1, 2020 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.