1

Good day everyone, I'am having trouble getting VPCs from VLAN 3 to communicate with the DHCP on Vlan 3 I've also tried configured IP helper on the Router but to no avail.

GNS 3 topology

Router Configuration dump

Router#sh run
Building configuration...

Current configuration : 947 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex full
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 192.168.2.1 255.255.255.0
 ip helper-address 192.168.2.2
!
interface FastEthernet0/0.3
 encapsulation dot1Q 3
 ip address 192.168.3.1 255.255.255.0
 ip helper-address 192.168.2.2
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

Router#

Main Switch Configuration dump

MainSwitch#sh run
Building configuration...

Current configuration : 1674 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname MainSwitch
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet1/0
 switchport mode trunk
!
interface FastEthernet1/1
 switchport mode trunk
!
interface FastEthernet1/2
 switchport mode trunk
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.2.1
ip route 0.0.0.0 0.0.0.0 192.168.3.1
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

MainSwitch#

SW-Clients Configuration dump

SW-Clients#sh run
Building configuration...

Current configuration : 1944 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW-Clients
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet1/0
 switchport mode trunk
!
interface FastEthernet1/1
 switchport access vlan 3
!
interface FastEthernet1/2
 switchport access vlan 3
!
interface FastEthernet1/3
 switchport access vlan 3
!
interface FastEthernet1/4
 switchport access vlan 3
!
interface FastEthernet1/5
 switchport access vlan 3
!
interface FastEthernet1/6
 switchport access vlan 3
!
interface FastEthernet1/7
 switchport access vlan 3
!
interface FastEthernet1/8
 switchport access vlan 3
!
interface FastEthernet1/9
 switchport access vlan 3
!
interface FastEthernet1/10
 switchport access vlan 3
!
interface FastEthernet1/11
 switchport access vlan 3
!
interface FastEthernet1/12
 switchport access vlan 3
!
interface FastEthernet1/13
 switchport access vlan 3
!
interface FastEthernet1/14
 switchport access vlan 3
!
interface FastEthernet1/15
 switchport access vlan 3
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

SW-Clients#

SW-IT Configuration dump

SW-IT#sh run
Building configuration...

Current configuration : 1939 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW-IT
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet1/0
 switchport mode trunk
!
interface FastEthernet1/1
 switchport access vlan 2
!
interface FastEthernet1/2
 switchport access vlan 2
!
interface FastEthernet1/3
 switchport access vlan 2
!
interface FastEthernet1/4
 switchport access vlan 2
!
interface FastEthernet1/5
 switchport access vlan 2
!
interface FastEthernet1/6
 switchport access vlan 2
!
interface FastEthernet1/7
 switchport access vlan 2
!
interface FastEthernet1/8
 switchport access vlan 2
!
interface FastEthernet1/9
 switchport access vlan 2
!
interface FastEthernet1/10
 switchport access vlan 2
!
interface FastEthernet1/11
 switchport access vlan 2
!
interface FastEthernet1/12
 switchport access vlan 2
!
interface FastEthernet1/13
 switchport access vlan 2
!
interface FastEthernet1/14
 switchport access vlan 2
!
interface FastEthernet1/15
 switchport access vlan 2
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

SW-IT#

Does any body have an idea what i'm doing wrong ?

I'm quite new to networking

Thanks for helping me in advance.

Edit 2: Just for Clarification I'll dump all vlan and VTP Configs here

Main Switch VLAN AND VTP Dump

MainSwitch#sh vlan-switch

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/3, Fa1/4, Fa1/5, Fa1/6
                                                Fa1/7, Fa1/8, Fa1/9, Fa1/10
                                                Fa1/11, Fa1/12, Fa1/13, Fa1/14
                                                Fa1/15
2    IT                               active
3    Clients                          active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
2    enet  100002     1500  -      -      -        -    -        0      0
3    enet  100003     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0

MainSwitch#sh vtp status
    VTP Version                     : 2
    Configuration Revision          : 2
    Maximum VLANs supported locally : 36
    Number of existing VLANs        : 7
    VTP Operating Mode              : Server
    VTP Domain Name                 : NSFW
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x0C 0xA9 0xB5 0xF6 0x72 0xC4 0xEF 0x3C
    Configuration last modified by 0.0.0.0 at 3-1-02 00:04:54
    Local updater ID is 0.0.0.0 (no valid interface found)
    MainSwitch#

SW-Clients VLAN and VTP configuration\

SW-Clients#sh vlan-switch

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active
2    IT                               active
3    Clients                          active    Fa1/1, Fa1/2, Fa1/3, Fa1/4
                                                Fa1/5, Fa1/6, Fa1/7, Fa1/8
                                                Fa1/9, Fa1/10, Fa1/11, Fa1/12
                                                Fa1/13, Fa1/14, Fa1/15
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
2    enet  100002     1500  -      -      -        -    -        0      0
3    enet  100003     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      0      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0

SW-Clients#sh vtp status
    VTP Version                     : 2
    Configuration Revision          : 2
    Maximum VLANs supported locally : 36
    Number of existing VLANs        : 7
    VTP Operating Mode              : Server
    VTP Domain Name                 : NSFW
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x0C 0xA9 0xB5 0xF6 0x72 0xC4 0xEF 0x3C
    Configuration last modified by 0.0.0.0 at 3-1-02 00:04:54
    Local updater ID is 0.0.0.0 (no valid interface found)
    SW-Clients#

SW-IT VLAN and VTP configuration

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active
2    IT                               active    Fa1/1, Fa1/2, Fa1/3, Fa1/4
                                                Fa1/5, Fa1/6, Fa1/7, Fa1/8
                                                Fa1/9, Fa1/10, Fa1/11, Fa1/12
                                                Fa1/13, Fa1/14, Fa1/15
3    Clients                          active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
2    enet  100002     1500  -      -      -        -    -        0      0
3    enet  100003     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      0      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0

SW-IT#sh vtp status
    VTP Version                     : 2
    Configuration Revision          : 2
    Maximum VLANs supported locally : 36
    Number of existing VLANs        : 7
    VTP Operating Mode              : Server
    VTP Domain Name                 : NSFW
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x0C 0xA9 0xB5 0xF6 0x72 0xC4 0xEF 0x3C
    Configuration last modified by 0.0.0.0 at 3-1-02 00:04:54
    Local updater ID is 0.0.0.0 (no valid interface found)

Edit 3: DHCP Server dump

As requested a dump of the IOS router posing as a DHCP Server

DHCP Server Config Dump

DHCP-SERVER#sh run
Building configuration...

Current configuration : 1061 bytes
!
! Last configuration change at 14:42:48 UTC Sun Jun 3 2018
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname DHCP-SERVER
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
ip dhcp excluded-address 192.168.2.1 192.168.2.10
ip dhcp excluded-address 192.168.3.1 192.168.3.10
!
ip dhcp pool IT
 network 192.168.2.0 255.255.255.0
 default-router 192.168.2.1
!
ip dhcp pool Clients
 network 192.168.3.0 255.255.255.0
 default-router 192.168.3.1
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.2.2 255.255.255.0
 duplex full
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

DHCP-SERVER#
16
  • 1
    Do you have VLAN 3 on MainSwitch? Just do a "vlan 3" to create it. Right now it's probably limited to the SW-Clients. The helper address looks fine, but note that you don't need it for VLAN 2, since that's where the DHCP server resides. Broadcasts will reach it naturally.
    – boomi
    Jun 2, 2018 at 15:38
  • Yes the vlan 3 is on the main Switch
    – Z3R0_XP
    Jun 3, 2018 at 2:00
  • VLAN 3 on the main switch is not assigned to any interfaces, not even the trunk interfaces, so the switch will not forward traffic for that VLAN. You should really define the VLAN as @boomi suggests, and you need to define the VLAN priorities so that the main switch is guaranteed to be the root switch (spanning-tree vlan <vlan> priority root primary). You should also use descriptions on your interfaces. We can see that on the main switch, F1/0, F1/1, and F1/2 are trunk interfaces, but we cannot tell to which other devices they are connected from the configuration.
    – Ron Maupin
    Jun 3, 2018 at 2:25
  • As far as I'm aware, all VLAN's should be on all trunks by default unless manually trimmed. Additionally, I don't think 'sh vlan' ever shows a trunk as a member of a VLAN. What is the DHCP server in your topology, another IOS router? Can we get that config? You might try doing captures on each link to see where you stop seeing DHCP traffic.
    – boomi
    Jun 3, 2018 at 2:51
  • All the VLANs are allowed on a trunk by default, but if the VLANs are not showing up as on the trunk interface, then you need to make sure you have created the VLAN on the switch. You can use the vlan 3 command to enter the VLAN mode, then you can set other parameters, or exit to leave the mode. That will create the VLAN on the switch. Not doing that can cause such problems. Notice that none of the trunk interfaces on the main switch are assigned, yet the trunk interfaces on the other switches are. Always create the VLANs, even if you have an SVI.
    – Ron Maupin
    Jun 3, 2018 at 4:57

1 Answer 1

0

Based on our chat, the problem seems to be that you are using routers, not switches. You have a routing problem because you can ping the router subinterface for the VLAN, but not the router subinterface for the other VLAN.

You will run into all types of problems and limitations trying to use a switch module in a router as if it were a real switch. For example, the router switch modules cannot channel, and there are many other features that are missing or don't work in a router switch module that work well in a real switch. The switch modules in routers simply do not have all the features of switches.

What you are attempting should work if you had actual switches, but it appears that the "switches" are trying to route, and without a route to the destination network, a router will drop the packets. Trying to ping the other subinterface in the router isn't working because the router is not getting the packets, and I think the "switch" is dropping them because it is really a router. I ran into such a problem with switches that default to having routing enable, and I had to disable routing on the switches before they would work correctly.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.