5

I am having a very strange spanning-tree issue with Cisco Nexus switches.

My server is connected to the TOR switch with trunk configuration because we have multiple VLANs on the server. When I reboot the server it creates chaos in spanning tree; and, because of that, my network freezes live traffic for few seconds until spanning-tree get settled down. This is very odd.

enter image description here

SW1 & SW2 are configured in vPC and I have configured VLAN 100 in HSRP configuration. I am having this issue with only the VLAN 100 traffic.

SW1 & SW2 spanning tree configuration:

spanning-tree loopguard default
spanning-tree vlan 10,20,30,40,100 priority 8192

Spanning tree details:

sw1# sh spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol rstp
  Root ID    Priority    8292
             Address     0023.04ee.be01
             This bridge is the root
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    8292   (priority 8192 sys-id-ext 100)
             Address     0023.04ee.be01
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

HSRP configuration:

interface Vlan100
  description *** VLAN 100 ***
  no shutdown
  mtu 9216
  no autostate
  no ip redirects
  ip address 74.200.100.2/23
  no ip ospf passive-interface
  ip router ospf 100 area 0.0.0.0
  hsrp 1
    preempt
    priority 110
    ip 74.200.100.1

On TOR switch port e1/27 connected to the server:

interface Ethernet1/27
  description Connected to server 
  switchport mode trunk
  switchport trunk allowed vlan 10,20,30,100
  spanning-tree port type edge
  spanning-tree bpduguard enable

The issue occurs every single time I physically reboot the server. It causes my spanning-tree topology to change which disturbs vlan 100 traffic and I see lots of packet drops.

You can see here on TOR switch, port e1/27 just changed topology:

swt-tor# show spanning-tree detail | inc ieee|occurr|from
  Number of topology changes 69 last change occurred 0:13:50 ago
          from Ethernet1/27
  Number of topology changes 69 last change occurred 0:13:50 ago
          from Ethernet1/27
  Number of topology changes 69 last change occurred 0:13:50 ago
          from Ethernet1/27
  Number of topology changes 5 last change occurred 69:38:03 ago
          from port-channel36
  Number of topology changes 69 last change occurred 0:13:50 ago
          from Ethernet1/27
  • How do I tell spanning tree to not change spanning tree on the connected server trunk port?

  • How this is impacting only VLAN 100 (HSRP interface)?

  • Crap!!! never mind this solved my problem spanning-tree port type edge trunk look like – Satish Jun 11 '18 at 20:35
  • 2
    Please post your answer and accept it so we'll all see that this question is resolved. – Jeff Learman Jun 11 '18 at 20:43
  • @JeffLearman done! but i have to wait for 2 days to accept my own answer ;) – Satish Jun 12 '18 at 0:49
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Dec 25 '18 at 8:39
4

Solved

This command was missing in e1/27 interface.

spanning-tree port type edge trunk

Full interface output look like following.

interface Ethernet1/27
  description Connected to server 
  switchport mode trunk
  switchport trunk allowed vlan 10,20,30,100
  spanning-tree port type edge trunk
  spanning-tree bpduguard enable

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.