1

I am trying to make an ISATAP configuration where two ipv6 hosts connected to dual stacked routers can communicate to each other.

I have the following configuration: config

I have configured RIP across the IPV4 network, configured ISATAP tunnels and configured static routing where every packet that arrives an edge router with a host in it's destination will be forwarded to the host.

R1 and R3 seems to be communicating well (pinging to the ipv6 interface works).

the configuration for R1 is:

interface Tunnel 1
no ip address
no ip redirects
ipv6 address 133::/64 eui-64
tunnel source 10.0.1.1
tunnel mode ipv6ip isatap
exit

interface FastEthernet0/0
ip address 10.0.1.1 255.255.255.0
no shutdown
exit

interface FastEthernet0/1
no ip address
no shutdown
ipv6 address 2001::1/64 
exit

ipv6 route 2003::/64 133::5EFE:A00:301
ipv6 route 2001::2/64 FastEthernet0/1
exit

and for R2:

interface Tunnel 1
no ip address
no ip redirects
ipv6 address 133::/64 eui-64
tunnel source 10.0.3.1
tunnel mode ipv6ip isatap
exit

interface FastEthernet0/0
ip address 10.0.3.1 255.255.255.0
no shutdown
exit

interface FastEthernet0/1
no ip address
no shutdown
ipv6 address 2003::1/64 
exit

ipv6 route 2001::/64 133::5EFE:A00:101
ipv6 route 2003::2/64 FastEthernet0/1
exit

**Router model is cisco c375

Thanks

  • You should include the full router configurations, and the route tables. – Ron Maupin Jun 12 '18 at 21:01
  • The second IPv6 route statement on each router is unnecessary, and you should remove it. You do not need an explicit route to a directly connected network, and you could actually cause problems with it. – Ron Maupin Jun 12 '18 at 21:02
  • The first IPv6 route cannot be correct because those are not EUI-64 addresses for the interface addresses, and you have the tunnel using EUI-64 addressing. You should explicitly address the tunnel, and you should use IPv6 /127 addressing for a point-to-point link. – Ron Maupin Jun 12 '18 at 21:03
1

solved, Problem was not enabling ipv6 unicast routing. this can be done by using: ipv6 unicast-routing.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.