2

I have to connect two SG220 series switches. On the first switch (S1) I have created 3 vlan (vlan10, vlan20 and vlan30). On one of the port I connected Mikrotik router with the same vlans and DHCP pools for each of them. On the S1 I configured the corresponding port in trunk mode and I excluded the default vlan1. When I dedicate a port to a specific vlan in access mode, connected device get an IP address from the right IP pool.

On the second switch (S2) i configured link port to S1 in a trunk mode and I added the 3 vlans and excluded default vlan1. I have the same setting on the corresponding link port on S1. But when I dedicate a specific port to a vlan on S2, connected device don't get an IP address.

Can someone tell me what am I doing wrong and how can I solve the problem.

This is the configuration of S1:

Switch-F0
v1.1.4.1
CLI v1.0
@
!
hostname "Switch-F0"
clock source sntp
sntp server 0.europe.pool.ntp.org port 123
clock timezone CET 2 minutes 0
!
vlan 10
name "vlan10"

vlan 20
name "vlan20"

vlan 30
name "vlan30"

voice vlan oui-table add 00:E0:BB 3COM
voice vlan oui-table add 00:03:6B Cisco
voice vlan oui-table add 00:E0:75 Veritel
voice vlan oui-table add 00:D0:1E Pingtel
voice vlan oui-table add 00:01:E3 Siemens
voice vlan oui-table add 00:60:B9 NEC/Philips
voice vlan oui-table add 00:0F:E2 H3C
voice vlan oui-table add 00:09:6E Avaya
!
spanning-tree mst configuration
name "2C:AB:EB:D3:90:5E"
!
ip telnet server
ip ssh server
!
interface po1
switchport mode trunk uplink
!
interface po2
 switchport mode trunk uplink
!
interface gi14
 switchport mode trunk uplink
 switchport trunk allowed vlan add 10,20,30
 switchport forbidden vlan add 1
!
interface gi24
 switchport trunk allowed vlan add 10,20,30
 switchport forbidden vlan add 1
!

This is the configuration of S2:

Switch-F3
v1.1.4.1
CLI v1.0
@
!
hostname "Switch-F3"
clock source sntp
sntp server pool.ntp.org port 123
clock timezone CET 2 minutes 0

username "cisco" secret encrypted 
!
vlan 10
 name "vlan10"
vlan 20
 name "vlan20"
vlan 30
 name "vlan30"

voice vlan oui-table add 00:E0:BB 3COM
voice vlan oui-table add 00:03:6B Cisco
voice vlan oui-table add 00:E0:75 Veritel
voice vlan oui-table add 00:D0:1E Pingtel
voice vlan oui-table add 00:01:E3 Siemens
voice vlan oui-table add 00:60:B9 NEC/Philips
voice vlan oui-table add 00:0F:E2 H3C
voice vlan oui-table add 00:09:6E Avaya
!
spanning-tree mst configuration
 name "B0:7D:47:45:49:EB"
!
ip telnet server
ip ssh server
!
interface gi33
 switchport mode access
 switchport access vlan 10
!
interface gi50
 switchport trunk allowed vlan add 10,20,30
 switchport forbidden vlan add 1
!

Thanks in advance.

  • 1
    You should provide the actual configs instead of describing what you configured. – Teun Vink Jun 27 '18 at 14:42
  • You need to provide more information. At the very least, we need you configurations. Speculation and guessing are off-topic here. Please edit your question to provide as much information as possible. – Ron Maupin Jun 27 '18 at 17:15
  • @Zac67 is correct. You have set up the trunk parameters, but you did not actually turn the trunk on. – Ron Maupin Jun 28 '18 at 17:09
  • In the switches, do you learn mac from Mikrotik and the host that is on the gi33 interface in vlan 10? Can you do a show and paste here? Is mikrotik with the server in DHCP-SERVER in red? Have you ever tried to put a machine in the gi33 interface port in the same IP range that you assigned in VLAN10 on the Mikrotik and tested IP connectivity? If it does and it works, it is some configuration error of the DHCP server in Mikrotik. – Pedro Ferreira Jun 29 '18 at 18:44
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Dec 25 '18 at 8:51
1

Apparently, your trunk setting on S1 and S2 don't match. You need to match the trunk settings exactly - same untagged/native VLAN, same tagged VLANs. If it still doesn't work you need to post the (sanitized) configurations.

Edit after you posted the configs: You need to enable trunk mode on the switch-to-switch interfaces:

switchport mode trunk
  • 1
    Thanks for the replay. The configuration is exactly same on the both switches. – Aleksandar Blazevski Jun 27 '18 at 13:10
  • I did that, but it still doesn't work. In the meantime I've noticed in the logs of S2 that when I plug the cable the STP goes directly to Blocking. On the other hand, the corresponding port on S1 is Forwarding. – Aleksandar Blazevski Jun 29 '18 at 9:41
  • Apparently, you've got a redundant link between S1 and S2. Without your information, a network diagram, or similar we're unable to see that. – Zac67 Jun 29 '18 at 10:46
  • I have additional link from S1 to S2 on which i running the whole net traffic. I can't remove that link because we can't have down time. That's why i excluded vlan1 from the second trunk link, because at the moment traffic goes through that vlan. – Aleksandar Blazevski Jun 29 '18 at 14:05
  • Standard RSTP and MSTP without further configuration work on the link level, ie. regardless of VLAN configuration. If you want spanning tree to work on the VLAN level you need to use RPVST+ or configure MSTP with multiple instances. – Zac67 Jun 29 '18 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.