1

I'd like to have a Cisco 6509-E join a VLAN as a client so I can add some reachability SLAs across an organizational boundary. I've tried doing the usual "ip address dhcp" on an actual interface as well as on a VLAN SVI. The option doesn't seem to exist. Does anyone know if this is possible / how to do it? I'm hoping there's something I'm missing.

Thanks in advance!


Version / Device info:

Cisco IOS Software, s72033_rp Software (s72033_rp-ADVENTERPRISEK9-M)
      Version 15.1(2)SY10, RELEASE SOFTWARE (fc4)
NAME: "WS-C6509-E", DESCR: "Cisco Systems Catalyst 6500 9-slot Chassis System"
NAME: "5", DESCR: "VS-S720-10G 5 ports Supervisor Engine 720 10GE Rev. 2.0"
NAME: "msfc sub-module of 5", DESCR: "VS-F6K-MSFC3 MSFC3 Daughterboard Rev. 1.0"
NAME: "VS-F6K-PFC3C Policy Feature Card 3 EARL sub-module of 5", DESCR: "VS-F6K-PFC3C Policy Feature Card 3 Rev. 1.0"

Trying to set up DHCP on a VLAN SVI.

Dev(config)#int vlan 10
Dev(config-if)#ip address dhcp
                          ^
% Invalid input detected at '^' marker.

Dev(config-if)#ip address ?
  A.B.C.D  IP address
  pool     IP Address autoconfigured from a local DHCP pool

Trying the same thing on a physical interface.

Dev(config-if)#int g5/3
Dev(config-if)#ip address ?
  A.B.C.D  IP address
  pool     IP Address autoconfigured from a local DHCP pool
  • The fact you are able to enter the IP address command shows that the gigabit interface is in L3 mode and the VLAN interface is L3 only, so no issues there. There isn’t any other commands required to support DHCP client, so it may be that the platform or version does not support DHCP client on those interfaces. You could try upgrading if there is a newer image. Out of interest, is the command supported on the Supervisor Managemnt interfaces? It may be a restriction on non-management ones as it is not a normal requirement to use DHCP client on a core switch – Karl Billington Jun 30 '18 at 8:40
0

Remember that a 6509 is first a layer-2 switch, and most of the interfaces are layer-2 interfaces, which cannot use IP addressing. Since the 6509 is also a layer-3 switch, you can convert interfaces to layer-3 interfaces, which can then be configured with IP addressing.

First make sure you have IP routing enabled with the global ip routing command. Then you need to convert an interface to a layer-3 interface:

interface Vlan10
 no switchport

-or-

interface GigabitEthernet5/3
 no switchport

After that, you should be able to assign a layer-3 (IP) address to the interface and treat it as a router interface rather than a switch interface.


Using DHCP to address your network devices is not a good idea. If you explain exactly what you need we may be able to help with that. IPSLA doesn't need DHCP, and it usually requires specific addressing in its configuration. You may be trying to solve an X-Y problem.

  • The default config for this configuration of hardware and firmware is fully L3, so the interface was already tested in that state. I tried doing no switchport on the SVI but that command wasn't accepted. Re. L3 OOB, ints look like this and show ip route shows a routing table. interface GigabitEthernet1/1 no ip address shutdown ! interface GigabitEthernet1/2 no ip address shutdown ! interface GigabitEthernet1/3 no ip address shutdown ! – Michael D Jun 29 '18 at 14:56
  • That doesn't mean that someone has not run the no ip routing command. That may be done for specific reasons, and many of the interfaces are layer-2 interfaces by default, regardless of the whether or not the 6509 was configured for layer-3. – Ron Maupin Jun 29 '18 at 14:58
  • This work is being done on a test chassis I reset to defaults before starting. I probably should've mentioned so originally. Also L3 cannot be disabled on this device. no ip routing is an invalid command. If you try to run it, it prints % Incomplete command.. – Michael D Jun 29 '18 at 15:06
  • That just mean you have more options on the command, not that it is an invalid command. – Ron Maupin Jun 29 '18 at 15:14
  • Just like to point out that VLAN interfaces (SVIs) are layer 3 only interfaces, so they will not require (or allow) the no switchport command in the above – Karl Billington Jun 29 '18 at 22:03
0

Apparently this is not a supported feature on the 6500-series chassis. The Cisco Feature Navigator lists it as supported, but I just couldn't make it happen. The posts I did find about this topic had no solution - seems everyone either refactored their network where they were able to, or put a device in front of their 6500.

https://lists.gt.net/cisco/nsp/109634

https://supportforums.cisco.com/t5/lan-switching-and-routing/cat6500-as-dhcp-client/td-p/1702122

https://supportforums.cisco.com/t5/wan-routing-and-switching/dhcp-address-on-interface-catalyst-6500/td-p/765392

https://supportforums.cisco.com/t5/lan-switching-and-routing/assign-dhcp-address-for-l3-routed-ports-on-6500/td-p/2807547

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.