1

Router internet interface Fastethernet0/0 192.168.0.17 (ip nat outside)

internal interface 192.168.1.1 (ip nat inside)

able to ping 8.8.8.8 from router

Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.0.17    YES DHCP   up                    up
FastEthernet0/1            192.168.1.1     YES NVRAM  up                    up
NVI0                       unassigned      NO  unset  up                    up

router config:

interface FastEthernet0/0
ip address dhcp
ip nat outside
ip virtual-reassembly
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip route-cache
duplex auto
speed auto


ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip nat inside source list 1 interface FastEthernet0/0 overload
access-list 1 permit 192.168.1.0 0.0.0.255

From switch able to ping both router intefaces but not 8.8.8.8

set default gateway on switch

ip default-gateway 192.168.1.1

Both are CISCO

switch config:

service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname nemanja_SW1_35550
!
enable secret 5 $1$vc35$d7PthbPyFSMsiQlnQTMIU0
enable password 7 1218011A1B05
!
no aaa new-model
clock timezone CST 1
ip subnet-zero
no ip domain-lookup
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0/1
 switchport mode dynamic desirable
!
interface FastEthernet0/2
 switchport mode dynamic desirable
!
interface FastEthernet0/3
 switchport mode dynamic desirable
interface Vlan1
 ip address 192.168.1.3 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.1.1
6
  • are you able to ping 8.8.8.8 from the router (using F0/0 interface directly)?
    – Golgot
    Jul 4, 2018 at 20:48
  • Please include the switch config.
    – Ron Trunk
    Jul 4, 2018 at 20:53
  • @Golgot, yes i can ping from F0/0
    – Milister
    Jul 4, 2018 at 21:01
  • @RonTrunk-included
    – Milister
    Jul 4, 2018 at 21:04
  • Please accept your own answer if this solved your problem.
    – Teun Vink
    Jul 6, 2018 at 21:18

2 Answers 2

1

Found solution,had to change default route to

ip route 0.0.0.0 0.0.0.0 192.168.0.1

192.168.0.1 is ISP provider router

-1

I think you need an extended access list ip access-list 100 permit ip 192.168.1.0 0.0.0.25 any change your nat statement to

ip nat inside source list 100 interface FastEthernet0/0 overload

1
  • @chuck-solved it was issue with default route
    – Milister
    Jul 6, 2018 at 19:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.