4

Please consider dot1q frames tagged 100 circulating on a LAN (VLAN 100).

To go out onto the Internet, frames have to go through a PPPoE sub-interface which is configured as below:

interface GigabitEthernet0/0/0.1
  encapsulation dot1Q 777
  pppoe enable group global
  pppoe-client dial-pool-number 1

Frames, leaving the LAN to go out onto the Internet, get the 777 tag.

Can you explain what happens to the frames tagged 100 as they go through (or try to go through) this Gi0/0/0.1 sub-interface?

Are they dropped?

Is their 100 tag replaced with tag 777?

What's happening to them?

Thank you.

=============================================================

EDIT 1 - in response to Mike Pennington

Thank you for your answer which is very helpful.

You are right. I also have a Dialer interface configured as you say.

Given what you explain, I think that my frames from VLAN 100 are dropped.

As such, frames tagged with 100 entering this router will exit to the internet assuming:

1) They enter the router on another IP vlan 100 subinterface or SVI

Shall I create another sub-interface:

interface GigabitEthernet0/0/0.100
  encapsulation dot1Q 100

What about the PPPoE link and the Dialer?

I can have only one PPPoE link and I guess only one Dialer interface.

2) They have the destination mac-address of the aforementioned subinterface

How can I tell that frames dot1q tagged 100 shall go through this sub-interface with its specific destination mac-address?

Is there a link that has to be made between the new sub-interface GigabitEthernet0/0/0.100 and the LAN sub-interface GigabitEthernet0/0/1.100 that is already configured and which is configured as:

interface GigabitEthernet0/0/1.100
 description ***Router sub-interface for voice traffic***
 encapsulation dot1Q 100
 ip address 192.168.100.1 255.255.255.0
 ip nat inside
 ip tcp adjust-mss 1452

3) There is a route in the router pointing that packet's destination IP address to the internet

Would you be so very kind to tell me how to configure this route?

Would this be a route from interface GigabitEthernet0/0/1.100 to the Dialer interface?

  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Dec 25 '18 at 9:00
4

Can you explain what happens to the frames tagged 100 as they go through (or try to go through) this Gi0/0/0.1 sub-interface?

First, let's be a little more clear about your configuration for other readers. More than likely, you also have an interface in the router configured like this:

interface Dialer1
 mtu 1492
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname myUsername
 ppp chap password myPassword
 dialer-list 1 protocol ip permit
!

As such, frames tagged with 100 entering this router will exit to the internet assuming:

  • They enter the router on another IP vlan 100 subinterface or SVI
  • They have the destination mac-address of the aforementioned subinterface
  • There is a route in the router pointing that packet's destination IP address to the internet

Is their 100 tag replaced with tag 777?

If they are routed to the internet

Are they dropped?

Vlan 100 packets will be dropped if the router doesn't know what to do with them. Large UDP packets exiting to the internet will be fragmented to fit the egress interface's MTU as-required.

| improve this answer | |
  • I edited my post. – Léa Massiot Jul 9 '18 at 14:22
  • @LéaMassiot I need to leave for the doctor's office and then for my office. I can revisit your other questions after I return from the office this evening (in the US) – Mike Pennington Jul 9 '18 at 14:28
  • That's very considerate of you to say. I hope your appointment goes well. I am in France (horlogeparlante.com/heure-brest-france-HEUREfrance3030300.html) Good luck. – Léa Massiot Jul 9 '18 at 15:13
  • Hello Mike. I hope you're ok and you didn't forget about me. I'm really counting on the help you can give me. Thanks. – Léa Massiot Jul 10 '18 at 7:59
  • Please let us continue discussion in chat – Mike Pennington Jul 10 '18 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.