2

I have two pfsense. One pfsense is on 192.168.0.1 and another pfsense is on 192.168.20.1. Basically I have installed 20.1 pfsense on one machine 192.168.0.180 which is in the network of 0.1 pfsense, and added the rules for that machine on 0.1 pfsense.

Now what I am trying to achieve is that the system connected to 20.1 pfsense rules should also be able to connect to the systems on 0.1 which is happening. But when I am trying to connect from 0.x to let's say 20.y it's not able to connect. Below image is the scenario. enter image description here

So basically I am trying to connect one system on 0.1 pfsense rule with another system on 20.1 pfsense rule.

I am trying to do one 1:1 mapping here on 0.1 pfsense. But somehow I am not able to achieve that. Below is the picture of my current configurations. enter image description here

What's wrong with my configurations ?

Is NAT only solution for fixing this problem ? What are other alternatives I can try ?

Regards

5
  • "I am trying to do one 1:1 mapping here on 0.1 pfsense." Why? NAT is not a substitute for routing, and it should only be used when necessary (private to public addressing and overlapping addressing). I see no reason to use NAT in the diagram. – Ron Maupin Jul 10 '18 at 12:35
  • @RonMaupin then how can I make a connection from node 1 in 0.1 to node 2 on 20.1 ? – Lokesh Pandey Jul 10 '18 at 15:47
  • Just enable routing. You don't need or want NAT. Routers default to routing. – Ron Maupin Jul 10 '18 at 15:50
  • Isn't there someone in your company that understands basic networking and routing of whom you could ask this? – Ron Maupin Jul 10 '18 at 15:54
  • @RonMaupin I am trying to understand this one for my own. So I need to add static routes and define destination network as 192.168.20.1 and gateway 192.168.0.180 right ? – Lokesh Pandey Jul 12 '18 at 3:57
1

Thank you @Ron for directing me in a right direction. I used static routes from System -> Routing -> Static Routes. And change the destination network and gateway according to my configurations. Like in this diagram below : enter image description here

You need to add the gateway this may be the internal or the external link. In case you didn't find the gateway click on add a new one first and configure it according to your gateway configuration. In my case I have used it as an internal link. Click save and try ping 192.168.20.2. I started getting response from another node on 192.168.20.1. enter image description here

3
  • You should accept your answer so that the question doesn't keep popping up forever, looking for an answer. – Ron Maupin Jul 12 '18 at 13:04
  • Estimados funciono muchas gracias por la ayuda atte. Edgar Pacosillo – user49830 Aug 31 '18 at 18:19
  • @user49830 English please. – Lokesh Pandey Sep 1 '18 at 3:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.