3

Switch: ProCurve Switch 2520G-8-PoE

Scenario: Multicast is flooded onto the network

Having multicast flooded makes it so TV is stuttering and pixelating. I do on my ProCurve have IGMP and Querier enabled. The switch is the querier. My messages are still flooded onto every port on the same untagged vlan (5).

On the switch I see the groups are created by the TV as I switch channels still it sends out. Anyone aware if this switch is NOT able to stop multicast flooding by default? If so how do I enable it on this switch?

Running config:

vlan 5 
name "CC_CAST" 
untagged 2-5,8 
ip address 172.16.1.5 255.255.255.0 
tagged 1,7,9 
ip igmp 
exit 

Show version gives:

ProCurve Switch 2520G-8-PoE(vlan-5)# show version
Image stamp:    /sw/code/build/walle(t4b_release)
                Jul 27 2009 01:04:24
                J.14.01
                474
Boot Image:     Primary

show ip igmp 5 config shows:

IGMP Service 

  VLAN ID : 5    
  VLAN NAME    : CC_CAST 
  IGMP Enabled [No] : Yes
  Forward with High Priority [No] : No 
  Querier Allowed [Yes] : Yes

  Port Type      | IP Mcast
  ---- --------- + --------
  1    1000T     | Auto    
  3    1000T     | Auto    
  4    1000T     | Auto    
  5    1000T     | Auto    
  7    1000T     | Auto    
  8    1000T     | Auto    
  9    1000T     | Auto    

and show ip igmp 5

 Status and Counters - IP Multicast (IGMP) Status

 VLAN ID : 5
 VLAN Name : CC_CAST
 Querier Address : This switch is Querier

  Active Group Addresses Reports Queries Querier Access Port
  ---------------------- ------- ------- -------------------
  230.3.1.204            1       0                          
  239.255.3.22           374     0                          
  239.255.255.0          321     0                          
  239.255.255.10         321     0                          
  239.255.255.20         321     0                          
  239.255.255.30         321     0                          
  239.255.255.246        190     0                          
  239.255.255.250        967     0                          

show ip igmp group 230.3.1.204

 IGMP ports for group 230.3.1.204

  Port  Type      Access      Age Timer Leave Timer
  ----- --------- ----------- --------- -----------
  3     1000T     host        0         0          
  • "Having multicast flooded makes it so TV is stuttering and pixelating." That is unlikely. Most switching is done in hardware at wire speed, and it is no more burdensome to the switch to send a frame to a single interface than it is to send it to all interfaces. There is something else causing your problem. – Ron Maupin Jul 12 '18 at 14:02
  • There are over 100Mbps data on each port so it's a problem. There are more data then what TV ethernet port is (10/100). The switch should be filtering out and only sending the multicast groups the TV joins? – Aninano Jul 12 '18 at 14:06
  • But what happens on other switch interfaces has no bearing on what happens on the receiver interface. All the other interfaces could be completely busy, but if the receiver is only receiving the multicast, then it should work just fine. Switching is done in hardware, and almost all modern switches will switch at wirespeed. It is only if the receiver interface is receiving other traffic besides the multicast traffic that you may have interference, and then you use QoS to try to mitigate that. – Ron Maupin Jul 12 '18 at 14:09
  • 1
    Wasn’t this answered yesterday with a different switch model? – Karl Billington Jul 12 '18 at 14:15
  • The problem is that on other switches we have possibility to disable multicast packages from being sent to all interfaces unless it joined the igmp group for that multicast stream. HP also states that this is default behavior for the switches, the eth0 interface on my pc is 100% all the time. Hope you understand what I mean. (Link from hp)[h22208.www2.hpe.com/eginfolib/networking/docs/switches/RA/15-18/… it says when one need a multicast it sends a join report. But I still get all without joining :P – Aninano Jul 12 '18 at 14:15
1

As per Aruba 2530 - IGMP Enabled, Querier on still no filtering

And RFC 4541

If no receivers join the group, then the switch can either flood the traffic to the IGMP querier or alternatively default to flooding the traffic. In this case it is flooding the traffic.

It makes sense as some multicast streams, ones that are designed not to be routed, may not use IGMP. This allows all hosts to receive the traffic.

You need to make sure that all groups are joined if you want to cut down on the flooding.

The 2520G is an older model, which is end of sale. It may be missing some of the newer features that other Procurve/ArubaOS switches have. Try upgrading to the latest software if you have any issues.

| improve this answer | |
  • Quote: On HP switches that do support data-driven IGMP ("Smart" IGMP), when unregistered multicasts are received the switch automatically filters (drops) them. Thus, the sooner the IGMP leave is processed, the sooner this multicast traffic stops flowing. End quote See [link](goo.gl/eGZMsn). So basically what I'm asking is does this switch support data-driven IGMP. Since flooding the network with over 100Mbit saturates all the TV's and generate pixelation. Then i can "add" to that on my Aruba 2530, does it support data-driven IGMP. I have tried looking but cannot see it. – Aninano Jul 13 '18 at 6:06
  • 1
    The software on the switch appears to be 6-7 years old, try upgrading to J.15.09.0028. h10145.www1.hpe.com/downloads/… – Karl Billington Jul 13 '18 at 6:16
  • You could also try configuring "igmp filter-unknown-mcast", wr mem, then reboot the switch – Karl Billington Jul 13 '18 at 6:38
  • @KarlBillington J.14.01 is definitely ancient (2009), probably the first 2520 release. Seconding the update, likely to solve the problem. – Zac67 Jul 13 '18 at 7:51
  • @KarlBillington after installing upgrade "igmp filter-unknown-mcast" is added as a function and this works perfectly. So most switches with igmp support are ment to not flood network. Also TV is not pixelating anymore. Now I'm back to test on the Aruba one. It has filter-unknown-mcast enabled still it spams. But going back to that thread when i have questions. Thanks – Aninano Jul 13 '18 at 8:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.