7

I am trying to connect "sfp-1ge-fe-e-t" sfp module to CISCO Catalyst C3560G-48TS switch.

When i pluged module to the port and following error was shown:

%GBIC_SECURITY_CRYPT-4-VN_DATA_CRC_ERROR: GBIC in port Gi0/49 has bad crc

Then I searched solution for the problem, so I found several solution that describes same steps.

like that: how to connect 3rd party sfp to the cisco switches

I tried following commands:

# service unsupported-transceiver

# no errdisable detect cause sfp-config-mismatch
# no errdisable detect cause gbic-invalid

But it didn't help actually. I couldn't turn on GBIC ports. It always shows "status down, protocol down".

Even show idprom interface gigabitEthernet 0/49 command doesn't show anything.

I have been experiencing with the proplem for two days.

Which steps should i follow? what is the real solution? Thanks in advance

enter image description here enter image description here enter image description here enter image description here

  • There is nothing you can do about this. The 3rd party SFP has to be tagged for Cisco, otherwise it's a no go. – user36472 Jul 25 '18 at 8:23
6

I'm afraid the real solution is to use either Cisco transceivers or third-party transceivers - from reputable vendors- that are specifically "tagged" to be used on Cisco switches.

Using random transceivers will only cause troubles and the time you will loose will vastly overcome the economy made on the hardware.

Edit:

As you can see in this datasheet the C3560G-48TS has SFP (1Gb) ports, not SFP+ (10Gb). So you cannot use a SFP+ transceiver like sfp-10g-sr

You can use this compatibility matrix to check which transceiver are compatible with your switch.

  • I have tested Cisco SFP (sfp-10g-sr) module too, but it also could not turn the port on the it showed following error: %PHY-4-SFP_NOT_SUPPORTED: The SFP in Gi0/51 is not supported – Simral Abdurahim 26 mins ago Even I have changed IOS, but it also doesn't work – Simral Abdurahim Jul 26 '18 at 8:15
  • @SimralAbdurahim see my edit. – JFL Jul 26 '18 at 9:51
0

You SFP has to be Cisco tagged.

Please note that some SFP supplier can provide a programmer to retag SFP on the fly.

We used this a lot, this is very convenient for spare management when you used mixed devices brands/models. Now we have lots of spare for every devices...

We use a specific programmer from a specific SFP vendor, but there is also generic solutions and DIY solutions (search SFP programmer on google)

-1

try this command :

(note that you should type it and it is not auto complete )

 # no errdisable detect cause gbic-inv service unsupported-transceiver

then remove SFP. then shut/no shut. then put it back.

if it doesn't work try default the port:

conf t # default int gig1/1/1

if it doesn't work, you should test all of combination of above command + physical job.

  • He already tried that, if you read the question. – user36472 Jul 25 '18 at 12:23
  • I think The combination of command is different. – hamid bayat Jul 25 '18 at 12:37
  • Service unsupported is at the end of no errdisable line. I think he test it seprately – hamid bayat Jul 25 '18 at 12:39
  • I just tested it and there is absolutely no difference. – user36472 Jul 25 '18 at 12:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.