I follow the Tutorial to connect a switch,

use ls *usb* I can find the usb:

$ ls *usb*
cu.wchusbserial1410   
tty.wchusbserial1410

I connect to it:

screen tty.wchusbserial1410 9600

but I get the messy code when I type the keyboard.

I type enter, there gets the ?, I type s, there will get f. you can see in the snapshot:


EDIT-01

My switch is Juniper-EX4300 and the usb driver is Qinheng.

and the Juniper manual shows the Baud rate is 9600.

EDIT-02

I use the console-serial line connect the switch port, and then use the serial-USB convertor connect the line and my Mac.

  • This is because of speed mismatch between your console and the device you try to connect to. You have to know on which speed your device is communicating and set this speed to your terminal program. Also good to know is number of data-bits, stop-bits and parity. – Winnie Tigger Aug 2 at 12:59
  • @WinnieTigger Do you mean the switch's console port ? – aircraft Aug 2 at 13:02
  • Yes! On what speed etc. is the switch console set? This parameters need to be the same in your terminal programm. – Winnie Tigger Aug 2 at 13:03
  • how to see the switch console port? and in the manual the Juniper EX4300 is 9600, I use this rate connect you can see in my post. – aircraft Aug 2 at 13:05
  • Is this a new device? If not, maybe someone changed it. – Winnie Tigger Aug 2 at 13:07

Serial port settings mismatch. Please set serial setting as below:

  • Baud rate—9600
  • Flow control—None
  • Data—8
  • Parity—None
  • Stop bits—1
  • DCD state—Disregard
  • whats then command of the settings with ‘screen’? – aircraft Aug 2 at 16:10
  • try 9600,cs8,-ixon,-ixoff – Datagram.Network Aug 2 at 16:15
  • this do not work, bro. – aircraft Aug 3 at 2:48

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.