2

I am new to Cisco products and have been following some online guides detailing the steps requested to set up but am stuck in a bit of a rut. I believe all correct interfaces are configured and have configured a dialler to the best of my knowledge. Can anyone spot any obvious mistakes and help a brother out? Thank you so much in advance!

A condensed version of my config

ip dhcp excluded-address 10.10.10.1 10.10.10.29
ip dhcp excluded-address 10.10.10.201 10.10.10.254
!
ip dhcp pool Public
 import all
 network 10.10.10.0 255.255.255.0
 dns-server 8.8.8.8 1.1.1.1 
 domain-name techbit.info
 default-router 10.10.10.1 
!

controller VDSL 0
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/38 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface Ethernet0
 no ip address
 ip flow ingress
 ip flow egress
 ip virtual-reassembly in
!
interface Vlan1
 ip address 10.10.10.1 255.255.255.0
 ip virtual-reassembly in
!
interface Dialer1
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname *******@skydsl
 ppp chap password 0 ********
 ppp pap sent-username ********@skydsl password 0 redacted
 ppp ipcp dns request
 ppp ipcp route default
 no cdp enable
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
no logging trap
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 privilege level 5
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

VDSL controller status (I can see that I have Showtime, so there must be a problem with Auth or routing?)

Controller VDSL 0 is UP

Daemon Status:       Up 

            XTU-R (DS)      XTU-C (US)
Chip Vendor ID:     'BDCM'           'IFTN'
Chip Vendor Specific:   0x0000           0xD086
Chip Vendor Country:    0xB500           0xB500
Modem Vendor ID:    'CSCO'           '    '
Modem Vendor Specific:  0x4602           0x0000
Modem Vendor Country:   0xB500           0x0000
Serial Number Near:    FGL2023258U C887VAM- 15.3(3)M6
Serial Number Far:     
Modem Version Near:    15.3(3)M6
Modem Version Far:     0xd086

Modem Status:        TC Sync (Showtime!) 
DSL Config Mode:     AUTO 
Trained Mode:        G.993.2 (VDSL2) Profile 17a
TC Mode:         PTM 
Selftest Result:     0x00 
DELT configuration:  disabled 
DELT state:      not running 
Trellis:         ON           ON
SRA:             disabled            disabled
 SRA count:          0           0
Bit swap:        enabled             enabled
 Bit swap count:     0           0
Line Attenuation:     0.0 dB          0.0 dB
Signal Attenuation:   0.0 dB          0.0 dB
Noise Margin:         6.1 dB          6.3 dB
Attainable Rate:    23764 kbits/s        3829 kbits/s
Actual Power:        10.2 dBm         7.2 dBm
Per Band Status:        D1  D2  D3  U0  U1  U2  U3
Line Attenuation(dB):   22.0    67.1    102.3   10.9    54.9    65.3    N/A 
Signal Attenuation(dB): 22.0    67.1    N/A 10.6    54.6    N/A N/A 
Noise Margin(dB):       6.1 6.1 N/A 7.5 6.2 N/A N/A 
Total FECC:     19338            769
Total ES:       8            119
Total SES:      5            0
Total LOSS:     0            0
Total UAS:      60           658
Total LPRS:     0            0
Total LOFS:     5            0
Total LOLS:     0            0

Full inits:     2
Failed full inits:  0
Short inits:        0
Failed short inits: 0

Firmware    Source      File Name (version)
--------    ------      -------------------
VDSL        embedded    VDSL_LINUX_DEV_01212008 (1)

Modem FW  Version:  130205_1433-4.02L.03.A2pv6C035j.d23j
Modem PHY Version:  A2pv6C035j.d23j
Vendor Version:     Ap6v35j.23j 68


          DS Channel1     DS Channel0   US Channel1   US Channel0
Speed (kbps):             0        20698             0          3788
SRA Previous Speed:       0        20682             0          3788
Previous Speed:           0        20682             0          3788
Reed-Solomon EC:          0        17982             0           387
CRC Errors:           0          985             0           183
Header Errors:            0           21             0             0
Interleave (ms):       0.00         8.00          0.00          0.00
Actual INP:        0.00         3.00          0.00          0.00

Training Log :  Stopped
Training Log Filename : flash:vdsllog.bin

Interface Status

ATM0 is down, line protocol is down 
  Hardware is MPC/AOE ATMSAR, address is e00e.da57.4088 (bia e00e.da57.4088)
  MTU 1600 bytes, sub MTU 1600, BW 4608 Kbit/sec, DLY 80 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ATM, loopback not set
  Keepalive not supported 
  Encapsulation(s): AAL5
  4 maximum active VCs, 1024 VCs per VP, 0 current VCCs
  VC Auto Creation Disabled.
  VC idle disconnect time: 300 seconds
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: Per VC Queueing
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out


Dialer1 is up (spoofing), line protocol is up (spoofing)
  Hardware is Unknown
  Internet address will be negotiated using IPCP
  MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Closed, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 1 seconds on reset
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 00:39:39
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes
     0 packets output, 0 bytes


Ethernet0 is up, line protocol is up 
  Hardware is PQII_VDSL_ETHERNET, address is e00e.da57.408c (bia e00e.da57.408c)
  MTU 1500 bytes, BW 3788 Kbit/sec, DLY 2600 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out


Vlan1 is up, line protocol is up 
  Hardware is EtherSVI, address is e00e.da57.4088 (bia e00e.da57.4088)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported 
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     6261 packets input, 657444 bytes, 0 no buffer
     Received 791 broadcasts (9 IP multicasts)
     0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     3139 packets output, 1065415 bytes, 0 underruns
     0 output errors, 1 interface resets
     3 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out

Please can someone help? I'm clearly missing something very obvious!

2
  • Please try these two config commands: “controller vdsl 0”, then “operating-mode auto”
    – This
    Aug 12 '18 at 2:04
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer.
    – Ron Maupin
    Dec 25 '18 at 9:11
3
 Trained Mode:    G.993.2 (VDSL2) Profile 17a
 TC Mode:         PTM

Your DSL is not using ATM. If it's supposed to be ADSL/ATM, then you need to set the VDSL controller to use that explicitly. Auto detection is finding VDSL2/PTM.

If PTM is correct, then everything goes through Ethernet0. As @jonathanjo points out, there could be VLAN tags as well as PPPoE, or it might be as simple as DHCP on Et0. (or it could require dot1x, which the 897 can't do.)

1

I don't claim to know when you have to configure ATM0 and when you use ethernet0.101 (if you know, please comment!), but a working Cisco 867VAE with VDSL (in the UK) has this in its config:

wan mode dsl
controller VDSL 0
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface Ethernet0
 no ip address
 no cdp enable

interface Ethernet0.101
 encapsulation dot1Q 101
 pppoe-client dial-pool-number 1

interface Dialer1
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1400
 dialer pool 1
 ppp authentication chap callin
 ppp chap hostname redacted@redacted
 ppp chap password 0 redacted
 ppp ipcp dns request
 no cdp enable
8
  • Thanks for your response. This is for PPPoA dialling (RJ11 cable connected to purple VDSL port, not PPPoE over ethernet 0). Does this help?
    – Jack
    Aug 11 '18 at 17:12
  • @Jack, this router is connected exactly the same as yours.
    – jonathanjo
    Aug 11 '18 at 17:48
  • @jonathanjo, just because the router is the same doesn't mean his service is the same. Perhaps you should think about what he's telling you; you might learn something about DSL service offerings
    – This
    Aug 11 '18 at 18:10
  • @Mike, thanks: I'm quite sure I don't know enough about the service offerings, but I don't know what you're saying I've said that is incorrect. Will happily correct it when I find out.
    – jonathanjo
    Aug 11 '18 at 18:28
  • 1
    Sorry Mike, VDSL uses PTM which is Ethernet. ADSL is almost always ATM, but AT&T Uverse has done some stupid **** and does ADSL/PTM in what is called "IP DSL" -- only their hacked firmware can do it.
    – Ricky
    Aug 11 '18 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.