1

I had an issues about EIGRP. But first, here's the topology : Topology I've done EIGRP Routing, but it's kinda strange. PC0 -> PC1 is able to ping, PC3 -> PC2 is able to ping. But, I can't ping PC0 -> PC2, PC0 -> PC3. This also happends on PC1. Here's my all of my router configuration :

-ROUTER0-

interface FastEthernet0/0
 ip address 10.10.0.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip address 10.10.3.1 255.255.255.252
!
interface FastEthernet0/1
 ip address 192.168.1.254 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 10
 network 10.0.0.0
 network 192.168.0.0
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
 network 192.168.4.0
 auto-summary
!
ip classless
ip route 192.168.0.0 255.255.255.0 FastEthernet0/1 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

-ROUTER1-

interface FastEthernet0/0
 ip address 10.10.0.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/0.30
 encapsulation dot1Q 30
 ip address 10.10.1.1 255.255.255.252
!
interface FastEthernet0/1
 ip address 192.168.2.254 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 10
 network 10.0.0.0
 network 192.168.0.0
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
 network 192.168.4.0
 auto-summary
!
ip classless
ip route 192.168.0.0 255.255.255.0 FastEthernet0/1 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

-ROUTER2-

interface FastEthernet0/0
 ip address 10.10.2.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/0.30
 encapsulation dot1Q 30
 ip address 10.10.1.2 255.255.255.252
!
interface FastEthernet0/1
 ip address 192.168.3.254 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 auto-summary
!
router eigrp 10
 network 10.0.0.0
 network 192.168.0.0
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
 network 192.168.4.0
 auto-summary
!
ip classless
ip route 192.168.0.0 255.255.255.0 FastEthernet0/1 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

-ROUTER3-

interface FastEthernet0/0
 ip address 10.10.2.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip address 10.10.3.2 255.255.255.252
!
interface FastEthernet0/1
 ip address 192.168.4.254 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 10
 network 10.0.0.0
 network 192.168.0.0
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
 network 192.168.4.0
 auto-summary
!
ip classless
ip route 192.168.0.0 255.255.255.0 FastEthernet0/1 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

It's seems the routing is up. But anyone know why this happend? Thank you.

5
  • 1
    Please add the configuration of the fifth device in this setup: the Cat3560. Please modify the diagram so that it becomes clear which 10.10.x.0/30 belongs to which device-to-device link. You'll have to decide what the cat3560's role should be: A) a Layer3-switch, participating in EIGRP and routing, or B) a Layer2-switch, just offering VLANs that the routers can use as if they had direct cables to any/some/all of the other routers. Aug 16, 2018 at 10:39
  • What's the thinking with using both tagged and untagged interfaces on the same ports on those routers? You could probably hack something together using different native VLAN's on trunk ports on the 3560's and then SVI's, but it's a pretty screwy design. You'd be better off running multiple subinterfaces on the Fa0/0 router ports and then setting up standard trunks and SVI's for inter-router and router/switch connections respectively.
    – rnxrx
    Aug 16, 2018 at 19:24
  • Maybe I'm missing something but, why are you advertising all of your networks out of each router instead of only the networks each router actually has? What I mean is, you don't have alternate/backup paths to each site from each router, in the event the switch went down, so why would you be expecting each router to receive traffic for networks they don't actually have?
    – Jesse P.
    Aug 17, 2018 at 12:08
  • @Jesse P: the 'network' statement in EIGRP (and in OSPF) does not define what networks the router advertises. The network statements are just a filter list, and every IP interface on the given router that has an IP adress matching the filter will be activated as an EIGRP interface. Different story with BGP; here, 'network' statements actually generate routing advertismens (when some other prerequites are met). Aug 18, 2018 at 8:25
  • @Marc'netztier'Luethi Ahh. You're right. I don't know why I was mixing them up - I knew that. Maybe old age is setting in quicker than I thought.
    – Jesse P.
    Aug 18, 2018 at 12:16

2 Answers 2

2

I've created the same topology as showed on an image and put into routers your configs and I'm able to ping all PC's from PC0. All PC's have IP addresses in a same /24 network as routers Fa0/1 interfaces and all have default-gateways set to router's IP (192.168.x.254).

Configuration of Cat 3560:

interface FastEthernet0/1
 switchport trunk allowed vlan 1,20
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk allowed vlan 1,30
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/3
 switchport trunk allowed vlan 1,30
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/4
 switchport trunk allowed vlan 1,20
 switchport trunk encapsulation dot1q
 switchport mode trunk
!

Also I've created VLANs on switch:

Switch(config)# vlan 20
Switch(config)# vlan 30

Ping results:

C:\>ping 192.168.2.1

Pinging 192.168.2.1 with 32 bytes of data:

Request timed out.
Reply from 192.168.2.1: bytes=32 time<1ms TTL=126
Reply from 192.168.2.1: bytes=32 time<1ms TTL=126

Ping statistics for 192.168.2.1:
    Packets: Sent = 3, Received = 2, Lost = 1 (34% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

Control-C
^C
C:\>ping 192.168.3.1

Pinging 192.168.3.1 with 32 bytes of data:

Request timed out.
Reply from 192.168.3.1: bytes=32 time<1ms TTL=125
Reply from 192.168.3.1: bytes=32 time<1ms TTL=125

Ping statistics for 192.168.3.1:
    Packets: Sent = 3, Received = 2, Lost = 1 (34% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

Control-C
^C
C:\>ping 192.168.4.1

Pinging 192.168.4.1 with 32 bytes of data:

Request timed out.
Reply from 192.168.4.1: bytes=32 time<1ms TTL=126
Reply from 192.168.4.1: bytes=32 time=1ms TTL=126

Ping statistics for 192.168.4.1:
    Packets: Sent = 3, Received = 2, Lost = 1 (34% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms

Control-C
^C
4
  • Please edit your answer using the proper formatting and include your full router and switch configs. It doesn't look like your configs match the OP and he didn't provide a switch config so there's no telling if yours matches theirs.
    – Jesse P.
    Aug 17, 2018 at 19:46
  • @JesseP. as I said, I just did Ctrl+C Ctrl+V of author routers configs and did no changes to them. The only blackbox in this schema is as switch. So I provided every configuration change for switch in my post. I see no reason to put again the same routers configuration again. Aug 18, 2018 at 13:31
  • I primarily wanted you to correct the formatting so it was readable (which appears to have been done now).
    – Jesse P.
    Aug 18, 2018 at 13:37
  • Nah, this one works well. i just created VLAN on the CoreSwitch (VLAN20 & VLAN30). Thank you sir, marked as solved my problems. Aug 20, 2018 at 3:52
2

After looking at the network diagram once more and thinking of the hints the OP got ("subinterfaces"), I think I now see where this is meant to go.

This answer assumes:

  • the Cat3560 will not participate in routing
  • the Cat3560 just has a set of VLANs, and each one serves as the emulation of a point-ot-point link from one router to one other router, almost as good as if the had a direct cable to each other.
  • the 10.10.x.0/30 subnets are used on these point-to-point links.

There is an alternative setup that also solves the challenge, but requires L3-switching (and probably EIGRP, for the fun of it) to run also on the Cat3560. I would've preferred that alternative, but the challenge seems to be twofold: L2-switching with VLANs on the Cat3560, and (dynamic) routing with subinterfaces on the routers, so we'll work towards that.

This will require some VLANs on the switch:

vlan 10
 name R0-to-R1

vlan 20
 name R0-to-R3

vlan 30
 name R3-to-R2

vlan 40
 name R2-to-R1

And a selective mapping of VLANs to the 4 switchports where the routers are connected to:

int f0/1
 description Router0 fa0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
 spanning-tree portfast trunk

int f0/2
 description Router1 fa0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,40
 spanning-tree portfast trunk

int f0/3
 description Router2 fa0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
 spanning-tree portfast trunk

int f0/4
 description Router3 fa0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 20,30
 spanning-tree portfast trunk

Please note: technically, it is not necessary to have switchport trunk allowed vlan... on the switch ports. Creating the VLANs and setting the port to mode trunkwould be sufficient. In a well-maintained environment, it is good practice to define which (set of) VLAN(s) is acceptable on a given switchport.

Then, on each router, you'll need

  • the LAN interface 192.168.x.0/24. I'll be picking the .1 for the router. Some people prefer the last address in the subnet (.254) - it's just a question of taste, guidelines and operational practice of the given environment.
  • two subinterfaces on the WAN side, separated by VLAN tags
  • a decent EIGRP setup, see comments in the command snippet.

I'll give the example for one router - the others will be left as an exercise to the reader.

!=========
!ROUTER 0
!========

int f0/0
 description Switch0 fast0/1

int f0/0.10
 description Router1 fast0/0.10 (via VLAN 10)
 enapsulation dot1q 10
 ip adress 10.10.0.1 255.255.255.252

int f0/0.20
 description Router3 fast0/0.20 (via VLAN 20)
 encapsulation dot1q 20
 ip adress 10.10.3.1 255.255.255.252

int fa0/1
 description LAN to PC0
 ip address 192.168.1.1 255.255.255.0


router eigrp 1
!
! Summarization is for large networks with multiple hierarchies and
! tiers of routing. 
! It just creates obstacles for a novice. Leave it off. (almost) always.
!
 no auto-summary 
!
! for the sake of clarity, add the to-be-EIGRP-activated 
! interfaces with the host wildcard mask. 
! in EIGRP, the network statements just define a filter list of IP adresses. 
! Interfaces on the router that have an address matching the 
! filter will be enanbled for EIGRP.
!   
 network 192.168.1.1 0.0.0.0
 network 10.10.0.1 0.0.0.0
 network 10.10.3.1 0.0.0.0
!
!
! good practice (optional): Don't be looking for EIGRP neighbors 
! in "client subnets", where there won't be any. 
! Make all interfaces passive, then explicitely enable 
! the (sub)interfaces that will actually have to speak EIGRP 
! to potential neighbors.
!
! YES, it is actually correct and valid to have the LAN 
! side enabled for EIGRP, but then leave it passive.

 passive-interface default
 no passive-interface fast0/0.10
 no passive-interface fast0/0.20
1
  • +1 for this answer. Good explanation also I like how you representate the router configuration. Thank you. This method also works as well. ^^ Aug 20, 2018 at 5:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.