1

I have a 4 routers that connected each other via an multilayer switch. Is it possible to remove/block an EIGRP neighbors via Switch?

For example, I have a topology like this : enter image description here

I wanted to remove EIGRP neighbors from RA to RB (10.10.0.2), but PC0 and PC1 still able to ping each other after I removed it via Switch. Is it possible? Thanks.

Router0#sh ip eigrp ne
IP-EIGRP neighbors for process 10
H   Address         Interface      Hold Uptime    SRTT   RTO   Q   Seq
                                   (sec)          (ms)        Cnt  Num
0   10.10.3.2       Fa             13   00:14:48  40     1000  0   42
1   10.10.0.2       Fa0/0          11   00:11:53  40     1000  0   42

Here's the Core Switch configuration :

 hostname Switch
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
 switchport trunk allowed vlan 10,20
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast trunk
!
interface FastEthernet0/2
 switchport trunk allowed vlan 10,40
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast trunk
!
interface FastEthernet0/3
 switchport trunk allowed vlan 30,40
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast trunk
!
interface FastEthernet0/4
 switchport trunk allowed vlan 20,30
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast trunk
!

Here's each router configuration:

-Router0-

spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 10.10.0.1 255.255.255.252
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip address 10.10.3.1 255.255.255.252
!
interface FastEthernet0/1
 ip address 192.168.1.254 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 10
 network 10.0.0.0
 network 192.168.0.0
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
 network 192.168.4.0
 no auto-summary
!
ip classless
ip route 192.168.0.0 255.255.255.0 FastEthernet0/1 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

-Router1-

spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 10.10.0.2 255.255.255.252
!
interface FastEthernet0/0.20
 no ip address
 shutdown
!
interface FastEthernet0/0.30
 encapsulation dot1Q 30
 ip address 10.10.1.1 255.255.255.252
 shutdown
!
interface FastEthernet0/0.40
 encapsulation dot1Q 40
 ip address 10.10.1.1 255.255.255.252
!
interface FastEthernet0/1
 ip address 192.168.2.254 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 10
 network 10.0.0.0
 network 192.168.0.0
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
 network 192.168.4.0
 no auto-summary
!
ip classless
ip route 192.168.0.0 255.255.255.0 FastEthernet0/1 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

-Router2-

spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.30
 encapsulation dot1Q 30
 ip address 10.10.2.1 255.255.255.252
!
interface FastEthernet0/0.40
 encapsulation dot1Q 40
 ip address 10.10.1.2 255.255.255.252
!
interface FastEthernet0/1
 ip address 192.168.3.254 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 auto-summary
!
router eigrp 10
 network 10.0.0.0
 network 192.168.0.0
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
 network 192.168.4.0
 no auto-summary
!
ip classless
ip route 192.168.0.0 255.255.255.0 FastEthernet0/1 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

-Router3-

spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip address 10.10.3.2 255.255.255.252
!
interface FastEthernet0/0.30
 encapsulation dot1Q 30
 ip address 10.10.2.2 255.255.255.252
!
interface FastEthernet0/1
 ip address 192.168.4.254 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 10
 network 10.0.0.0
 network 192.168.0.0
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
 network 192.168.4.0
 no auto-summary
!
ip classless
ip route 192.168.0.0 255.255.255.0 FastEthernet0/1 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end
2
  • You should really use the no auto-summary router command, and you should be more specific on your 10.0;0.0 networks since you have those subnetted with a longer mask. Also, remove the static routes you have configured because that defeats the purpose of the routing protocol.
    – Ron Maupin
    Aug 20, 2018 at 14:38
  • Roger that, router configuration updated. Aug 21, 2018 at 6:57

1 Answer 1

1

EDITED

The first thing I want to point out is that when you share only partial information, we have to make assumptions, and they can be wrong. The more information you give us, the better our answers will be.

Now that you have provided the device configurations, I've taken the liberty of creating a new diagram to show you one way to better represent your network. This is a logical view that makes the interconnections between the routers much clearer.

Network Diagram

Now that we can see the true topology, there are a number of ways to accomplish your goal.

Option 1. You have to configure static neighbors on all your routers. The eigrp neighbor command uses unicast hellos instead of multicast, so you have to specify who the neighbors are on all routers. For example:

router eigrp 1
network 10.0.0.0
network 192.168.0.0
neighbor 10.10.3.2 fa 0/0

Option 2. Configure passive interface on the link:

router eigrp 1
passive-interface fa0/0.10

Option 3. Remove the interface from the routing domain.

router eigrp 10
network 10.10.3.0 0.0.0.3
network 192.168.1.0

Note that EIGRP does not run on interface fa0/0.10

15
  • Did I need to reconfigure my router from scratch or I just added this static neighbors to my current routers configuration? Aug 20, 2018 at 12:27
  • Just and the neighbor commands to your configuration. As a general rule, you never have to configure your routers from scratch. If something needs to be removed, you can just use the no command. For example, to remove the eigrp configuration, you just use "no router eigrp".
    – Ron Trunk
    Aug 20, 2018 at 12:35
  • So, I just configuring these static neighbors? No need to add any configuration on switch? Aug 20, 2018 at 12:45
  • What is your current switch configuration? Edit your question to include it.
    – Ron Trunk
    Aug 20, 2018 at 12:47
  • Added. I configuring each port that connect to each router with trunk and adding encap dot1q. Aug 20, 2018 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.