1

I have just turned up two t1 lines hooked into two AdTran NetVanta 3430 routers. While the NetVanta boxes seem fine, what I really want to do is to configure some of my old Cisco boxes to handle the T1s rather than bridging from the AdTran boxes to the Cisco boxes.

The problem I'm having is that I'm not quite sure how to get CHAP working properly with the Cisco boxes to allow the Cisco boxes to connect via their serial interface and get and IP established upline dynamically. I already have yet another T1 which has a fixed IP setup I implemented a number of years ago, and that has been working just fine, unfortunately, I'm not sure I can get my vendor to provide the static upline option for the new circuits, thus this post.

Any thoughts would be greatly appreciated. I'll post the AdTran configuration to follow:

config t
!
hostname "SomeHostName"
enable password somepassword
!
no ip firewall
!
ip subnet-zero
ip classless
ip routing
ipv6 unicast-routing
bridge irb
!
name-server 8.8.8.8 4.2.2.2
auto-config
!
event-history on
no logging forwarding
no logging email
!
no service password-encryption
!
username "somelocaluser" password "somepassword"
!
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
no dot11ap access-point-control
!
no ethernet cfm
!
interface eth 0/1
    bridge-group 1
    no ip address
    no shutdown
!
interface eth 0/2
    bridge-group 1
    no ip address
    no shutdown
!
interface t1 1/1
    description FR
    tdm-group 1 timeslots 1-24 speed 64
    no shutdown
!
interface bvi 1
    mac-address 00:00:00:00:43:76
    ip address 10.0.1.1 255.255.255.0 ' Some actually routable IP block (not really in the 10/8 range)
    ip mtu 1500
    no shutdown
!
Interface fr 1 point-to-point
    frame-relay lmi-type ansi
    no fair-queue
    no shutdown
    cross-connect 1 t1 1/1 1 frame-relay 1
!
Interface fr 1.1 point-to-point
    frame-relay interface-dlci 16
    description fr 1.1
    snmp trap link-status
    no ip address
    ip mtu 1500
!
interface ppp 1
    description PPP
    ip address negotiated
    no fair-queue
    ppp chap hostname someremotehostname
    ppp chap password someremotehostpass
    no shutdown
    cross-connect 2 frame-relay 1.1 ppp 1
!
!
ip route 0.0.0.0 0.0.0.0  frame-relay 1.1
!
no tftp server
no tftp server overwrite
no http server
http secure-server
no snmp agent
no ip ftp server
ip ftp server default-filesystem flash
no ip scp server
no ip sntp server
!
sip udp 5060
sip tcp 5060
!
line con 0
    login
!
line telnet 0 4
    login
    password someotherpassword
    shutdown
line ssh 0 4
    login local-userlist
    no shutdown
!
end
!
!
write

Even just a skeletal Cisco translation is greatly appreciated. In other words, something like the CHAP stuff in ppp belongs on Cisco interface x, the bvi should be a subchannel of the serial interface... Just need a few clues, as I cannot find any similar configurations for the Cisco which do CHAP, point-to-point frame relay for t1, despite a fair amount of time in search engines over the past week.

Heck, I'd be very grateful for a link to a configuration like the AdTran.

Thanks in advance, if there is anything else needed to point me in the right direction, I'll be happy to post a follow on to supply it.

  • PPP over frame... that takes me back to the 80s. – Ricky Beam Aug 27 '18 at 1:29
  • It would be more like the 90s for me, but yeah... In any case, if you are prepared for some consulting and can remember back to the 80s, I'm prepared to pay a bit for a solution. I'm beginning to feel a bit like Shakespear's monkeys, but unlike them, I don't have unlimited time. :-) – Commerce Aug 27 '18 at 15:33
  • Ricky - Owe you something for the help, certainly my thanks. Connectivity seems to be there, but the PPP CHAP stuff is not going well. Will continue to slog away at it. – Commerce Aug 31 '18 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.