1

I have a cisco SF 300 switch which is connected to a chinese brand BDCOM switch (2500 series full gigabit port) . When both the ports of switch are configured in access mode, it works. But when they are configured in trunk mode tagging two vlans , it doesn't work. I need to pass two vlans in between these two switches. What might be the issue ? Here is the configuration of cisco switch:

interface gigabitethernet1 switchport trunk allowed vlan add 17,2029 !

BDCom switch configuration:

interface GigaEthernet0/51
switchport trunk vlan-allowed 17,2029
switchport mode trunk

Adding more: there is only single link in between two switches. If there was multiple physical link between them, we could suspect about STP issue. But it was not the case.

  • You would need to edit your question to include the switch configurations. We can only speculate or guess (off-topic here) without more information. – Ron Maupin Sep 2 '18 at 15:19
  • Please give us the full (sanitized) switch configurations. There are other configurations than the interface configurations that can affect this, and we need to see them. – Ron Maupin Sep 2 '18 at 15:39
  • 2
    Type "show spanning-tree vlan 17" and the equivalent command on the BDCom switch, and add the output to your question. – Ron Trunk Sep 2 '18 at 16:44
  • Please accept your own answer, so that the question does not keep popping up. – user36472 Nov 3 '18 at 9:17
0

I realized that the problem was with STP. The Bdcom switch interface was in blocking mode. So I manually disable STP in both the connecting interfaces at both switches: BDcom and cisco.

For Bdcom:

interface GigaEthernet0/36
switchport trunk vlan-allowed 17,18
switchport mode trunk
spanning-tree bpdufilter enable

For Cisco:

interface gigabitethernet1
spanning-tree disable
switchport trunk allowed vlan add 17,18

I am not clearly understanding though how STP status is changing in trunk mode. But it worked after disabling STP.

  • 2
    You haven't told us anything about multiple connections between both switches - how are we supposed to solve your problem? Generally, multiple connections between switches are blocked (=need to be blocked) by STP to prevent bridge loops. Alternatively, multiple links between two switches can be aggregated (LAG). If there are only single links between the switches you've got a problem with the BDPU guard configuration or similar. Deactivating STP is not a good idea generally. – Zac67 Sep 3 '18 at 15:17
  • There was not multiple connections between two switches, only single link was there. But as you said there may be problem with the BPDU guard configuration. – Shyamkkhadka Sep 3 '18 at 15:29
  • 1
    There is some other problem, and disabling STP is a dangerous way to get around the problem. If you would simply edit your question to include what people has asked, then we could try to help you determine the root of the problem and solve it correctly. – Ron Maupin Sep 3 '18 at 16:40
0

A very common issue is someone using ISL trunking protocol on non Cisco switches. 802.1q will need to be used on both sides of the link for trunking to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.