1

below is a capture of the configuration. R1 can ping the other two routers but R2 and R3 can't ping each other. Any idea what my issue could be? Screen Shot 2018-09-03 at 2.57.00 PM.pngenter image description here

Router2#sh run

interface GigabitEthernet0/0 
ip address 192.168.2.2 255.255.255.240 
duplex auto 
speed auto 

Router1:

interface GigabitEthernet0/0 
ip address 192.168.2.1 255.255.255.240 
duplex auto 
speed auto 
! 
interface GigabitEthernet0/1 
no ip address 
duplex auto 
speed auto 
shutdown 
! 
interface Serial0/0/0 
ip address 192.168.2.17 255.255.255.240 
clock rate 2000000 

Router3:

interface Serial0/0/0 
ip address 192.168.2.18 255.255.255.240 
! 
interface Serial0/0/1 
no ip address 
clock rate 2000000 
shutdown 
! these are the changes made to the routers 
  • We need more information. Please edit your question to include the router configurations. – Ron Maupin Sep 3 '18 at 20:11
  • Unfortunately, homework and test questions are off limits on this site. This question is best asked over on Super User – Jesse P. Sep 3 '18 at 20:25
  • Router2#sh run interface GigabitEthernet0/0 ip address 192.168.2.2 255.255.255.240 duplex auto speed auto Router1: interface GigabitEthernet0/0 ip address 192.168.2.1 255.255.255.240 duplex auto speed auto ! interface GigabitEthernet0/1 no ip address duplex auto speed auto shutdown ! interface Serial0/0/0 ip address 192.168.2.17 255.255.255.240 clock rate 2000000 Router3: interface Serial0/0/0 ip address 192.168.2.18 255.255.255.240 ! interface Serial0/0/1 no ip address clock rate 2000000 shutdown ! these are the changes made to the routers – Diallo Abdoul Sep 3 '18 at 20:28
  • Without configs, we cannot say. Most common issues: (a) R1 not configured for routing. (b) routing isn't setup correctly. – Ricky Beam Sep 3 '18 at 20:30
  • I just sent the configuration. All I did was assigning IPs to the routers, nothing else. I just don't know the routers to the extremities do not ping each other – Diallo Abdoul Sep 3 '18 at 20:35
2

Since you didn't include the full router configurations, I must assume you do not have any static routes or routing protocols configured.

Routers learn routes in three ways:

  • Directly connected networks
  • Statically configured routes
  • Dynamically through a routing protocol

Router 2 has no knowledge of the network on the other side of Router 1, and the same things holds for Router 3. If a router has a packet with a destination to an unknown network, it drops the packet. Router 2 doesn't know how to reach the network with Router 3, so it drops packets destined for Router 3, and Router 3 has no knowledge of the network of Router 2, so it drops packets destined for Router 2. That is how it should be.

You will either need to configure static routes on Router 2 and Router 3, or you will need to run a common routing protocol on your routers.

On router 2, you can create a static route:

ip route 192.168.2.16 255.255.255.240 192.168.2.1

On Router 3, you can create a static route:

ip route 192.168.2.0 255.255.255.240 192.168.2.17
  • Thank you so much Ron, it works now. So, if I understood your answer. Although R2 and R3 are directly connected to R1, I still need to configure a routing protocol? Why can't R2 and R3 learn routes from R1, or it's only on certain situations that can be possible? – Diallo Abdoul Sep 3 '18 at 21:40
  • R2 and R3 can learn routes from R1, but you would need to run a routing protocol for that. I explained the three ways that routers learn routes. R2 is not connected to the R1-R3 network, so method 1 is out. That means that you either need to statically configure the route, or you need to configure a routing protocol (RIP, EIGRP, OSPF, IS-IS, etc.). – Ron Maupin Sep 3 '18 at 21:47
  • Okay got it now, thx again. – Diallo Abdoul Sep 3 '18 at 21:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.