3

what do the ! and . mean in switch config files?

Current configuration: 1363 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch A
!
Command Purpose
Step 1 configure terminal Enter global configuration mode.
enable secret 5 $1$ej9.$DMUvAUnZOAmvmgqBEzIxE0
!
.
<output truncated>
.
interface gigabitethernet0/1
ip address 172.20.137.50 255.255.255.0
!
interface gigabitethernet0/2
mvr type source
<output truncated>
...!
interface VLAN1
 ip address 172.20.137.50 255.255.255.0
 no ip directed-broadcast
!
ip default-gateway 172.20.137.1 !
!
snmp-server community private RW
snmp-server community public RO
snmp-server community private@es0 RW
snmp-server community public@es0 RO
snmp-server chassis-id 0x12
!
end 
3
  • Hello and welcome to Network Engineering. In a Cisco environment ! indicates a comment or command lines to be ignored. . is indications, that configuration has been truncated (removed) from the original config. – user36472 Sep 11 '18 at 6:06
  • So in this example case that I posted ! has just been used to make code more readable? Coz nothing follows !. Thanks Cown. – robinhoodjr Sep 11 '18 at 6:14
  • Yes, in order to make the configurations more readable, Cisco made the ! and added it between all the configuration sections to give it simplicity and make it more readable. – user36472 Sep 11 '18 at 6:20
4

In a Cisco environment, when utilizing show running-config and show startup-config the exclamation (!) points are only there to help in formatting the output to make it more readable and create space between sections in the config.

The period (.) is used to truncate (remove) long sections of config, that is identical.

They do not have any other meaning.

-1

hi is just googled myself here because in some cases these ! are absolute irritating ie. in this output where the grouped logic of "aaa authentication login telnet local (and) username cisco password 0 Ocsic " is ripped by that !. For my logic I dont group those lines without having a prior knowledge about the output:

aaa new-model
aaa authentication login default none
aaa authentication login telnet local
!
username cisco password 0 Ocsic
!
line vty 0
password LetMeIn
login authentication telnet
transport input telnet
line vty 1
password LetMeIn
transport input telnet
1
  • This does not seem to answer the question. – Teun Vink Sep 21 '20 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.