6

I am having a puzzling issue with OSPF connectivity on one of my routers. The other routers in my network have formed an adjacency and are working correctly, but this last one is a case I've never seen before. All of the interfaces on the remaining router are up and functional and are connected to AREA 0 just as the other two routers are. However, a show ip ospf command results in the following:

 Area BACKBONE(0) (Inactive)

        Number of interfaces in this area is 3

Additionally, I get nothing if I try to ping 224.0.0.5 or 224.0.0.6 from this router. I've tried restarting the OSPF process on the router as well as rebooting the router itself, but it makes no difference. When I turn debugging on, I can see the router isn't even sending OSPF hello messages. What could be the cause of something like this?

The router interfaces are configured as follows for the router in question:

f0/0 - 111.1.0.2/8
f0/1 - 112.1.0.2/8
f0/2/0 - (Vlan5) 122.0.0.1/8
f0/2/3 - (Vlan88) 10.10.10.1/28

Here is the entire router config along with OSPF process info and interface statuses:

router_1#sh ip ospf 
 Routing Process "ospf 10" with ID 122.0.0.1
 Start time: 00:00:19.304, Time elapsed: 18:57:25.596
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Supports Link-local Signaling (LLS)
 Supports area transit capability
 Router is not originating router-LSAs with maximum metric
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Incremental-SPF disabled
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 Number of areas transit capable is 0
 External flood list length 0
 IETF NSF helper support enabled
 Cisco NSF helper support enabled
    Area BACKBONE(0) (Inactive)
    Number of interfaces in this area is 3
    Area has no authentication
    SPF algorithm last executed 01:36:13.484 ago
    SPF algorithm executed 3 times
    Area ranges are
    Number of LSA 1. Checksum Sum 0x00F9B7
    Number of opaque link LSA 0. Checksum Sum 0x000000
    Number of DCbitless LSA 0
    Number of indication LSA 0
    Number of DoNotAge LSA 0
    Flood list length 0

 router_1#sh ip int br
    Interface                  IP-Address      OK? Method Status                Protocol
    FastEthernet0/0            111.1.0.2       YES NVRAM  up                    up      
    FastEthernet0/1            112.1.0.2       YES NVRAM  up                    up      
    FastEthernet0/2/0          unassigned      YES unset  up                    up      
    FastEthernet0/2/1          unassigned      YES unset  administratively down down    
    FastEthernet0/2/2          unassigned      YES unset  administratively down down    
    FastEthernet0/2/3          unassigned      YES unset  up                    up      
    Vlan1                      unassigned      YES NVRAM  administratively down down    
    Vlan5                      122.0.0.1       YES NVRAM  up                    up      
    Vlan88                     10.10.10.1      YES NVRAM  up                    up      

router_1#sh run
Building configuration...

Current configuration : 3904 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router_1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$iXM1$Rcki3hrzpXULV8lCJXDqY1
!
no aaa new-model
!
!
ip cef
!
!
no ip domain lookup
multilink bundle-name authenticated
!
!
!
username thedoctor privilege 15 secret 5 $1$KUwA$VWYQeI/fm8LacwgysL7RK/
archive
 log config
  hidekeys
!
!
!
class-map match-all data-inmmediate
 match ip dscp af13 
class-map match-all class-all
 match any 
class-map match-all data-priority
 match ip dscp af23 
class-map match-all data-routine
 match ip dscp default 
class-map match-all data-flash
 match ip dscp default 
 match ip dscp af33 
class-map match-all video
 match ip dscp cs4  33  af41  35  af42 
class-map match-all data-flash-override
 match ip dscp 31 
class-map match-all voice
 match ip dscp cs5  41  42  43  44 
!
!
policy-map ecn-llq-enable
 class voice
  priority 48
 class video
  bandwidth percent 1
  random-detect dscp-based
  random-detect exponential-weighting-constant 1
  random-detect ecn
  random-detect dscp 32   8     16    16   
  random-detect dscp 33   16    24    16   
  random-detect dscp 34   24    32    16   
  random-detect dscp 35   32    40    16   
  random-detect dscp 36   40    48    16   
 class data-flash-override
  bandwidth percent 35
  random-detect dscp-based
  random-detect exponential-weighting-constant 1
  random-detect ecn
  random-detect dscp 31   70    4000  2    
 class data-flash
  bandwidth percent 1
  random-detect dscp-based
  random-detect exponential-weighting-constant 1
  random-detect ecn
  random-detect dscp 30   80    96    16   
 class data-priority
  bandwidth percent 1
  random-detect dscp-based
  random-detect exponential-weighting-constant 1
  random-detect ecn
  random-detect dscp 22   96    112   12   
 class data-inmmediate
  bandwidth percent 1
  random-detect dscp-based
  random-detect exponential-weighting-constant 1
  random-detect ecn
  random-detect dscp 14   112   128   8    
 class data-routine
  bandwidth percent 25
  random-detect dscp-based
  random-detect exponential-weighting-constant 1
  random-detect ecn
  random-detect dscp 0   2     4000  2    
policy-map shape-all-ncw
 class class-all
  shape average 128000
  service-policy ecn-llq-enable
policy-map shape-all-hnw
 class class-all
  shape average 1000000
  service-policy ecn-llq-enable
!
!
!
!         
interface FastEthernet0/0
 description Intermidiate_Router_GW
 ip address 111.1.0.2 255.0.0.0
 ip ospf cost 400
 duplex auto
 speed auto
 service-policy output shape-all-hnw
!
interface FastEthernet0/1
 description Router2
 ip address 112.1.0.2 255.0.0.0
 ip ospf cost 600
 duplex auto
 speed auto
 service-policy output shape-all-hnw
!
interface FastEthernet0/2/0
 description ENCRYPTION1
 switchport access vlan 5
!
interface FastEthernet0/2/1
 shutdown
!
interface FastEthernet0/2/2
 shutdown
!
interface FastEthernet0/2/3
 description AF_NM
 switchport access vlan 88
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan5
 description ENCRYPTION1
 ip address 122.0.0.1 255.0.0.0
!
interface Vlan88
 description AF_NM
 ip address 10.10.10.1 255.255.255.248
!
router ospf 10
 log-adjacency-changes
 network 111.0.0.0 0.255.255.255 area 0
 network 112.0.0.0 0.255.255.255 area 0
 network 122.0.0.0 0.255.255.255 area 0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 120.0.0.1
ip route 122.1.1.0 255.255.255.0 122.0.0.2
ip route 122.1.2.0 255.255.255.0 122.0.0.2
!         
!
ip http server
ip http access-class 23
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 23 permit 10.10.10.0 0.0.0.7
!
!
control-plane
!
!
line con 0
 login local
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet
line vty 5 15
 privilege level 15
 login local
 transport input telnet
!
scheduler allocate 20000 1000
!
end
  • 2
    Can you post your configuration and show ip ospf interface? – Daniel Dib Dec 4 '13 at 17:32
  • Here's a link that may be helpful: learningnetwork.cisco.com/thread/7177#30411 – Ron Trunk Dec 4 '13 at 19:17
  • @Daniel Dib - I've updated with the output you asked for. – THE DOCTOR Dec 4 '13 at 19:52
  • @Ron - I looked at the forum post already, but unfortunately none of it seems to apply to my situation. – THE DOCTOR Dec 4 '13 at 19:54
  • 3
    I just tested this in a lab setup, and the router stayed in inactive state until it sees a neighbor on one of its interfaces (just being up isn't enough). So now I'm more interested in your actual config. Can your neighbors ping each other? Are you by chance using loopback interfaces? OSPF won't send hellos on loopbacks. – Ron Trunk Dec 4 '13 at 20:47
6

Well, this is kinda funny. Firstly, I should mention that this is a project that I was recently asked to work on where everyone that previously worked on it has left the company and there is next to no documentation. All I had to go on was a grossly inaccurate network topology diagram which I am in the process of redrawing.

Anyway, after investigating a million other things, I traced the tremendous mess of cables behind the server racks to look at the multiple ethernet cables from the segment that wasn't talking to the rest of the network. This is where I saw no link lights for the ethernet ports on the back of a server whereas the front panel showed several green lights. What I found out is that the front panel of the server will show those green lights even when it isn't turned on! Since it was off, there was no active connection from that particular server rack to the rest of the network. After turning it on, I checked the router again and AREA 0 is no longer inactive. It now has its OSPF neighbors and routes that it should have and the end devices are able to communicate properly. So, everything works now that the server has been turned on.

In summary, one needs to always ask the following two questions:

  1. Are you sure it's plugged in?
  2. Have you tried turning it off and on again?
| improve this answer | |
  • oooooh, sometimes shoot from the hip troubleshooting is inferior to bottom up troubleshooting :D – John Kennedy Dec 27 '13 at 18:53
  • 2
    or use ospf debug commands ;-) – Mike Pennington Dec 27 '13 at 18:55
  • I did use the debug commands, but they didn't tell me much except that I was receiving no hello messages or anything even though all my local router interfaces were up since the server was something like 2 hops away. – THE DOCTOR Dec 27 '13 at 18:58
  • @THEDOCTOR, that's why you use debug commands, if you don't see bidirectional hellos, figure out why. Up doesn't mean adjacent as far as ospf is concerned – Mike Pennington Dec 27 '13 at 19:32
  • That was actually one of my first troubleshooting steps, but I was focusing too much on the possibility of it being a layer 3 or layer 4 issue. – THE DOCTOR Dec 27 '13 at 19:37
0

The interfaces in Area 0 must be UP

| improve this answer | |
  • 1
    Yes, they are. Status and protocol for all interfaces are UP. – THE DOCTOR Dec 4 '13 at 17:02
  • Also, make sure the interfaces of the adjacent routers are not passive. Can you also post the configs from the neighbour routers. – Indu Reddy Dec 4 '13 at 21:28
-6

Use Serial Interfaces to connect routers.

Most the time using NIC like Fast Ethernet or Gigabit interface won't operate in routing process.

| improve this answer | |
  • 5
    "Most the time using NIC like Fast Ethernet or Gigabit interface won't operate in routing process." Where did you get that bizarre idea? All the router interfaces that are assigned addresses, including virtual interfaces, can participate in the routing process. – Ron Maupin Apr 2 '18 at 16:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.