2

I have a problem with Dhcp of some the Vlans. here is how my network is :

I have a router ASR1001, which connects 15 switches(2960) as a ring topology. each switch has a subinterface of the router and the dhcp of all the switches is created at the router. here is the configuration of dhcp:

ip dhcp excluded-address 192.168.90.1 192.168.90.10
ip dhcp excluded-address 192.168.90.254


ip dhcp pool SITEA
network 192.168.90.0 255.255.255.0
default-router 192.168.90.254
dns-server 8.8.8.8 8.8.4.4
lease 8

and the subinterface config for each switch is:

interface GigabitEthernet0/0/1.90
description "SITEA"
encapsulation dot1Q 90
ip address 192.168.90.254 255.255.255.0
ip nbar protocol-discovery

The problem I have facing is that VLAN cannot receive dynamic IP address but can receive static ip address.

I tried removing the dhcp config for that vlan and created again, still the same. I also tried rebooting the switch, didn't help also.

Any suggestions.

Full config of the switch:

Building configuration...

Current configuration : 17949 bytes
!
! Last configuration change at 14:48:28 Africa Thu Sep 13 2018
!
version 15.2
no service pad
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname SITEA
!
boot-start-marker
boot-end-marker
!
logging buffered 64000
logging console informational
enable secret xx
!
no aaa new-model
clock timezone Africa 3 0
switch 1 provision ws-c2960x-24pd-l
!
!
ip dhcp snooping vlan 10-150
no ip dhcp snooping information option
ip dhcp snooping database flash:DHCPSnoopingDB
ip dhcp snooping database write-delay 60
ip dhcp snooping
no ip domain-lookup
ip name-server 8.8.8.8
vtp mode transparent
!
!
!
!
!
!
!

spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
vlan 10
 name CA
!
vlan 20
 name BA
!
vlan 30
 name DA
!
vlan 40
 name FA
!
vlan 50
 name GA
!
vlan 60
 name HA
!
vlan 70
 name IA
!
vlan 80
 name Ben
!
vlan 90
 name SITEA
!
vlan 100
 name KA
!
vlan 110
 name LA
!
vlan 120
 name MA
!
vlan 130
 name OA
!
vlan 140
 name PA
!
vlan 150
 name QA
!
vlan 201
 name SA
!
vlan 299
 name TA
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0
 no ip address
 shutdown
!
interface GigabitEthernet1/0/1
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/2
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/3
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/4
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/5
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/6
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/7
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/8
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/9
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/10
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/11
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/12
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/13
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/14
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/15
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/16
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/17
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/18
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/19
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/20
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/21
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/22
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/23
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/24
 description Un-Trusted Data Port
 switchport access vlan 90
 switchport mode access
 switchport port-security maximum 3
 switchport port-security aging time 1
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 no snmp trap link-status
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 ip dhcp snooping limit rate 10
!
interface GigabitEthernet1/0/25
 description ** Connection to Sw2 - Gi1/0/25
 switchport trunk native vlan 299
 switchport mode trunk
 switchport nonegotiate
 logging event trunk-status
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 mls qos trust dscp
 ip dhcp snooping trust
!
interface GigabitEthernet1/0/26
 description ** Connection to Sw1 - Gi1/0/25
 switchport trunk native vlan 299
 switchport mode trunk
 switchport nonegotiate
 logging event trunk-status
 srr-queue bandwidth share 1 70 25 5
 priority-queue out
 mls qos trust dscp
 ip dhcp snooping trust
!
interface TenGigabitEthernet1/0/1
!
interface TenGigabitEthernet1/0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 no ip address
 shutdown
!
interface Vlan20
 no ip address
 shutdown
!
interface Vlan30
 no ip address
 shutdown
!
interface Vlan40
 no ip address
 shutdown
!
interface Vlan50
 no ip address
 shutdown
!
interface Vlan60
 no ip address
 shutdown
!
interface Vlan70
 no ip address
 shutdown
!
interface Vlan80
 no ip address
 shutdown
!
interface Vlan90
 no ip address
 shutdown
!
interface Vlan100
 no ip address
 shutdown
!
interface Vlan110
 no ip address
 shutdown
!
interface Vlan120
 no ip address
 shutdown
!
interface Vlan130
 no ip address
 shutdown
!
interface Vlan140
 no ip address
 shutdown
!
interface Vlan150
 no ip address
 shutdown
!
interface Vlan201
 description Management_VLAN Interface
 ip address 10.1.1.90 255.255.255.0
!
interface Vlan299
 no ip address
 shutdown
!
ip default-gateway 10.1.1.254
ip http server
ip http secure-server
!
!
!

Full code of the router:

Building configuration...

Current configuration : 15410 bytes
!
! Last configuration change at 11:39:24 UTC Thu Sep 13 2018
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no platform punt-keepalive disable-kernel-core
!
hostname CE-Router
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
enable secret xx
!
no aaa new-model
!
!
!
!
!
!
!
!
!


ip name-server 8.8.8.8

ip dhcp excluded-address 192.168.20.1 192.168.20.10
ip dhcp excluded-address 192.168.20.254
ip dhcp excluded-address 192.168.30.1 192.168.30.10
ip dhcp excluded-address 192.168.30.254
ip dhcp excluded-address 192.168.40.1 192.168.40.10
ip dhcp excluded-address 192.168.40.254
ip dhcp excluded-address 192.168.50.1 192.168.50.10
ip dhcp excluded-address 192.168.50.254
ip dhcp excluded-address 192.168.60.1 192.168.60.10
ip dhcp excluded-address 192.168.60.254
ip dhcp excluded-address 192.168.70.1 192.168.70.10
ip dhcp excluded-address 192.168.70.254
ip dhcp excluded-address 192.168.80.1 192.168.80.10
ip dhcp excluded-address 192.168.80.254
ip dhcp excluded-address 192.168.90.1 192.168.90.10
ip dhcp excluded-address 192.168.90.254
ip dhcp excluded-address 192.168.100.1 192.168.100.10
ip dhcp excluded-address 192.168.100.254
ip dhcp excluded-address 192.168.110.1 192.168.110.10
ip dhcp excluded-address 192.168.110.254
ip dhcp excluded-address 192.168.120.1 192.168.120.10
ip dhcp excluded-address 192.168.120.254
ip dhcp excluded-address 192.168.130.1 192.168.130.10
ip dhcp excluded-address 192.168.130.254
ip dhcp excluded-address 192.168.140.1 192.168.140.10
ip dhcp excluded-address 192.168.140.254
ip dhcp excluded-address 192.168.150.1 192.168.150.10
ip dhcp excluded-address 192.168.150.254
ip dhcp excluded-address 192.168.10.1 192.168.10.14
ip dhcp excluded-address 192.168.10.254
ip dhcp excluded-address 192.168.160.1 192.168.160.10
ip dhcp excluded-address 192.168.160.254
ip dhcp excluded-address 192.168.170.1 192.168.170.10
ip dhcp excluded-address 192.168.170.254
!
ip dhcp pool M
 network 192.168.50.0 255.255.255.0
 default-router 192.168.50.254
 dns-server 8.8.8.8 8.8.4.4
 lease 8
!
ip dhcp pool MO
 network 192.168.10.0 255.255.255.0
 default-router 192.168.10.254
 dns-server 9.9.9.9 8.8.8.8
 lease 8
!
ip dhcp pool Mot
 network 192.168.20.0 255.255.255.0
 default-router 192.168.20.254
 dns-server 8.8.8.8 8.8.4.4
 lease 8
!
ip dhcp pool MoY
 network 192.168.40.0 255.255.255.0
 default-router 192.168.40.254
 dns-server 8.8.8.8 8.8.4.4
 lease 8
!
ip dhcp pool C
 network 192.168.60.0 255.255.255.0
 default-router 192.168.60.254
 dns-server 8.8.8.8 8.8.4.4
 lease 8
!
ip dhcp pool E
 network 192.168.70.0 255.255.255.0
 default-router 192.168.70.254
 dns-server 8.8.8.8 8.8.4.4
 lease 8
!
ip dhcp pool F
 network 192.168.100.0 255.255.255.0
 default-router 192.168.100.254
 dns-server 8.8.8.8 8.8.4.4
 lease 8
!
ip dhcp pool G
 network 192.168.120.0 255.255.255.0
 default-router 192.168.120.254
 dns-server 8.8.8.8 8.8.4.4
 lease 8
!
ip dhcp pool H
 network 192.168.130.0 255.255.255.0
 default-router 192.168.130.254
 dns-server 8.8.8.8 8.8.4.4
 lease 8
!
ip dhcp pool I
 network 192.168.140.0 255.255.255.0
 default-router 192.168.140.254
 dns-server 8.8.8.8 8.8.4.4
 lease 8
!
ip dhcp pool J
 network 192.168.150.0 255.255.255.0
 default-router 192.168.150.254
 dns-server 8.8.8.8 8.8.4.4
 lease 8
!
ip dhcp pool K
 network 192.168.80.0 255.255.255.0
 default-router 192.168.80.254
 dns-server 8.8.8.8 8.8.4.4
 lease 8
!
ip dhcp pool L
 network 192.168.110.0 255.255.255.0
 default-router 192.168.110.254
 dns-server 8.8.8.8 8.8.4.4
 lease 8
!
ip dhcp pool O
 network 192.168.30.0 255.255.255.0
 default-router 192.168.30.254
 dns-server 8.8.8.8 8.8.4.4
 lease 8
!
ip dhcp pool P
 network 192.168.160.0 255.255.255.0
 default-router 192.168.160.254
 dns-server 8.8.8.8 8.8.4.4
 lease 8
!
ip dhcp pool Q
 network 192.168.170.0 255.255.255.0
 default-router 192.168.170.254
 dns-server 8.8.8.8 8.8.4.4
 lease 8
!
ip dhcp pool SITEA
 network 192.168.90.0 255.255.255.0
 default-router 192.168.90.254
 dns-server 8.8.8.8 8.8.4.4
 lease 8
!
!
!
!
!
!
!
!
!
!
subscriber templating
!
flow exporter CE-ROUTER
 destination 192.168.10.246
 source GigabitEthernet0/0/0
 transport udp 1600
 export-protocol netflow-v5
!
!
flow monitor MONITOR-1
 exporter CE-ROUTER
 record netflow ipv4 original-input
!
multilink bundle-name authenticated
license udi pid ASR1001-X sn xx
!
!
redundancy
 mode none
!
!
cdp run
!
ip tftp source-interface GigabitEthernet0
!


interface TenGigabitEthernet0/0/0
 no ip address
 shutdown
!
interface TenGigabitEthernet0/0/1
 no ip address
 shutdown
!
interface GigabitEthernet0/0/0
 description "Primary Fiber Connection 
 bandwidth 158720
 ip address 172.16.1.2 255.255.255.252
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nbar protocol-discovery
 ip flow monitor MONITOR-1 input
 negotiation auto
!
interface GigabitEthernet0/0/1
 description "All Ministries LAN Interface" - -Core-Sw1 - Gi1/0/48
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nbar protocol-discovery
 ip tcp adjust-mss 1452
 negotiation auto
 cdp enable
 service-policy output Parent-LAN-Shaper
!
interface GigabitEthernet0/0/1.10
 description 
 encapsulation dot1Q 10
 ip address 192.168.10.254 255.255.255.0
 ip nbar protocol-discovery
!
interface GigabitEthernet0/0/1.20
 description ""
 encapsulation dot1Q 20
 ip address 192.168.20.254 255.255.255.0
 ip nbar protocol-discovery
!
interface GigabitEthernet0/0/1.30
 description 
 encapsulation dot1Q 30
 ip address 192.168.30.254 255.255.255.0
 ip nbar protocol-discovery
!
interface GigabitEthernet0/0/1.40
 description 
 encapsulation dot1Q 40
 ip address 192.168.40.254 255.255.255.0
 ip nbar protocol-discovery
!
interface GigabitEthernet0/0/1.50
 description 
 encapsulation dot1Q 50
 ip address 192.168.50.254 255.255.255.0
 ip nbar protocol-discovery
!
interface GigabitEthernet0/0/1.60
 description 
 encapsulation dot1Q 60
 ip address 192.168.60.254 255.255.255.0
 ip nbar protocol-discovery
!
interface GigabitEthernet0/0/1.70
 description 
 encapsulation dot1Q 70
 ip address 192.168.70.254 255.255.255.0
 ip nbar protocol-discovery
!
interface GigabitEthernet0/0/1.80
 description 
 encapsulation dot1Q 80
 ip address 192.168.80.254 255.255.255.0
 ip nbar protocol-discovery
!
interface GigabitEthernet0/0/1.90
 description 
 encapsulation dot1Q 90
 ip address 192.168.90.254 255.255.255.0
 ip nbar protocol-discovery
!
interface GigabitEthernet0/0/1.100
 description 
 encapsulation dot1Q 100
 ip address 192.168.100.254 255.255.255.0
 ip nbar protocol-discovery
!
interface GigabitEthernet0/0/1.110
 description 
 encapsulation dot1Q 110
 ip address 192.168.110.254 255.255.255.0
 ip nbar protocol-discovery
!
interface GigabitEthernet0/0/1.120
 description 
 encapsulation dot1Q 120
 ip address 192.168.120.254 255.255.255.0
 ip nbar protocol-discovery
!
interface GigabitEthernet0/0/1.130
 description 
 encapsulation dot1Q 130
 ip address 192.168.130.254 255.255.255.0
 ip nbar protocol-discovery
!
interface GigabitEthernet0/0/1.140
 description 
 encapsulation dot1Q 140
 ip address 192.168.140.254 255.255.255.0
 ip nbar protocol-discovery
!
interface GigabitEthernet0/0/1.150
 description 
 encapsulation dot1Q 150
 ip address 192.168.150.254 255.255.255.0
 ip nbar protocol-discovery
!
interface GigabitEthernet0/0/1.160
 description 
 encapsulation dot1Q 160
 ip address 192.168.160.254 255.255.255.0
 ip nbar protocol-discovery
!
interface GigabitEthernet0/0/1.170
 description 
 encapsulation dot1Q 170
 ip address 192.168.170.254 255.255.255.0
 ip nbar protocol-discovery
!
interface GigabitEthernet0/0/1.201
 description 
 encapsulation dot1Q 201
 ip address 10.1.1.254 255.255.255.0
!


!
interface GigabitEthernet0/0/4
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet0/0/5
 no ip address
 shutdown
 negotiation auto
!
interface ATM0/1/0
 no ip address
 shutdown
 no atm enable-ilmi-trap
!
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 no ip address
 shutdown
 negotiation auto

Network Diagram: enter image description here

9
  • Please include the full configurations of both the router and switches.
    – user36472
    Sep 13, 2018 at 12:30
  • 5
    I'm a bit confused by the design, could you add a simple drawing or sketch showing how everything is connected?
    – user36472
    Sep 13, 2018 at 13:01
  • Which port on the switch is the router plugged into?
    – Ron Trunk
    Sep 13, 2018 at 15:16
  • @Cown Thanks for the suggestion. I added a diagram. It is a ring topology. I hope this helps
    – Liban
    Sep 13, 2018 at 18:44
  • 1
    One command I do not see for DHCP snooping that we use in a working configurations is the ip dhcp snooping information option allow-untrusted command.
    – Ron Maupin
    Feb 17, 2019 at 16:18

3 Answers 3

2

Given that this question was asked 4 years ago, I must assume that it has been resolved by now. Still, here is my take: I am assuming that you need the Vlan90 SVI on each switch to get an IP address. For each Vlan90 SVI on each switch to receive a dynamic IP address, try applying the following configuration on the 2960s:

interface Vlan90
  ip address dhcp
  no shutdown

Then use debug dhcp detail on the 2960 to see the interaction. Also use debug ip dhcp server packets on the router to see the requests from the clients and see if there is anything wrong.

Alternatively, you could be asking why hosts on VLAN 90 (attached to VLAN 90 access ports of the 2960s) cannot receive DHCP leases. To troubleshoot host DHCP issues, issue the debug ip dhcp server packets command on the router, and run Wireshark with the DHCP filter on the affected hosts.

0

I suggest no shutting the SVI (int vlan 90) for that VLAN and adding an 'ip helper' pointing back to the router.

0

ip dhcp excluded-address 192.168.90.1 192.168.90.10 ip dhcp excluded-address 192.168.90.254

ip dhcp pool SITEA network 192.168.90.0 255.255.255.0 default-router 192.168.90.254 dns-server 8.8.8.8 8.8.4.4 lease 8

@ your DHCP Configuration clearly shows that default -gateway is excluded, actually not required to exclude default gateway ip address in DHCP . Instead of excluding, just add default-gateway ip address to DHCP pool Configuration.

Router(config)# no ip dhcp excluded-address 192.168.90.1 192.168.90.10]

Router(config)# no ip dhcp excluded-address 192.168.90.254

Router(config)#ip dhcp pool SITEA

Router(config)#network 192.168.90.0 255.255.255.0

Router(config)#default-router 192.168.90.254

Router(config)#dns-server 8.8.8.8 8.8.4.4

Router(config)#lease 8

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.