10

I am working on trying to setup our network for multicast traffic. In the coming months we will be installing new equipment that sends out multicast traffic. In the past we have only had 1 VLAN so we just used IGMP querier and snooper and this met our needs. In the new office that we just moved into we have segregated the network into multiple VLANs. I understand that we will need to use PIM to accomplish what we want. After some research I understand that PIM Dense Mode will broadcast initially out to every user and then prune back the ports that do not want the multicast feed. This leads me to believe that PIM Sparse Mode is the better option.

We are currently a Dell PowerConnect shop with a pretty simple layout. (See below for our network topology diagram)

My questions are:

  1. Should we setup on our core network switch OSPF with a router ID of 1.1.1.1 and then not set any OSPF settings on any other switch?
  2. Would PIM Sparse Mode only need to be enabled on the core switches or on all of the switches in the network?

We are wanting to keep as much of the data from hitting our Cisco switch as that connects to our other branch offices.

When I attempted to setup PIM Sparse Mode I did not see any neighbors showing up which I believe is needed to have PIM work.

I initially looked at this PDF for sample configurations but they use PIM Dense and following this paper didn't work at all. ftp://ftp.dell.com/Manuals/Common/powerconnect-m6220_White%20Papers48_en-us.pdf

Update: I seemed to be able to get this working in my test environment but that used 2x 6224 switches. I have not been able to get this to work yet going through the 8132F switches yet.

Update: Does IP PIM Sparse need to be enabled on each interface on the acting router? Have been testing with this just enabled on the VLAN not the interface.

Update: Have been doing some more testing with VLC player trying to get this working. Have attached my configs for the switches. Any suggestions? After upgrading the 8132F to version 6 of the firmware it does remove the "ip igmp" command from the VLAN.

Core config *Switch shows model of N4032F but this is indeed an 8132F

!Current Configuration:
!System Description "Dell Networking N4032F, 6.0.0.8, Linux 2.6.32.9"
!System Software Version 6.0.0.8
!Cut-through mode is configured as disabled
!
configure
vlan 9
name "Metronet"
exit
vlan 10
name "Servers"
exit
vlan 11
name "Endpoints"
exit
vlan 12
name "Voice"
exit
vlan 13
name "Guest"
exit
vlan 14
name "Security Cameras"
exit
vlan 15
name "Mobile Media"
exit
vlan 9-15
exit
snmp-server location "MSH Rack 1 Slots 36-37"
snmp-server contact "Daniel"
hostname "Core"
slot 1/0 3    ! Dell Networking N4032F
slot 1/1 6    ! Dell QSFP Card
slot 2/0 3    ! Dell Networking N4032F
slot 2/1 6    ! Dell QSFP Card
sntp unicast client enable
sntp server 10.10.10.242
clock timezone -5 minutes 0
stack
member 1 2    ! N4032F
member 2 2    ! N4032F
exit
interface out-of-band
ip address none
exit
ip access-list BlockGuest3
permit tcp 10.11.13.0 0.0.0.255 10.11.10.40 0.0.0.0
permit tcp 10.11.13.0 0.0.0.255 eq 67 10.11.10.12 0.0.0.0
permit ip 10.11.13.0 0.0.0.255 10.11.15.0 0.0.0.0
deny ip 10.11.13.0 0.0.0.255 10.10.0.0 0.0.0.255
deny ip 10.11.13.0 0.0.0.255 10.11.10.0 0.0.0.255
deny ip 10.11.13.0 0.0.0.255 10.11.11.0 0.0.0.255
deny ip 10.11.13.0 0.0.0.255 10.11.12.0 0.0.0.255
permit every
exit
ip routing
ip route 0.0.0.0 0.0.0.0 10.11.9.2
interface vlan 1
exit
interface vlan 9
ip address 10.11.9.1 255.255.255.252
exit
interface vlan 10
ip address 10.11.10.1 255.255.255.0
ip pim
exit
interface vlan 11
ip address 10.11.11.1 255.255.255.0
ip pim
exit
interface vlan 12
ip address 10.11.12.1 255.255.255.0
ip pim
exit
interface vlan 13
ip address 10.11.13.1 255.255.255.0
ip access-group BlockGuest3 in 1
exit
interface vlan 14
ip address 10.11.14.1 255.255.255.0
exit
interface vlan 15
ip address 10.11.15.1 255.255.255.0
ip pim
exit
username "admin" password password_removed privilege 15 encrypted
ip ssh server
ip multicast-routing
ip pim sparse-mode
ip pim rp-address 10.11.10.1 224.0.0.0 240.0.0.0
!
interface Te1/0/1
description "Metronet"
switchport access vlan 9
exit
!
interface Te1/0/3
channel-group 1 mode active
description "MDF"
switchport mode trunk
exit
!
interface Te1/0/4
channel-group 2 mode active
description "IDF"
switchport mode trunk
exit
!
interface Te2/0/3
channel-group 1 mode active
description "MDF"
switchport mode trunk
voice vlan dscp 1
exit
!
interface Te2/0/4
channel-group 2 mode active
description "IDF"
switchport mode trunk
voice vlan dscp 1
exit
!
interface port-channel 1
classofservice trust ip-dscp
switchport mode trunk
exit
!
interface port-channel 2
classofservice trust ip-dscp
switchport mode trunk
exit
!
snmp-server engineid local 800002a203d067e5d1a2e3
snmp-server community "dev1" ro ipaddress 10.10.10.169
snmp-server community "nagios" ro ipaddress 10.10.10.31
snmp-server host 10.10.10.31 traps version 2 "nagios"
enable password password_removed encrypted
exit

MDF Config

!Current Configuration:
!System Description "PowerConnect 6248P, 3.3.8.2, VxWorks 6.5"
!System Software Version 3.3.8.2
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 10-15
exit
hostname "MDF"
sntp unicast client enable
sntp server 10.10.10.242
clock timezone -5 minutes 0
stack
member 1 5
member 2 5
member 3 5
exit
ip address 10.11.10.31 255.255.255.0
ip default-gateway 10.11.10.1
ip address vlan 10
no ip helper enable
interface vlan 10
name "Servers"
exit
interface vlan 11
name "Endpoint"
exit
interface vlan 12
name "Voice"
exit
interface vlan 13
name "Guest"
exit
interface vlan 14
name "Security Cameras"
exit
username "admin" password password_removed level 15 encrypted
voice vlan
ip ssh server
bridge multicast filtering
ip igmp snooping
!
interface ethernet 2/g14
classofservice trust ip-dscp
switchport mode general
switchport general pvid 11
switchport general allowed vlan add 11
switchport general allowed vlan add 12 tagged
switchport general allowed vlan remove 1
voice vlan 12
exit
!
interface ethernet 3/g46
classofservice trust ip-dscp
switchport mode general
switchport general pvid 11
switchport general allowed vlan add 11
switchport general allowed vlan add 12 tagged
switchport general allowed vlan remove 1
voice vlan 12
exit
!
interface ethernet 3/xg3
channel-group 1 mode auto
switchport mode general
switchport general allowed vlan add 10-14
exit
!
interface port-channel 1
classofservice trust ip-dscp
switchport mode general
switchport general allowed vlan add 10-15 tagged
exit
snmp-server community daniel ro ipaddress 10.10.10.129
snmp-server community nagios ro ipaddress 10.10.10.31
snmp-server host 10.10.10.31 nagios traps v2
exit

Current network layout

1
  • If your multicast traffic is crossing vlans, then yes, you need to enable PIM sparse mode on the VLAN interfaces.
    – Ron Trunk
    Feb 7, 2014 at 18:48

3 Answers 3

6

My questions are:

Should we setup on our core network switch OSPF with a router ID of 1.1.1.1 and then not set any OSPF settings on any other switch?

OSPF is not necessary for this implementation.

Would PIM Sparse Mode only need to be enabled on the core switches or on all of the switches in the network?

Pim-SM needs to be enabled on each L3 interface on which you want to allow the multicast traffic. For example, if you wish to contain the traffic to Vlans 15 and 14, you would have to do the following on your core:

configure
ip multicast
ip igmp
ip pim sparse
interface vlan 14
ip igmp
ip pim
interface vlan 15
ip igmp
ip pim
exit

If you want the traffic to traverse all Vlans, then you will need the appropriate interface configuration under each Vlan. Your L2 switches will need IGMP snooping turned on (ideally on all interfaces via the global configuration).

configure
ip igmp snooping 
bridge multicast filtering

For a very basic multicast setup like this, these should be the only features that you would need.

1
  • Thanks. I have tried this setup and something is still not working correctly. I tried to setup a test environment with 2 Dell PowerConnect 6224 with no success. Granted the 6224 do not have the "ip pim" or "ip pim sparse" commands. They do have a "ip pimsm" command which does enable PIM Sprase. I setup VLC on a Win XP(Wont stream out of my Win 7 machine) machine and streamed a video with RTP to 239.0.0.25:5008, then watched for those packets on another machine with Wireshark. After stopping the video on the receiving client the packets for 239.0.0.25 still came through.
    – DanielJay
    Dec 11, 2013 at 15:48
1

You also need to set up a PIM RP since you only have 1 routing device you do not need to support auto-rp or bsr

ip pim rp-address rp-address [access-list]

the access-list has the multicast IP range so access-list 10 239.192.0.0 0.0.255.255 would make the 4900m the RP for the private multicast address range

2
  • Per his setup the traffic would never need to hit the 4900m, nor would he have to configure an RP. You can build source trees directly since there is only one device routing the multicast. I.e. the RP is what traffic is sent to initially on the network to build a shared tree as IGMP joins come in. I intentionally left the RP configuration out of my answer. Dec 6, 2013 at 16:08
  • I did not read where traffic did not have to go cross vlan, it has been my experience that if you need to multicast between vlans (else why bother with PIM at all) and you do sparse mode you need an RP even if there is only 1 router. If he does not need it in the 4900 he needs it in the Dell
    – fredpbaker
    Dec 6, 2013 at 18:54
1

I believe the answer from John Kennedy is the correct way to do things for other model of switches. However after being in correspondence with Dell there is a limitation in the PowerConnect 6248 firmware currently and the topology we are running.

Will have to wait for future released firmware.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.