I'm trying to export my current F5 bigIP configuration into a file and later create a replica of the same bigIP with that configuration.

This reference mentioned following this:

Create the UCS archive file by using the following command syntax, replacing with the full path to the UCS archive file:

tmsh save /sys ucs <path/to/UCS>

I logged in to my bigIP, but when trying this, it gives me error. What is the problem? How to fix it?

Syntax Error: "ucs" unexpected argument
  • what version is your BIG-IP?
    – Jason Rahm
    Oct 8 '18 at 20:27
  • It is 13. But I figured out the problem: I needed to be admin role only!
    – Tina J
    Oct 8 '18 at 23:27

(tmos)# save /sys ucs

Configuration Items:


I guess you are under tmos shell, right?

I mean you have to enter in tmos shell running the command "tmsh". Then, you have to write the rest of your input


[root@F5-LTM:Active:In Sync] config # tmsh
root@(F5-LTM)(cfg-sync In Sync)(Active)(/Common)(tmos)# save /sys ucs foobar.ucs
  • Yes this is what I'm doing. But still get Syntax Error: "ucs" unexpected argument :-/
    – Tina J
    Sep 27 '18 at 14:32
  • 1
    have you tried to tab after each command to see the options you have?
    – BloodyMery
    Sep 28 '18 at 11:13
  • Interesting. I only have config after sys, and after that Options: current-partition partitions. No ucs there.
    – Tina J
    Sep 28 '18 at 15:00
  • is it licensed corretly?
    – BloodyMery
    Oct 1 '18 at 16:48

I had an operator role. I needed to have an administrator or iRule Manager(or something similar?) role only for this to show up!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.