1

I was trying to setup NAT and Access Rules and apparently did something very wrong because now I cannot get into ASDM at all. I've tried multiple machines and all of them time out. Also the landing page for 192.168.3.1 no longer loads.

I do still have console access to the ASA 5505, so all hope is not lost. However, I cannot seem to figure out how to delete the new NAT rule I made. I am running show run nat and/or show nat but how can I determine what is the exact rule of the NAT rule so I can delete it? Thanks.

Also, I have rebooted ("reload" command) the ASA since the issue started, but there's no change.

Here's my "show run"

    DrewzASA(config)# show run
: Saved
:
: Serial Number: 
: Hardware:   ASA5505, 512 MB RAM, CPU Geode 500 MHz
:
ASA Version 9.2(3)
!
hostname DrewzASA
domain-name drewz.local
enable password ********************* encrypted
names
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.3.1 255.255.255.0
 dhcprelay information trusted
!
interface Vlan2
 description CenturyLink 100 Mbps fiber
 nameif outside
 security-level 0
 pppoe client vpdn group DrewzGroup
 ip address pppoe setroute
!
ftp mode passive
dns server-group DefaultDNS
 domain-name drewz.local
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network Work_Corp_WAN
 host (removed)
 description Work corporate network
object network Dell-Precision
 host 192.168.3.38
 description Dell-Precision
object network obj-Work_Corp_WAN
object service RDP-TCP
 service tcp source eq 3389 destination eq 3389
 description Win_RDP_port-3389
object network Dell-Optiplex
 host 192.168.3.133
 description Dell-Optiplex
object service SSL
 service tcp source eq https destination eq https
 description SSL
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
icmp deny any echo-reply outside
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,outside) source static any interface destination static interface Dell-Optiplex service any SSL
!
object network obj_any
 nat (inside,outside) dynamic interface
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication http console LOCAL
aaa authentication serial console LOCAL
aaa authentication ssh console LOCAL
aaa authentication enable console LOCAL
aaa authorization command LOCAL
aaa authorization exec LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.3.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
no ssh stricthostkeycheck
ssh 192.168.3.0 255.255.255.0 inside
ssh timeout 60
ssh version 2
ssh key-exchange group dh-group1-sha1
console timeout 0
vpdn group DrewzGroup request dialout pppoe
vpdn group DrewzGroup localname fryandrew@centurylink.net
vpdn group DrewzGroup ppp authentication chap
vpdn username fryandrew@centurylink.net password ************ store-local

dhcpd dns 1.1.1.1 8.8.8.8
dhcpd domain Drewz.local
!
dhcpd address 192.168.3.30-192.168.3.90 inside
dhcpd dns 1.1.1.1 interface inside
!
dhcprelay server 192.168.3.4 inside
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
username DrewAdmin password ***************** encrypted privilege 15
username DrewAdmin attributes
 service-type admin
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect icmp
  inspect icmp error
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:37d9b320a37aed6a67887a79e24e58e5
: end
DrewzASA(config)#
  • 1
    You should post the full configuration, remember to sanitize it and remove all passwords etc. – user36472 Oct 3 '18 at 5:43
  • 1
    What exactly are you trying to do with that NAT statement in your config, for SSL? – Jesse P. Oct 3 '18 at 14:28
  • I was trying to create a port-forwarding rule to direct all SSL traffic to a web-server on my LAN. – SamAndrew81 Oct 3 '18 at 15:04
2

(if you're trying to connect to 1.1, that would be a problem as the ASA is 3.1.)

The core of the problem is the any interface part of the global nat entry. That will override the default path for SSL on the inside interface as well, which is clearly not what you want. If you remove that line (no nat ...), things should return to normal.

Your definition for "SSL" should only cover destination 443/https as incoming connections will not be sourced from 443.

  • Sorry, that was a typo in my original post. The ASA is indeed at 192.168.3.1 not 192.168.1.1 – SamAndrew81 Oct 3 '18 at 16:05
  • Thank you. How do I remove that line you mentioned (no NAT ...)? I know I use a "no" command in Configure Terminal mode, but I cannot figure out the NAT rule name... – SamAndrew81 Oct 3 '18 at 16:07
  • Thanks, Ricky. I got my problem solved with this command: no NAT nat (inside,outside) source static any interface destination static interface Dell-Optiplex service any SSL – SamAndrew81 Oct 4 '18 at 4:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.