1

I am trying to assign an IP address to Interface g0/0 on a Cisco 892FSP. However, it keeps telling me that a layer two interface cannot be assigned an IP address. Any ideas?

  • Please post show version and the full configuration of the router. You are probably trying to use one of the access ports and not the WAN port, which is the only routable port. – user36472 Oct 5 '18 at 9:25
  • This is exactly what happened, I was trying to configure one of the access ports. Assumed they were FE ports and not GE. – Caine Kiewit Oct 5 '18 at 9:31
5

Please provide your sanitized configuration. Probably you're trying to assign IP address on Layer-2 interface (which is part of switch-module) and that is not allowed. If you want to allow some traffic from switchport to be routed, you need to create VLAN (or use default VLAN 1) and assign IP address on VLAN interface.

Example:

Create VLAN

(config)# vlan 100

Assign VLAN to interface

(config)# interface g0/0
(config-if)# switchport access vlan 100

Create L3 interface and assign IP address to it

(config)# interface Vlan100
(config-if)# ip address 10.10.10.1 255.255.255.0
0

Layer2 devices are not feasible to configure ip address beacuse the IPaddress is layer3 construct .ip address cannot be configured on layer2 switch ports.

It's feasible to configure ip address for accessing switch with management IP address VLAN can be created and assign ip address to Vlan .

-1

There is not such thing as IP on layer 2 device.

Since you have this issue on the router this means that you port was configured with switch command.

run: show running-config to see the configurations on the port

Try to use "no switch" command on this port, to fix it.

  • Not every device able to use it's interfaces in two modes. Switches like 6500 or 3750 give you that option, but not SOHO 890. – Andrey Prokhorov Oct 8 '18 at 6:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.