1

Simplified diagram of a larger network, but I'm having trouble getting DHCP from the router. Going into simulation mode in packet tracer, I'm seeing an error on the layer 3 switch saying "There is no subinterface with this VLAN enabled"

enter image description here

Router Config

en
conf t
int gig 0/1
ip address 205.165.85.5 255.255.255.252
no shut
int gig 0/1.5
encapsulation dot1q 5
ip address 192.168.86.30 255.255.255.240
!
ip dhcp pool vlan5
network 192.168.86.16 255.255.255.240
default-router
end

Switch

en
conf t
ip routing
vtp domain ndd430
vtp mode server
vlan 5
int fa0/1
switchport access vlan 5
spanning-tree portfast
!
int gig 0/2
no switchport
ip address 205.165.85.6 255.255.255.252
no shut
int vlan 5
ip address 192.168.86.30 255.255.255.240
ip helper-address 205.165.85.5
end

EIGRP

router eigrp 100
network 205.165.85.4 0.0.0.3
  • Please edit your question to include the configurations of the network devices. – Ron Maupin Oct 14 '18 at 21:47
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Dec 25 '18 at 9:44
2

welcome to Network Engineering!

The problem is your switch configuration. You have Gi0/2 configured as a L3 interface, but the router is a trunk port.

Moreover, you have your 192.168.86.16/28 subnet split between two separate networks: One on the router and one on the switch, but they are not connected at layer 2.

Change your switch config to this:

int gig 0/2
switchport
switchport mode trunk

Also, remove the helper address on int vlan5

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.