2

OSPF peering between two of my routers went down 2 days before. After troubleshooting, I removed the authentication commands from both devices GRE tunnel interfaces

ip ospf authentication message-digest 
 ip ospf message-digest-key 1 md5 xxxx

Then the peering formed. So OSPF peering is not forming when authentication is enabled but forming when there is no authentication.

Please note that password is same and there is nothing wrong with authentication configuration.

I'd like to make OSPF work with authentication enabled.

Please find the config below:

interface Tunnel10
 ip address 192.168.10.13 255.255.255.252
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no ip route-cache cef
 no ip route-cache
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 7 645454654
 keepalive 10 5
 tunnel source 10.10.1.10
 tunnel destination 10.10.1.26
end




interface Tunnel10
 ip address 192.168.10.14 255.255.255.252
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no ip route-cache cef
 no ip route-cache
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 7 654654654654
 keepalive 10 5
 tunnel source 10.10.1.26
 tunnel destination 10.10.1.10
end

router ospf 10
 router-id 1.1.1.1
 log-adjacency-changes
 network 192.168.10.12 0.0.0.3 area 10

router ospf 10
 router-id 2.2.2.2
 log-adjacency-changes
 network 192.168.10.12 0.0.0.3 area 10
6
  • 4
    What happened "two days before"? What changed? – Ron Trunk Oct 18 '18 at 12:01
  • 3
    Try "debug ospf adjacency" and post the output to your question. – Ron Trunk Oct 18 '18 at 13:41
  • 3
    You don't have an authentication command under the router configuration: area 10 authentication message-digest. – Ron Maupin Oct 18 '18 at 15:09
  • I don't have the area 10 authentication message-digest command under router configuration. it is only on tunnel interface level. – Fahad Oct 19 '18 at 3:27
  • the devices are in live environment so I have a feeling that devices will go down when I activate debug command – Fahad Oct 19 '18 at 3:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.