I've spent two weekends googling and trying every suggestion I can find, but still, when I try to connect to my ASA, the launcher accepts my credentials, the "updating software" bar goes to 20%, and the launcher just disappears. No error popups, no connection, nothing. I'm tearing my hair out on this.

It's an ASA 5505 with 1 GB of RAM, it has all the required licensing, including 3DES encryption.

System image is 9.1(7)32 (filename is asa917-32-k8.bin if that helps).

Device manager is 7.5(1)112.

I've tried on XP, Windows 10, even Ubuntu (though I really suck at linux), using Chrome, IE, and Firefox. I've tried different versions of Java, and both 32 and 64 bit Java. I know people have this working; I had it working, on Windows 10, at my previous employer.

I'm attempting to connect via Java Web Start, as I read that it just doesn't work to install the launcher anymore. I can SSH to the CLI just fine, and it's in production and working as it should. HTTPS is enabled for the inside network, which is where I'm trying to connect ASDM from.

I've added exceptions in for the ASA in Java on the management machines, and I've even imported into Java the ASA's self-signed cert.

I can post the whole config if anyone wants to see it; I hesitate to do it right off the bat and quadruple the length of the post, because I think this more of a Java issue.

Does anyone have any advice? Let me know, because I'm at a loss.

  • Try a newer version of ASDM. The newest available is 7.9.2-152 and ASDM is usually extremely backwards compatible wiyh which versions of ASA software it works with. I suggest that because there may be an incompatibility with that version of ASDM and current versions of Java or current versions of Windows.
    – Jesse P.
    Commented Oct 27, 2018 at 23:04
  • The version I'm using is latest officially supported for the 5505. I have tried with a couple of older versions of ASDM I had lying around, but got the same result. I suspect there's an exact Java version and bitness that will work with this, but I don't know what it is.
    – Agent 219
    Commented Oct 28, 2018 at 17:08
  • I understand that "officially" you're on the newest version but that's only because 5505's are EoL/EoS and Cisco is not updating documentation for obsolete models. I have a 5505 for a client and am using ASDM 7.9(2)152 without a problem so I know it's fully compatible. I'd give it a shot.
    – Jesse P.
    Commented Oct 28, 2018 at 17:20
  • At least by running the actual newest release of ASDM you're giving yourself the best chances of having compatible version of Java and OS.
    – Jesse P.
    Commented Oct 28, 2018 at 17:24
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer.
    – Ron Maupin
    Commented Dec 25, 2018 at 9:46

1 Answer 1


Many a work day has been lost to Java and ASDM :) you are not the first! You will not be the last!!

  1. Upgrade ASDM to latest version you can
  2. Remove all trace of current Java and install corresponding Java version to ASDM
  3. Go into Java security settings and add the https site for the firewall as a trusted site
  4. Open up Internet Exploder and add the firewall as a trusted site
  5. Now try and connect

Its' generally nothing to do with the ASDM I've found. It's generally a problem with windows and Java security that blocks it.

  • 1
    That's partly accurate. It is most definitely a problem with ASDM, in that Cisco develops it to be dependent on specific versions of Java rather than using version-agnostic code.
    – Jesse P.
    Commented Oct 28, 2018 at 22:23
  • Actually, it's JAVA changing the rules. You cannot write a java program that will be 100% compatible with all future versions of java, because the morons keep breaking things. (usually under the banner of "security")
    – Ricky
    Commented Oct 28, 2018 at 22:57
  • @RickyBeam Maybe not but what they could do is include the Java runtime libraries that ASDM is looking for, so that it won't matter which version the user has installed on their system.
    – Jesse P.
    Commented Oct 28, 2018 at 23:33
  • It's not any "libraries" but the entire jre. While the jnlp says "1.6+", there's only so far beyond 1.6 that it'll work. It's a common failing of Java -- it's never been "write once, run anywhere".
    – Ricky
    Commented Oct 29, 2018 at 2:40
  • @RickyBeam Fair enough. I guess the only remaining options are to use CLI (which is my vote, as I only use ASDM if looking at live traffic or installing certs) or Cisco should write ASDM in something else (like Qt).
    – Jesse P.
    Commented Oct 29, 2018 at 4:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.