1

Apologies if any details not clear as I'm not a network expert.

I have a Procurve 3500yl layer-3 switch. I am trying to make two VLANs and get a PC in one VLAN to connect to the other VLAN.

Below is the running configuration from the switch:

Running configuration:

; J8692A Configuration Editor; Created on release #K.14.41

hostname "ProCurve Switch 3500yl-24G"

module 1 type J86xxA

ip routing

vlan 1
   name "DEFAULT_VLAN"
   untagged 9-24
   no untagged 1-8
   no ip address
   exit

vlan 20
   name "local"
   untagged 5-8
   ip address 192.168.1.1 255.255.255.0
   exit

vlan 10
   name "operator"
   untagged 2-4
   ip address 10.11.156.31 255.255.255.0
   tagged 1
   exit

ip route 10.11.156.0 255.255.255.0 vlan 10
ip route 192.168.1.0 255.255.255.0 vlan 20
snmp-server community "public" unrestricted

I am trying to get PC (IP address: 192.168.1.2) to ping IP address 10.11.156.1 which is another router connected to VLAN 10.

I can ping 10.11.156.31 which is the VLAN address, but I can't ping 10.11.156.1. Do you have any idea what is the problem here?

3
  • Just because 1.2 knows how to get a packet to 156.1 does not mean 156.1 knows how to get back to 1.2.
    – Ricky
    Oct 28, 2018 at 22:49
  • @RickyBeam but they are directly connect networks. shouldn't they see each other normally?
    – user247954
    Oct 29, 2018 at 16:49
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer.
    – Ron Maupin
    Dec 25, 2018 at 9:54

2 Answers 2

2

The ip route lines should be redundant as the subnets are directly attached. Remove the lines from config and verify with show ip route.

You need to make sure that

  1. the 10.11.156.1 host has a default route to 10.11.156.31 (or specific route to 192.168.1.0/24).
  2. connectivity between 10.11.156.1 and 10.11.156.31 is established. Can you ping either way?
5
  • I removed the ip route lines but still the issue.
    – user247954
    Oct 28, 2018 at 18:00
  • also ip 10.11.156.1 and ip 10.11.156.31 can bing each other normally
    – user247954
    Oct 28, 2018 at 18:41
  • See 1. - can you ping 192.168.1.1 from 10.11.156.1??
    – Zac67
    Oct 28, 2018 at 20:55
  • No I can't do that. Do you know why or what shall be done ?
    – user247954
    Oct 29, 2018 at 16:51
  • Yet again, does 10.11.156.1 have a route to 192.168.1.0/24, default or specific??
    – Zac67
    Oct 29, 2018 at 17:46
2

Has your PC (192,168.1.2/24) got the vlan interface as it's default gateway? 192.168.1.1?

Also the router on VLAN10 should have a route for 192.168.1.1/24 pointing to 10.11.156.31. I'm sure this is a simple routing issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.