We have a small office network switch connected to a DSL modem for internet and telephony access. Now we would to extend network to another location in the same building for which I deployed a cisco 1841 router.

Previous Topology:

Internet --- DSL Modem --- Office LAN Switch (L2) (192.168.1.0/24) --- SIP Phone

New Topology:

Internet --- DSL Modem --- Office LAN Switch (L2) (192.168.1.0/24) --- cisco 1841 --- Branch Lan Switch (L2)(192.168.0.0/24) --- SIP Phone

SIP phones are connected to cloud PBX at the service provider and the in the previous configuration they were working perfectly.

Now in the second configuration; although we have internet access at the branch; I am having trouble with the SIP phones!!

In this router I have configured a NAT overloading. Can you please tell me what I shall do for SIP phones to work??

Below you can find the configuration and IP NAT SIP debug for cisco 1841.

version 12.4
!
boot-start-marker
boot-end-marker
!
!
resource policy
!
clock timezone GMT 3
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool MAIN-POOL
   network 192.168.0.0 255.255.255.0
   domain-name mycomp.local
   default-router 192.168.0.1 
   dns-server 192.168.0.1 
!
!
ip domain name mycomp.com
ip name-server 8.8.8.8
ip name-server 8.8.4.4
!
!
!
interface FastEthernet0/0
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
 no mop enabled
!
interface FastEthernet0/1
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
ip dns server
ip nat inside source list 50 interface FastEthernet0/1 overload
!
access-list 50 permit 192.168.0.0 0.0.0.255
!
!
control-plane
!
!

debug ip nat sip:

Nov  6 07:02:35.678: NAT: SIP: [0] processing unrecognized message
Nov  6 07:02:45.385: NAT: SIP: [0] processing INVITE message
Nov  6 07:02:45.385: NAT: SIP: [0] translated embedded address 192.168.0.14->192.168.1.51
Nov  6 07:02:45.385: NAT: SIP: [0] translate embedded port 5062->1029
Nov  6 07:02:45.385: NAT: SIP: [0] register:0 door_created:1
Nov  6 07:02:45.385: NAT: SIP: Contact header found
Nov  6 07:02:45.385: NAT: SIP: Trying to find expires parameter
Nov  6 07:02:45.385: NAT: SIP: [0] translated embedded address 192.168.0.14->192.168.1.51
Nov  6 07:02:45.385: NAT: SIP: [0] translate embedded port 5062->1029
Nov  6 07:02:45.385: NAT: SIP: [0] register:0 door_created:1
Nov  6 07:02:45.385: NAT: SIP: [0] register:0 door_created:0
Nov  6 07:02:45.385: NAT: SIP: [0] message body found
Nov  6 07:02:45.389: NAT: SIP: Media Lines present:1
Nov  6 07:02:45.389: NAT: SIP: old_sdp_len:306 new_sdp_len :327
Nov  6 07:02:45.421: NAT: SIP: [1] processing SIP/2.0 401 Unauthorized message
Nov  6 07:02:45.421: NAT: SIP: [1] translated embedded address 192.168.1.51->192.168.0.14
Nov  6 07:02:45.421: NAT: SIP: [1] translate embedded port 1029->5062
Nov  6 07:02:45.421: NAT: SIP: [1] register:0 door_created:1
Nov  6 07:02:45.421: NAT: SIP: [1] register:0 door_created:0
Nov  6 07:02:45.433: NAT: SIP: [0] processing ACK message
Nov  6 07:02:45.433: NAT: SIP: [0] translated embedded address 192.168.0.14->192.168.1.51
Nov  6 07:02:45.433: NAT: SIP: [0] translate embedded port 5062->1029
Nov  6 07:02:45.433: NAT: SIP: [0] register:0 door_created:1
Nov  6 07:02:45.525: NAT: SIP: [0] processing INVITE message
Nov  6 07:02:45.525: NAT: SIP: [0] translated embedded address 192.168.0.14->192.168.1.51
Nov  6 07:02:45.525: NAT: SIP: [0] translate embedded port 5062->1029
Nov  6 07:02:45.525: NAT: SIP: [0] register:0 door_created:1
Nov  6 07:02:45.525: NAT: SIP: Contact header found
Nov  6 07:02:45.525: NAT: SIP: Trying to find expires parameter
Nov  6 07:02:45.525: NAT: SIP: [0] translated embedded address 192.168.0.14->192.168.1.51
Nov  6 07:02:45.525: NAT: SIP: [0] translate embedded port 5062->1029
Nov  6 07:02:45.525: NAT: SIP: [0] register:0 door_created:1
Nov  6 07:02:45.525: NAT: SIP: [0] register:0 door_created:0
Nov  6 07:02:45.525: NAT: SIP: [0] message body found
Nov  6 07:02:45.525: NAT: SIP: Media Lines present:1
Nov  6 07:02:45.529: NAT: SIP: old_sdp_len:306 new_sdp_len :327
Nov  6 07:02:45.557: NAT: SIP: [1] processing SIP/2.0 100 Trying message
Nov  6 07:02:45.557: NAT: SIP: [1] translated embedded address 192.168.1.51->192.168.0.14
Nov  6 07:02:45.557: NAT: SIP: [1] translate embedded port 1029->5062
Nov  6 07:02:45.557: NAT: SIP: [1] register:0 door_created:1
Nov  6 07:02:45.557: NAT: SIP: [1] register:0 door_created:0
Nov  6 07:02:45.801: NAT: SIP: [1] processing SIP/2.0 403 Remote is disconnected (last code: 400) message
Nov  6 07:02:45.801: NAT: SIP: [1] translated embedded address 192.168.1.51->192.168.0.14
Nov  6 07:02:45.805: NAT: SIP: [1] translate embedded port 1029->5062
Nov  6 07:02:45.805: NAT: SIP: [1] register:0 door_created:1
Nov  6 07:02:45.805: NAT: SIP: [1] register:0 door_created:0
Nov  6 07:02:45.813: NAT: SIP: [0] processing ACK message
Nov  6 07:02:45.813: NAT: SIP: [0] translated embedded address 192.168.0.14->192.168.1.51
Nov  6 07:02:45.813: NAT: SIP: [0] translate embedded port 5062->1029
Nov  6 07:02:45.813: NAT: SIP: [0] register:0 door_created:1
Nov  6 07:02:47.677: NAT: SIP: [0] processing unrecognized message
Nov  6 07:02:56.616: NAT: SIP: [0] processing unrecognized message
Nov  6 07:03:05.680: NAT: SIP: [0] processing unrecognized message
Nov  6 07:03:06.431: NAT: SIP: [0] processing unrecognized message
up vote 0 down vote accepted

I have solved the issue.

It seems, SIP ALG is ON by default and when I disabled SIP ALG, VoIP clients started working properly:

enable
configure terminal
no ip nat service sip udp port 5060
no ip nat service sip tcp port 5060
  • You should accept your answer so that the question doesn't keep popping up forever, looking for an answer. – Ron Maupin Dec 6 at 15:27

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.