2

I'm trying to setup a home lab to study for a Cisco certification. My problem is I'm tired of having to physically plug the console into a different device every single time I want to configure it by CLI. So what I've decided to do is setup 5 simultaneous telnet sessions to these devices. (4 switches, 1 router).

So here is my topology:

PC --> Motorola Cable modem --> R1 --> S1 --> S2 --> S3 --> S4

So basically my cable modem will be connected to both my PC and R1. I'm doing it like this so I don't have to connect my PC to R1 and thus lose internet whenever I need to study.

My PC's IP is dynamically from the Motorola cable modem and R1's IP is statically assigned in the same network. This is subnet 192.168.0.0/24. R1's IP is 192.168.0.155

My PC is 192.168.0.2, the cable modem is 192.168.0.1

R1's interface that faces S1 is 192.168.254.254... S1 is 192.168.254.1... S2 is 192.168.254.2, etc.

I'm able to telnet into R1 without any issues from my PC thus eliminating the need for a console cable AND I can still access the internet at the same time. From R1 I'm able to ping all the switches in the LAN.

Here's the problem: I can't ping the switches from my PC. I just don't understand why that's possible. If I can ping R1 and R1 can ping the switches shouldn't R1 route to the LAN?

Someone please help me out with this. I'm stumped and I know I'm overlooking something simple. The object here is I want to eliminate the need for a console cable and be able to access the internet while simultaneous accessing my home lab.

1
  • R1 needs to be told to route the lab to the LAN. The current behavior makes perfect sense, in the absence of directions to to that - you can get into R1, and once in, you can see what it sees on other interfaces, but for it to actually route between interfaces, there has to be a route set up. – Ecnerwal Dec 13 '13 at 20:15
1

What you're overlooking is that your PC still has the default gateway of the cable modem and not R1. So all packets being sent to a subnet that isn't within that PC's LAN get sent to the cable modem which has no idea how to get to 192.168.254.0/24.

So you have two options if you want to also keep your internet access (thus, not change your default gateway):

  1. Set a static route on your cable modem to 192.168.254.0/24
  2. Set a static route on your PC to 192.168.254.0/24
1
  • Well how do I do option 2? I'm having trouble with option 1 – Lazaro D Dec 13 '13 at 20:52
0

Your cable modem is the problem, given the current topology. 192.168.254.0/24 is a different network than the one your PC is on (192.168.0.0/24). When you attempt to telnet to a switch, your request goes to your cable modem, as it's most likely set up as your PC's default gateway. Your cable modem has no knowledge of the 192.168.254.0/24 network, so it can't forward along to your router. Your router, however, has an interface on the 192.168.0.0/24 network, so that's why you can get to it just fine.

There's a couple of solutions - you could add a route to your PC, routing 192.168.254.0/24 to next-hop 192.168.0.155. That's kind of janky, though. The better solution would probably be to add that route to your cable modem.

2
  • I'm looking through the GUI of the cable modem and I don't see a way to add a static route at all. Any ideas? – Lazaro D Dec 13 '13 at 20:49
  • 1
    Just add it to your PC: For windows: route add <destination network> mask <destination subnet> <next hop> so it would be: route add 192.168.254.0 mask 255.255.255.0 192.168.0.155 – Michael May Dec 13 '13 at 20:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.