For someone who recently got their CCENT, I feel kind of stumped.

I have two switches, both are Cisco 3550s. I am using VLAN 1 as a management vlan and on S1, I assigned IP address 10.24.0.11/24 to VLAN 1. On S2, I assigned IP address 10.24.0.12/24 to VLAN 1.

Both VLANs on both switches have been issued the no shut command, all the normal stuff, I have done.

If I issue sh ip int brief, all ports are in VLAN 1 respective to each switch. Port 1 on S1 is plugged into Port 1 on S2. Both ports are in VLAN 1 and in the 10.24.0.0/24 subnet. Both ports, I have issued duplex full speed 100 on and did no shut. But both ports are down/down as if a cable is not connecting them.

I am stumped, what am I doing wrong? I have the switchport mode access command on both ports as well. Please help! Thank you for your time!

  • No link/act lights on the ports? – Ted Quanstrom Nov 8 at 2:07
  • Hi Ted, correct no link/act lights! Thanks. – ffgeek Nov 8 at 2:09
  • What happens if you plug the cable into different ports? Don't worry about vlan config yet, just try other ports. You can also try S1 P1 to another port on the same switch and the same thing with S2. If still no lights, try new cable. – Ted Quanstrom Nov 8 at 2:13
  • I can’t remember for sure, but the 3550 may not be auto sensing. Try a crossover cable. – Ron Trunk Nov 8 at 2:20
  • I did try a different cable between S1 and S2 and no change. By default all ports are in VLAN 1 so a vlan configuration on the port isn't necessary, right? I am just puzzled bc both ports should act as if they are in the same switch if they are connected and those ports are in vlan 1 in network 10.24.0.0 /24. I will troubleshoot some more tomorrow. – ffgeek Nov 8 at 2:21

Both ports, I have issued duplex full speed 100 on and did no shut.

Don't ever do that. Use autonegotiation at all times. If you later replace one of the switches the manually configured link will land on your feet. Why would you need manual configuration?

Depending on the switch, you might have also deactivated Auto MDI-X which would make a crossover cable necessary - this as a possible explanation for the failed link. Auto MDI-X takes care of choosing the correct port role - MDI-X for a switch port or MDI for a host/router port.

  • I agree although, some people still follow the Old-School Methodology of hard-coding.speed and duplex to avoid issues that could occur in the early versions autoconfiguration. Today there isn't generally a valid reason not to. – Ben Personick Nov 8 at 19:22

Based on the behavior, do you have AutoMDIX turned off, or is that not something the switches are doing? It sounds like when you would connect a straight through to like ports before auto-media was everywhere.

if you aren't using Auto MDIX or if you have disabled on the switch/port for some reason, try enabling it, or try running a cross-over between the ports, and see if the ports get link.

Also, attempt to see if the cable is bad

Based on your description and configuration, it looks like a Layer 1 issue rather than a network issue. As Zac mentioned, can you try to keep your speed and duplexity to auto rather than a predefined value? If that works, this will help us narrow down the issue.

You can also try to connect the ports on the switch. This is to find issues with NIC, ports, and cables.

Finally, also try to use some other ports and see how it goes

Thanks

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.