1

I have an Arista switch I'm trying to setup for learning. The router is a Netgate SG-3100 running pfSense 2.4.5.

I have two VLANs setup:

  • VLAN 22 - for normal browsing. Using the 10.0.22.0/24 subnet
  • VLAN 10 - management (e.g. iDRAC, switch OOB management etc.). This is Using the 10.0.10.0/24 subnet.

The switch has it's own dedicated out-of-band management port (management interface 1).

And there are of course the normal access ports on the switch.

I thought I'd take those ports, and divide them up between VLAN 10 and VLAN 22.

Port 1 is a trunk uplink port, with all VLANs allowed.

I connected a cable from the switch management port to one of the normal access ports (VLAN 10)

On the switch, I also configured a static IP for the management port, and also setup next hop (per this guide).

So I have:

interface Ethernet1
   switchport mode trunk
!
interface Ethernet2
!
interface Ethernet3
   switchport access vlan 10
....
interface Ethernet21
   switchport access vlan 22
!
....
interface Management1
   ip address 10.0.10.4/24
!
ip route 0.0.0.0/0 10.0.10.1
!
no ip routing
!

So the VLAN 10 ports are working fine - I can connect to them, and get a DHCP address, or use static addresses fine.

However, the VLAN 22 ports are not working - I was thinking this might be something to do with the ip route 0.0.0.0/0 10.0.10.1 - do I need to configure something else here to also allow 10.0.22.1/24?

UPDATE. To clarify, what I mean by VLAN 22 ports not working is - if I plug in a machine there, it will not get a DHCP lease, and if I put in the right IP address details manually, it isn't able to ping the gateway machine (10.0.22.1).

Here is the full config - https://gist.github.com/victorhooi/4145fbf03086a5fbcc9915f39c550d6e

3
  • You need to define "VLAN 22 ports are not working" - likely they do but with your setup, they're not connecting anywhere. What is your goal?
    – Zac67
    Nov 11, 2018 at 9:37
  • Sorry, you're right - I mean that I'm not getting a DHCP lease on those addresses, and even if I setup the correct IP details manually, I can't ping the gateway machine (10.0.22.1).
    – victorhooi
    Nov 11, 2018 at 20:30
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer.
    – Ron Maupin
    Dec 25, 2018 at 9:56

1 Answer 1

1

VLAN 22 requires some kind of connection to whatever DHCP server you've got. You either need to connect it directly with a dedicated link or a VLAN trunk, or to set up a helper address and DHCP relay on the switch.

Additionally, you need to connect your firewall to VLAN 22 (directly or by VLAN trunk) or provide a router in between, possibly a layer-3 switch.

2
  • Port 1 on the switch is a VLAN trunk uplink. It's going to another VLAN trunk port (Set to pass all VLANs, with native VLAN of 22 - although I assume that's not required here) - which is then connected to a pfSense router (acting as DHCP server).
    – victorhooi
    Nov 11, 2018 at 20:48
  • It appears you need to check connectivity as the DHCP server doesn't work. Likely, the VLAN trunk is failing. Alternatively, the trunk isn't set up correctly on the pfSense.
    – Zac67
    Nov 11, 2018 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.