3

I need to connect a Cisco 2900 router (172.16.0.0) to a Juniper SRX550 (172.16.128.1 & 172.16.192.1).

As far as I know, Cisco 2900 have no VLANs, so it's on VLAN 1. The Juniper SRX550 have multiple VLANs. Port 0/0/3 is VLAN 128, and port 0/0/4 is VLAN 192 on the Juniper SRX.

If I make port 0/0/5 a trunk port, and make it a member of VLANs 128 & 192, then connect it to an available port Cisco 2900 router, would they be able to talk to each other? I think I may have to do static routes if not.

  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Dec 25 '18 at 10:01
5

Matt!

That is achievable. You can pass trunk (multiple tagged vlan's) to Cisco router by using sub-interfaces.

Configuration example:

interface GigabitEthernet 0/0
  no ip address
  no shutdown

interface GigabitEthernet 0/0.128
  ! interface Gi0/0.128 - 128 here is just a number
  ! it can be any positive integer number

  encapsulation dot1q 128
  ! encapsulation dot1q 128 - here 128 is an actual vlan number

  ip address 10.128.0.1 255.255.255.0

interface GigabitEthernet 0/0.192
  encapsulation dot1q 192
  ip address 10.192.0.1 255.255.255.0
| improve this answer | |
  • ... and that works exactly this way across the whole product range of Cisco routers back to. the 2600 series (and some even older ones, too). Sometimes, 802.1q support would depend on having the support for tagging on the interface chip present in the system or module - so it could work for some interfaces of a router, but not for others. – Marc 'netztier' Luethi Nov 13 '18 at 15:17
1

As far as I know, Cisco 2900 have no VLANs[...]

I don't believe this is the case, I believe the 2900s did support vlan interfaces, at least our old 2911 did, I think it was the 2800s that did not support vlans.

In which case See Andre's Answer.

However lets assume this is true and go on to examine the latter part of the question:

[...]

If I make port 0/0/5 a trunk port, and make it a member of VLANs 128 & 192, then connect it to an available port Cisco 2900 router, would they be able to talk to each other?

No.

IF the Cisco 2900 can not support vlan interfaces, then you will not be able to utilize it by connecting it to a trunk port of the Juniper.

The trunk port will require all non native (and possibly native) vLAN traffic to be tagged.

vLAN tagging extends the normal frame to include a 802.1q header that is not part of the data payload, and comes prior to the ethernet type section.

Because of this, most devices which are not vLAN aware will consider the tagged frames inside the packets to be corrupt, and at the least will be unable to properly match the packets to their destinations.

ie. if you have a trunk port one or both of the vlans you have assigned to it will be tagged, and if the router does not understand vlan tagging it may not be able to interpret the frames correctly.

Even if it could get past the frame weirdness the 2900 would only have one IP address on it, not two, so it can not have a method to hair-pin turn the traffic on the interface since the two vlans are in separate segments.

Even if the 2900 could have two IP addresses in two separate ranges on a single interface, and ignored the vlan tag instead of considering it corrupt traffic and the juniper was set up to use those IPs as it's gateway, even in this scenario giving all benefits of the doubt and ignoring normal limitations of the router, in this scenario you could have your hairpinning, but the return traffic to the Juniper would be dropped by the Juniper for any vlan that was supposed to be tagged in the trunk (And again at least one vlan must be tagged in this trunk as only one vlan can be untagged )

So the best case scenario would be that one vlan's traffic could be routed to the other, with no return traffic ever being received, which would be of no real value.

So in no scenario can you really expect such a system to work.

If the 2900 is truly Dot1q unaware, then your only option is to use two interfaces with the vlans set as native vlans on the connected switch/router.

| improve this answer | |
  • 3
    If by "supporting VLANs" you actually refer to 802.1q tagged subinterfaces, then yes, 2800s supported them. If by "supporting VLANs", you are referring to the SVI (interface vlan) that could be configured to add an internal interface into to a L2-VLAN of an inserted switch module (EHWIC or NEM), then yes, the 2800s supported them, too. – Marc 'netztier' Luethi Nov 13 '18 at 15:12
  • Thanks, Mark, I thought the 2800s supported the vlans but wasn;t sure as I had which version router we used confused it was a 2811 after all not a 2911, just went EOL back in 2015 IIRC – Ben Personick Nov 19 '18 at 19:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.