1

I've followed the commands in this post: DSCP trust boundary

policy-map MARKDOWN
  class class-default
    set dscp ef

Interface Config:

interface gig 0/1
  service-policy input MARKDOWN

The commands went in fine on the Cisco switch I'm using, but it doesn't re-mark the DSCP field.

Switch I'm using is Cisco C2960 Ver 12.2(25r)SEE1.

  1. is this just a possible bug
  2. does this command work OK with other switches?
11
  • By default that switch with that code should remark all traffic to BE, which is what you seem to want to do, so what you are doing is really pointless. How are you determining the DSCP value on the packets leaving the switch?
    – Ron Maupin
    Commented Nov 12, 2018 at 19:10
  • You are marking the traffic as it's already marked.
    – user36472
    Commented Nov 12, 2018 at 19:11
  • sorry should be EF, not default,changed it. Commented Nov 12, 2018 at 19:12
  • You still need an access list to tell the switch what you want to mark. You cannot change the default class.
    – user36472
    Commented Nov 12, 2018 at 19:13
  • Check my post here: networkengineering.stackexchange.com/questions/42660/… Answer number two: Marking incomming traffic based on port/type
    – user36472
    Commented Nov 12, 2018 at 19:14

1 Answer 1

1

so I managed to figure it out....

Turn on QoS using switch(config)#mls qos command

the original example now changes DSCP values from 0 to 46 ....

Mind you, this is for everything, but I can refine it with an ACL.

edit: I also realise that this is one interface, with mls qos it will default other interfaces to 0.... I've fixed this with another policy map which is the same as in the original example, except with a different name and trust DSCP instead of set

1
  • You should accept your answer so that the question doesn't keep popping up forever, looking for an answer.
    – Ron Maupin
    Commented Dec 11, 2018 at 2:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.