2

I have a design like this enter image description here

But I'm receiving a lot of mismatch errors and it doesn't work at all. I tried to ping 10.0.0.1 to no avail.

I'm trying to configure the vlans on the switch 1 this way (the interface that goes to the router is f0/1):

Switch 1 configuration

configure terminal 
vlan 2 
name subnet1

vlan 3
name subnet2

interface fastEthernet 0/3
switchport mode access 
switchport access vlan 3
exit

interface fastEthernet 0/2 
switchport mode access
switchport access vlan 2 
exit

interface fastEthernet 0/1 
switchport mode trunk
exit

Switch(config)#interface vlan 2
Switch(config-if)#ip address 192.168.1.3 255.255.255.0
Switch(config-if)#no shutdown

Switch(config)#interface vlan 3
Switch(config-if)#ip address 192.168.2.3 255.255.255.0
Switch(config-if)#no shutdown

Switch 11

interface fastEthernet 0/1
switchport mode trunk 
exit

**ALSO SAME CONFIG AS MAIN ROUTER WITH VLAN BEING EQUAL AS CONFIGURED BEFORE.**

Update: Router config.

Router>enable 
Router#configure terminal 
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 10.0.0.1 255.255.255.0
Router(config-if)#no shutdown

Router(config)#interface fastEthernet 0/0.2
Router(config-subif)#
Router(config-subif)#encapsulation dot1Q 2
Router(config-subif)#ip address 192.168.1.2 255.255.255.0
Router(config-subif)#

Router(config)#interface fastEthernet 0/0.3
Router(config-subif)#
Router(config-subif)#encapsulation dot1Q 3
Router(config-subif)#ip address 192.168.2.2 255.255.255.0
Router(config-subif)#

Router(config)#interface FastEthernet0/0
Router(config-if)#ip helper 192.168.1.4
Router(config-if)#interface FastEthernet0/0.2
Router(config-subif)#ip helper 192.168.1.4
Router(config-subif)#interface FastEthernet0/0.3
Router(config-subif)#ip helper 192.168.1.4
Router(config-subif)#

I tried to also configure Switch 11 with a f0/1 trunk mode, and all the other ports to a vlan with the address 192.168.1.4

Any suggestion?

Update 1: Errors are switches Native VLAN mismatch type switch11 f0/1 with Switch1 f0/2

Update 2: I have v2 RIP routing on the router with all the related IPs.

Update 3: I have connectivity between PCs and PC to router. Still get switch errors/warnings:

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/1 (1), with Switch FastEthernet0/2 (2).

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/3 (3), with Switch FastEthernet0/1 (1).

Update 4:

Can't seem to get the DHCP server to work. I used the IP helper command on the router f0/0 interface and subinterfaces but doesn't work.

Update 5: Show command for switch 1 f0/2 (now named switch 0. The one connected to the router):

Switch>show interfaces fastEthernet 0/2 switchport
Name: Fa0/2
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 2 (subnet1)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: All
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Update 6: Got rid of the warnings (creating the vlans on the subnet switches and assigning the vlan to the trunk)! Now the only issue is I can't get the DHCP to work.

Update note: Remember there's connectivity with the Router subinterfaces 0.2 or 0.3. Ex: ping from PC to 192.168.1.2 works and between PCs on different subnets

However the errors won't stop and can't seem to get the DHCP server to work.

I used this tutorial but it only has a main switch

FINAL UPDATE: Seems like what I did was the only possible thing according to this post "I'm afraid you can't use ip helper-address to assign IP addresses to PCs from a secondary address scope."

So I'd need a L3 router in order to do that. I guess this is all and I'll ad a L3 router.

  • Welcome on this Stack Exchanges site. If you receive errors, please include them in your question. Also, please be specific in what 'does not work properly' means. – Teun Vink Nov 20 '18 at 14:22
  • Ok I updated the post. Please check it again. – Cliff Nov 20 '18 at 14:28
  • 2
    Looking on your diagram I can tell that this will not work. At least, you will be not able to route networks on 2960 switch, as it's only have Layer-2 functionality. Instead, you can configure your link to 2811 as trunk, including in it VLANs for subnet 192.168.1.0/24 and 192.168.2.0/24 and terminating them on 2811 as subinterfaces. – Andrey Prokhorov Nov 20 '18 at 14:30
  • We need to see the configurations of the other switches. But make sure the switch-to-switch links are all set to "switchport mode trunk" – Ron Trunk Nov 20 '18 at 14:30
  • 1
    We can help you solve this faster if you include the full switch and router configurations, not just bits and pieces. Also, when you say you can't ping, where are you pinging from? – Ron Trunk Nov 20 '18 at 14:52
1

This can't work.

The single router interface needs to be configured as a VLAN trunk for VLAN IDs 1(?) and 2. The switches must use VLAN trunking on their interconnects and on that to the router.

You need to make sure that each subnet provides proper connectivity from the end node all the way to the router.

On the router, each VLAN subinterface needs to be configured with an IP address from the subnet. In your config, 192.168.2.0/24 is missing. 10.0.0.1/24 is bound but doesn't seem to provide any connectivity anywhere.

RIP doesn't hurt but doesn't do anything either with just one router.

  • Please see the updated post. Switch to switch and switch to router interfaces are configured as trunk. Also the subinterfaces have the right subnet IP as the configuration shows. – Cliff Nov 20 '18 at 16:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.